Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование с нарастающим итогом (упрощение формулы) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование с нарастающим итогом (упрощение формулы) (Формулы/Formulas)
Суммирование с нарастающим итогом (упрощение формулы)
Rodger Дата: Вторник, 12.07.2016, 16:25 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток!

Помогите пожалуйста упростить формулу, пример прилагается.
К сообщению приложен файл: 0920582.xlsx(34Kb)
 
Ответить
СообщениеДоброго времени суток!

Помогите пожалуйста упростить формулу, пример прилагается.

Автор - Rodger
Дата добавления - 12.07.2016 в 16:25
_Boroda_ Дата: Вторник, 12.07.2016, 16:41 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Для наименований
Код
=СУММЕСЛИМН(Р_П_Н[[Выручка без НДС ]];Р_П_Н[Наименование];C4;Р_П_Н[Квартал];ЕСЛИ(F$1="с н/и";"<=";"")&E$1;Р_П_Н[Вид данных];D$3)

Для заготовок
Код
=СУММПРОИЗВ(D$4:D$15*(B16=ПРОСМОТР(СТРОКА(B$4:B$15);СТРОКА(B$4:B$15)/(B$4:B$15<>"");B$4:B$15)))
К сообщению приложен файл: 0920582_1.xlsx(32Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Для наименований
Код
=СУММЕСЛИМН(Р_П_Н[[Выручка без НДС ]];Р_П_Н[Наименование];C4;Р_П_Н[Квартал];ЕСЛИ(F$1="с н/и";"<=";"")&E$1;Р_П_Н[Вид данных];D$3)

Для заготовок
Код
=СУММПРОИЗВ(D$4:D$15*(B16=ПРОСМОТР(СТРОКА(B$4:B$15);СТРОКА(B$4:B$15)/(B$4:B$15<>"");B$4:B$15)))

Автор - _Boroda_
Дата добавления - 12.07.2016 в 16:41
Rodger Дата: Вторник, 12.07.2016, 16:49 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, _Boroda_, Да, вроде все так. Спасибо большое!
 
Ответить
Сообщение_Boroda_, _Boroda_, Да, вроде все так. Спасибо большое!

Автор - Rodger
Дата добавления - 12.07.2016 в 16:49
Rodger Дата: Среда, 13.07.2016, 08:26 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
А еще вот такой вопрос: как поменяется формула, если кварталы поменять на месяца?
 
Ответить
СообщениеА еще вот такой вопрос: как поменяется формула, если кварталы поменять на месяца?

Автор - Rodger
Дата добавления - 13.07.2016 в 08:26
китин Дата: Среда, 13.07.2016, 08:38 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3723
Репутация: 587 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Да в принципе никак, если вы соответствующим образом реорганизуете свою таблицу. Поменяете список в проверке данных и будете ставить в таблице с датами не 1 кв а 01.01.2016 в формате Дата ММММ


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДа в принципе никак, если вы соответствующим образом реорганизуете свою таблицу. Поменяете список в проверке данных и будете ставить в таблице с датами не 1 кв а 01.01.2016 в формате Дата ММММ

Автор - китин
Дата добавления - 13.07.2016 в 08:38
Rodger Дата: Среда, 13.07.2016, 08:49 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, ну да, точно, спасибо.
 
Ответить
Сообщениекитин, ну да, точно, спасибо.

Автор - Rodger
Дата добавления - 13.07.2016 в 08:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование с нарастающим итогом (упрощение формулы) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!