Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод в таблице числовых значений зависящих от нескольких пе - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод в таблице числовых значений зависящих от нескольких пе (Формулы/Formulas)
Вывод в таблице числовых значений зависящих от нескольких пе
Moklaud Дата: Среда, 13.07.2016, 12:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
В составленной таблице (Определение частного коэффициента) нужно подобрать значение Б из таблицы значений, которое зависит от интенсивности (все выделено цветами). Нужно составить формулу отображения данных в первичной таблице, чтобы при изменении значения интенсивности, менялись значения коэффициентов на табличные.
К сообщению приложен файл: 8583902.xls(32Kb)


Сообщение отредактировал Moklaud - Среда, 13.07.2016, 12:37
 
Ответить
СообщениеВ составленной таблице (Определение частного коэффициента) нужно подобрать значение Б из таблицы значений, которое зависит от интенсивности (все выделено цветами). Нужно составить формулу отображения данных в первичной таблице, чтобы при изменении значения интенсивности, менялись значения коэффициентов на табличные.

Автор - Moklaud
Дата добавления - 13.07.2016 в 12:36
китин Дата: Среда, 13.07.2016, 12:37 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ВПР. вот так вот банально ответил


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 13.07.2016, 12:38
 
Ответить
СообщениеВПР. вот так вот банально ответил

Автор - китин
Дата добавления - 13.07.2016 в 12:37
ArkaIIIa Дата: Среда, 13.07.2016, 12:37 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 858
Репутация: 114 ±
Замечаний: 0% ±

2010
Я так понимаю ИНДЕКС+ПОИСКПОЗ.
Файл приложите.
 
Ответить
СообщениеЯ так понимаю ИНДЕКС+ПОИСКПОЗ.
Файл приложите.

Автор - ArkaIIIa
Дата добавления - 13.07.2016 в 12:37
ArkaIIIa Дата: Среда, 13.07.2016, 12:43 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 858
Репутация: 114 ±
Замечаний: 0% ±

2010
Эм, а логика переноса значений на чем завязана (на цвете?)? В общем, руками впишите, что должно быть в Б.


Сообщение отредактировал ArkaIIIa - Среда, 13.07.2016, 12:56
 
Ответить
СообщениеЭм, а логика переноса значений на чем завязана (на цвете?)? В общем, руками впишите, что должно быть в Б.

Автор - ArkaIIIa
Дата добавления - 13.07.2016 в 12:43
китин Дата: Среда, 13.07.2016, 12:49 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а вот такие вот костылики
Код
=ИНДЕКС($J$5:$J$19;ПОИСКПОЗ(--ЛЕВБ(ПРОСМОТР(--ЛЕВБ(A5;ПОИСК("+";A5)-1);{0;6;11};$C$18:$C$19);1);$I$5:$I$19;0))
К сообщению приложен файл: 123.xls(34Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа вот такие вот костылики
Код
=ИНДЕКС($J$5:$J$19;ПОИСКПОЗ(--ЛЕВБ(ПРОСМОТР(--ЛЕВБ(A5;ПОИСК("+";A5)-1);{0;6;11};$C$18:$C$19);1);$I$5:$I$19;0))

Автор - китин
Дата добавления - 13.07.2016 в 12:49
ArkaIIIa Дата: Среда, 13.07.2016, 12:52 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 858
Репутация: 114 ±
Замечаний: 0% ±

2010
Ну да... подлиннее, чем у Китина)
Код
=ЕСЛИ(И(--ЛЕВБ(A5;ПОИСК("+";A5;1)-1)>=--ЛЕВБ($A$18;1);--ЛЕВБ(A5;ПОИСК("+";A5;1)-1)<=--(ЛЕВБ(ПРАВБ($A$18;4);1)));ПРОСМОТР($C$18/1000;$I$8:$I$9;$J$8:$J$9);ПРОСМОТР($C$19/1000;$I$8:$I$9;$J$8:$J$9))
 
Ответить
СообщениеНу да... подлиннее, чем у Китина)
Код
=ЕСЛИ(И(--ЛЕВБ(A5;ПОИСК("+";A5;1)-1)>=--ЛЕВБ($A$18;1);--ЛЕВБ(A5;ПОИСК("+";A5;1)-1)<=--(ЛЕВБ(ПРАВБ($A$18;4);1)));ПРОСМОТР($C$18/1000;$I$8:$I$9;$J$8:$J$9);ПРОСМОТР($C$19/1000;$I$8:$I$9;$J$8:$J$9))

Автор - ArkaIIIa
Дата добавления - 13.07.2016 в 12:52
_Boroda_ Дата: Среда, 13.07.2016, 12:59 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А у меня такие
Код
=ВПР(ПРОСМОТР(--ЛЕВБ(A5;ПОИСК("+";A5)-1);--ЛЕВБ(A$18:A$29;ПОИСК("+";A$18:A$29)-1);C$18:C$29)/1000;I$5:J$19;2)

Код
=ВПР(ПРОСМОТР(--ПОДСТАВИТЬ(A5;"+";",");--ЛЕВБ(A$18:A$29;ПОИСК("+";A$18:A$29)-1);C$18:C$29)/1000;I$5:J$19;2)

После строки 20 можно еще значения дописывать


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА у меня такие
Код
=ВПР(ПРОСМОТР(--ЛЕВБ(A5;ПОИСК("+";A5)-1);--ЛЕВБ(A$18:A$29;ПОИСК("+";A$18:A$29)-1);C$18:C$29)/1000;I$5:J$19;2)

Код
=ВПР(ПРОСМОТР(--ПОДСТАВИТЬ(A5;"+";",");--ЛЕВБ(A$18:A$29;ПОИСК("+";A$18:A$29)-1);C$18:C$29)/1000;I$5:J$19;2)

После строки 20 можно еще значения дописывать

Автор - _Boroda_
Дата добавления - 13.07.2016 в 12:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод в таблице числовых значений зависящих от нескольких пе (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!