Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/узнать название столбика с наибольшим значением - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » узнать название столбика с наибольшим значением (Формулы/Formulas)
узнать название столбика с наибольшим значением
Goblinax Дата: Четверг, 14.07.2016, 02:16 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день, уважаемые знатоки екселя!

нужно узнать название столбика с наибольшим значением, как в примере. Наверное это ерундовая задача, но весь вечер не могу с ней разобраться(. Заранее больше спасибо!
К сообщению приложен файл: 7287752.xlsx(8Kb)
 
Ответить
СообщениеДобрый день, уважаемые знатоки екселя!

нужно узнать название столбика с наибольшим значением, как в примере. Наверное это ерундовая задача, но весь вечер не могу с ней разобраться(. Заранее больше спасибо!

Автор - Goblinax
Дата добавления - 14.07.2016 в 02:16
krosav4ig Дата: Четверг, 14.07.2016, 02:26 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1362
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007, 2013
так нужно?
Код
=ГПР(МАКС(B3:E3);ЕСЛИ({1:0};B3:E3;B$2:E$2);2;)
К сообщению приложен файл: 3230104.xlsx(9Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Четверг, 14.07.2016, 02:33
 
Ответить
Сообщениетак нужно?
Код
=ГПР(МАКС(B3:E3);ЕСЛИ({1:0};B3:E3;B$2:E$2);2;)

Автор - krosav4ig
Дата добавления - 14.07.2016 в 02:26
_Boroda_ Дата: Четверг, 14.07.2016, 02:52 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ПРОСМОТР(;-1/(МАКС(B3:E3)=B3:E3);B$2:E$2)

Ну и классика
Код
=ИНДЕКС(B$2:E$2;ПОИСКПОЗ(МАКС(B3:E3);B3:E3;))
К сообщению приложен файл: 7287752_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ПРОСМОТР(;-1/(МАКС(B3:E3)=B3:E3);B$2:E$2)

Ну и классика
Код
=ИНДЕКС(B$2:E$2;ПОИСКПОЗ(МАКС(B3:E3);B3:E3;))

Автор - _Boroda_
Дата добавления - 14.07.2016 в 02:52
китин Дата: Четверг, 14.07.2016, 07:30 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вариант с ПРОСМОТР (другой)
Код
=ПРОСМОТР(МАКС(B3:E3);B3:E3;$B$2:$E$2)

неправильно.

[p.s.]а если у кого то две пятерки, ну попался ботан , тогда что выводить?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 14.07.2016, 08:20
 
Ответить
Сообщениевариант с ПРОСМОТР (другой)
Код
=ПРОСМОТР(МАКС(B3:E3);B3:E3;$B$2:$E$2)

неправильно.

[p.s.]а если у кого то две пятерки, ну попался ботан , тогда что выводить?

Автор - китин
Дата добавления - 14.07.2016 в 07:30
китин Дата: Четверг, 14.07.2016, 07:38 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а если у кого то две пятерки


тогда формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$E$2;;НАИМЕНЬШИЙ(ЕСЛИ($B3:$E3=МАКС($B3:$E3);СТОЛБЕЦ($B$2:$E$2)-1);СТОЛБЕЦ(A1)));"")
К сообщению приложен файл: 123456.xlsx(9Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
а если у кого то две пятерки


тогда формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$E$2;;НАИМЕНЬШИЙ(ЕСЛИ($B3:$E3=МАКС($B3:$E3);СТОЛБЕЦ($B$2:$E$2)-1);СТОЛБЕЦ(A1)));"")

Автор - китин
Дата добавления - 14.07.2016 в 07:38
_Boroda_ Дата: Четверг, 14.07.2016, 07:40 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
=ПРОСМОТР(МАКС(B3:E3);B3:E3;$B$2:$E$2)

Игорь, поставь в В3 цифру 8.
Для такого варианта нужна сортировка по B3:E3


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
=ПРОСМОТР(МАКС(B3:E3);B3:E3;$B$2:$E$2)

Игорь, поставь в В3 цифру 8.
Для такого варианта нужна сортировка по B3:E3

Автор - _Boroda_
Дата добавления - 14.07.2016 в 07:40
китин Дата: Четверг, 14.07.2016, 08:21 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Мдя Саша точно. не проснулся, накосячил


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеМдя Саша точно. не проснулся, накосячил

Автор - китин
Дата добавления - 14.07.2016 в 08:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » узнать название столбика с наибольшим значением (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!