Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Преобразовать данные в таблице для создания сводной таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразовать данные в таблице для создания сводной таблицы (Формулы/Formulas)
Преобразовать данные в таблице для создания сводной таблицы
Viper25 Дата: Четверг, 14.07.2016, 16:33 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 4 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте.
Есть таблица с данными.
Подскажите, пожалуйста, как ее преобразовать, чтобы получилась маленькая сводная.
Дата Сумма
01.07.16 22 575,90
02.07.16 5 100,00
03.07.16 9 353,60
Уже крутил и так, и этак.

Спасибо.
К сообщению приложен файл: 8581291.xlsx(11Kb)
 
Ответить
СообщениеЗдравствуйте.
Есть таблица с данными.
Подскажите, пожалуйста, как ее преобразовать, чтобы получилась маленькая сводная.
Дата Сумма
01.07.16 22 575,90
02.07.16 5 100,00
03.07.16 9 353,60
Уже крутил и так, и этак.

Спасибо.

Автор - Viper25
Дата добавления - 14.07.2016 в 16:33
Manyasha Дата: Четверг, 14.07.2016, 16:45 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1582
Репутация: 659 ±
Замечаний: 0% ±

Excel 2007, 2010
Viper25, для Вашего примера можно так:
даты
Код
=ИНДЕКС($B$1:$M$1;1;4*СТРОКА(A1)-3)

сумма
Код
=ИНДЕКС($B$5:$M$5;1;4*СТРОКА(A1))
К сообщению приложен файл: 8581291-1.xlsx(11Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеViper25, для Вашего примера можно так:
даты
Код
=ИНДЕКС($B$1:$M$1;1;4*СТРОКА(A1)-3)

сумма
Код
=ИНДЕКС($B$5:$M$5;1;4*СТРОКА(A1))

Автор - Manyasha
Дата добавления - 14.07.2016 в 16:45
_Boroda_ Дата: Четверг, 14.07.2016, 16:53 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9345
Репутация: 3921 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариантик
Код
=НАИМЕНЬШИЙ(B$1:M$1;СТРОКА(A1))

Код
=ПРОСМОТР(G14;B$1:M$1;E$5:M$5)


Вернее, так
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(B$1:Z$1;СТРОКА(A1));"")

Код
=ЕСЛИОШИБКА(ПРОСМОТР(G14;B$1:W$1;E$5:Z$5);"")
К сообщению приложен файл: 8581291_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариантик
Код
=НАИМЕНЬШИЙ(B$1:M$1;СТРОКА(A1))

Код
=ПРОСМОТР(G14;B$1:M$1;E$5:M$5)


Вернее, так
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(B$1:Z$1;СТРОКА(A1));"")

Код
=ЕСЛИОШИБКА(ПРОСМОТР(G14;B$1:W$1;E$5:Z$5);"")

Автор - _Boroda_
Дата добавления - 14.07.2016 в 16:53
Viper25 Дата: Пятница, 15.07.2016, 14:39 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 4 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, подскажите, почему формула ЕСЛИОШИБКА(ПРОСМОТР(G14;B$1:W$1;B$5:Z$5);"") дает неправильный результат.
 
Ответить
Сообщение_Boroda_, подскажите, почему формула ЕСЛИОШИБКА(ПРОСМОТР(G14;B$1:W$1;B$5:Z$5);"") дает неправильный результат.

Автор - Viper25
Дата добавления - 15.07.2016 в 14:39
_Boroda_ Дата: Пятница, 15.07.2016, 15:02 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9345
Репутация: 3921 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А у Вас вон в той ячейке данные не как в этой, а более другие


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА у Вас вон в той ячейке данные не как в этой, а более другие

Автор - _Boroda_
Дата добавления - 15.07.2016 в 15:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразовать данные в таблице для создания сводной таблицы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!