Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как вывести список из таблицы согласно определенному условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как вывести список из таблицы согласно определенному условию (Формулы/Formulas)
Как вывести список из таблицы согласно определенному условию
enzo Дата: Среда, 20.07.2016, 13:48 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Уважаемые, добрый день! Есть у меня таблица перечня позиций. Я беру фильтром выбираю определенное условие (столбец постоянный к примеру "Группа крови" = 2) , и вывожу список для распечатки. Делал это фильтром , потом копировал значения удалял столбцы... Попросили автоматизировать)) Хотят чтобы была ячейка "Группа крови", куда напишут цифру 2 и из таблицы будет вытягиваться все позиции с группой 2, но с меньшим определенными столбцами.

Пока ломаю голову как можно сделать это...
 
Ответить
СообщениеУважаемые, добрый день! Есть у меня таблица перечня позиций. Я беру фильтром выбираю определенное условие (столбец постоянный к примеру "Группа крови" = 2) , и вывожу список для распечатки. Делал это фильтром , потом копировал значения удалял столбцы... Попросили автоматизировать)) Хотят чтобы была ячейка "Группа крови", куда напишут цифру 2 и из таблицы будет вытягиваться все позиции с группой 2, но с меньшим определенными столбцами.

Пока ломаю голову как можно сделать это...

Автор - enzo
Дата добавления - 20.07.2016 в 13:48
китин Дата: Среда, 20.07.2016, 13:49 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а файл с группой крови на рукаве?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 20.07.2016, 14:13
 
Ответить
Сообщениеа файл с группой крови на рукаве?

Автор - китин
Дата добавления - 20.07.2016 в 13:49
Udik Дата: Среда, 20.07.2016, 13:51 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1209
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
без файла сложно отвечать. А так - например, расширенный фильтр.


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениебез файла сложно отвечать. А так - например, расширенный фильтр.

Автор - Udik
Дата добавления - 20.07.2016 в 13:51
enzo Дата: Среда, 20.07.2016, 13:55 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Извиняюсь))) прикладываю!
К сообщению приложен файл: 2128895.xlsx(14Kb)
 
Ответить
СообщениеИзвиняюсь))) прикладываю!

Автор - enzo
Дата добавления - 20.07.2016 в 13:55
sboy Дата: Среда, 20.07.2016, 14:04 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 196
Репутация: 48 ±
Замечаний: 0% ±

Excel 2007
[offtop] enzo, Очень творческий пример)))) улыбался от души) почему у всех телка Маша?
 
Ответить
Сообщение[offtop] enzo, Очень творческий пример)))) улыбался от души) почему у всех телка Маша?

Автор - sboy
Дата добавления - 20.07.2016 в 14:04
китин Дата: Среда, 20.07.2016, 14:07 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица3[имя];НАИМЕНЬШИЙ(ЕСЛИ(Таблица3[группа крови]=$R$1;СТРОКА(Таблица3[имя])-2);СТРОКА(A1)));"")
К сообщению приложен файл: 333333.xlsx(16Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 20.07.2016, 14:11
 
Ответить
Сообщениеформула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица3[имя];НАИМЕНЬШИЙ(ЕСЛИ(Таблица3[группа крови]=$R$1;СТРОКА(Таблица3[имя])-2);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 20.07.2016 в 14:07
Udik Дата: Среда, 20.07.2016, 14:43 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1209
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
Расширеный фильтр с макросом
К сообщению приложен файл: 0t.xlsm(24Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеРасширеный фильтр с макросом

Автор - Udik
Дата добавления - 20.07.2016 в 14:43
enzo Дата: Среда, 20.07.2016, 14:49 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
китин, Спасибо то что нужно)!
 
Ответить
Сообщениекитин, Спасибо то что нужно)!

Автор - enzo
Дата добавления - 20.07.2016 в 14:49
enzo Дата: Среда, 20.07.2016, 14:52 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
sboy, не знаю , друг отправил, чтоб сделал я, видимо Маша его обидела)
 
Ответить
Сообщениеsboy, не знаю , друг отправил, чтоб сделал я, видимо Маша его обидела)

Автор - enzo
Дата добавления - 20.07.2016 в 14:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как вывести список из таблицы согласно определенному условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!