Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование по определенным условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по определенным условиям (Формулы/Formulas)
Суммирование по определенным условиям
julytt Дата: Четверг, 21.07.2016, 10:57 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

2007
Подскажите, пожалуйста, как решить задачку.
В ячейках J и K меняются условия (периоды даты) и в зависимости от них необходимо посчитать СУММУ столбец С
К сообщению приложен файл: __.xls(30Kb)


Все женщины ангелы, но когда им обрезают крылья они летают на метле.

Сообщение отредактировал julytt - Четверг, 21.07.2016, 10:59
 
Ответить
СообщениеПодскажите, пожалуйста, как решить задачку.
В ячейках J и K меняются условия (периоды даты) и в зависимости от них необходимо посчитать СУММУ столбец С

Автор - julytt
Дата добавления - 21.07.2016 в 10:57
китин Дата: Четверг, 21.07.2016, 11:19 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а вот такая вот формулка
Код
=СУММПРОИЗВ($C$2:$C$25*(--(ТЕКСТ($B$2:$B$25&"."&$A$2:$A$25;"ММ.ГГГГ"))>=--(ТЕКСТ($J$5;"ММ.ГГГГ")))*(--(ТЕКСТ($B$2:$B$25&"."&$A$2:$A$25;"ММ.ГГГГ"))<=--(ТЕКСТ($K$5;"ММ.ГГГГ"))))
К сообщению приложен файл: 234.xls(36Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа вот такая вот формулка
Код
=СУММПРОИЗВ($C$2:$C$25*(--(ТЕКСТ($B$2:$B$25&"."&$A$2:$A$25;"ММ.ГГГГ"))>=--(ТЕКСТ($J$5;"ММ.ГГГГ")))*(--(ТЕКСТ($B$2:$B$25&"."&$A$2:$A$25;"ММ.ГГГГ"))<=--(ТЕКСТ($K$5;"ММ.ГГГГ"))))

Автор - китин
Дата добавления - 21.07.2016 в 11:19
Manyasha Дата: Четверг, 21.07.2016, 11:20 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 662 ±
Замечаний: 0% ±

Excel 2007, 2010
еще один вариант:
Код
=СУММПРОИЗВ((ДАТА(A2:A25;B2:B25;1)>=J5)*(ДАТА(A2:A25;B2:B25;1)<=K5)*C2:C25)
К сообщению приложен файл: -1.xls(36Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениееще один вариант:
Код
=СУММПРОИЗВ((ДАТА(A2:A25;B2:B25;1)>=J5)*(ДАТА(A2:A25;B2:B25;1)<=K5)*C2:C25)

Автор - Manyasha
Дата добавления - 21.07.2016 в 11:20
AlexM Дата: Четверг, 21.07.2016, 11:23 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Код
=СУММПРОИЗВ((--(B2:B25&"."&A2:A25)>=J5)*(--(B2:B25&"."&A2:A25)<=K5)*C2:C25)
К сообщению приложен файл: julytt.xls(36Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((--(B2:B25&"."&A2:A25)>=J5)*(--(B2:B25&"."&A2:A25)<=K5)*C2:C25)

Автор - AlexM
Дата добавления - 21.07.2016 в 11:23
Pelena Дата: Четверг, 21.07.2016, 11:27 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9852
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Вариант, похожий на Маринин, но если даты произвольные, а не первый и последний день месяца
Код
=СУММПРОИЗВ((ДАТА($A$2:$A$25;$B$2:$B$25;1)>=ДАТА(ГОД($J$5);МЕСЯЦ($J$5);1))*(ДАТАМЕС(ДАТА($A$2:$A$25;$B$2:$B$25;1);1)-1<=КОНМЕСЯЦА($K$5;0))*$C$2:$C$25)

можно короче
Код
=СУММПРОИЗВ((ДАТА($A$2:$A$25;$B$2:$B$25;ДЕНЬ($J$5))>=$J$5)*(ДАТА($A$2:$A$25;$B$2:$B$25;ДЕНЬ(K5))<=$K$5)*$C$2:$C$25)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант, похожий на Маринин, но если даты произвольные, а не первый и последний день месяца
Код
=СУММПРОИЗВ((ДАТА($A$2:$A$25;$B$2:$B$25;1)>=ДАТА(ГОД($J$5);МЕСЯЦ($J$5);1))*(ДАТАМЕС(ДАТА($A$2:$A$25;$B$2:$B$25;1);1)-1<=КОНМЕСЯЦА($K$5;0))*$C$2:$C$25)

можно короче
Код
=СУММПРОИЗВ((ДАТА($A$2:$A$25;$B$2:$B$25;ДЕНЬ($J$5))>=$J$5)*(ДАТА($A$2:$A$25;$B$2:$B$25;ДЕНЬ(K5))<=$K$5)*$C$2:$C$25)

Автор - Pelena
Дата добавления - 21.07.2016 в 11:27
julytt Дата: Четверг, 21.07.2016, 11:54 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

2007
Огромное всем спасибо.
Manyasha хорошая простая формула, почему сама не додумалась %) не пойму :)
Спасибо всем за помощь.


Все женщины ангелы, но когда им обрезают крылья они летают на метле.
 
Ответить
СообщениеОгромное всем спасибо.
Manyasha хорошая простая формула, почему сама не додумалась %) не пойму :)
Спасибо всем за помощь.

Автор - julytt
Дата добавления - 21.07.2016 в 11:54
_Boroda_ Дата: Четверг, 21.07.2016, 11:56 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9354
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММПРОИЗВ((((B2:B25&-A2:A25)-J5)*(K5-(B2:B25&-A2:A25))>=0)*C2:C25)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ((((B2:B25&-A2:A25)-J5)*(K5-(B2:B25&-A2:A25))>=0)*C2:C25)

Автор - _Boroda_
Дата добавления - 21.07.2016 в 11:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по определенным условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!