Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать сумму до указанной даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сумму до указанной даты (Формулы/Formulas)
Посчитать сумму до указанной даты
drugojandrew Дата: Четверг, 28.07.2016, 18:08 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте.
Нужно посчитать сумму по указанную дату, причем если я в таблицу дописываю другие даты/числа, формула не должна изменяться, т.е. должна учитывать диапазон всего столбца. Подскажите, пожалуйста. Пример приложил.
К сообщению приложен файл: 8783884.xls(25Kb)
 
Ответить
СообщениеЗдравствуйте.
Нужно посчитать сумму по указанную дату, причем если я в таблицу дописываю другие даты/числа, формула не должна изменяться, т.е. должна учитывать диапазон всего столбца. Подскажите, пожалуйста. Пример приложил.

Автор - drugojandrew
Дата добавления - 28.07.2016 в 18:08
_Boroda_ Дата: Четверг, 28.07.2016, 18:15 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Если даты не по порядку
Код
=СУММЕСЛИ(A2:ИНДЕКС(A:A;СЧЁТЗ(A:A));"<="&D1;B2:ИНДЕКС(B:B;СЧЁТЗ(A:A)))

Если по порядку
Код
=СУММ(B1:ИНДЕКС(B:B;ПОИСКПОЗ(D1;A:A;)))

Тоже не пор порядку, но СУММЕСЛИ по всему столбцу не есть хорошо
Код
=СУММЕСЛИ(A:A;"<="&D1;B:B)
К сообщению приложен файл: 8783884_1.xls(24Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Если даты не по порядку
Код
=СУММЕСЛИ(A2:ИНДЕКС(A:A;СЧЁТЗ(A:A));"<="&D1;B2:ИНДЕКС(B:B;СЧЁТЗ(A:A)))

Если по порядку
Код
=СУММ(B1:ИНДЕКС(B:B;ПОИСКПОЗ(D1;A:A;)))

Тоже не пор порядку, но СУММЕСЛИ по всему столбцу не есть хорошо
Код
=СУММЕСЛИ(A:A;"<="&D1;B:B)

Автор - _Boroda_
Дата добавления - 28.07.2016 в 18:15
Nic70y Дата: Четверг, 28.07.2016, 18:19 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3480
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММЕСЛИ(A:A;"<="&D2;B:B)
может и так сойдет?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММЕСЛИ(A:A;"<="&D2;B:B)
может и так сойдет?

Автор - Nic70y
Дата добавления - 28.07.2016 в 18:19
drugojandrew Дата: Четверг, 28.07.2016, 18:22 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=СУММЕСЛИ(A2:ИНДЕКС(A:A;СЧЁТЗ(A:A));"<="&D1;B2:ИНДЕКС(B:B;СЧЁТЗ(A:A)))

Говорит "ошибка в формуле"
 
Ответить
Сообщение
=СУММЕСЛИ(A2:ИНДЕКС(A:A;СЧЁТЗ(A:A));"<="&D1;B2:ИНДЕКС(B:B;СЧЁТЗ(A:A)))

Говорит "ошибка в формуле"

Автор - drugojandrew
Дата добавления - 28.07.2016 в 18:22
TimSha Дата: Четверг, 28.07.2016, 18:23 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 456
Репутация: 73 ±
Замечаний: 0% ±

Excel 2013 Pro +
Как вариант: предварительно оформить данные списком/таблицей.
Код
=СУММЕСЛИ(A2:A11;"<="&D2;B2:B11)


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
СообщениеКак вариант: предварительно оформить данные списком/таблицей.
Код
=СУММЕСЛИ(A2:A11;"<="&D2;B2:B11)

Автор - TimSha
Дата добавления - 28.07.2016 в 18:23
Nic70y Дата: Четверг, 28.07.2016, 18:26 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3480
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Говорит
кто?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Говорит
кто?

Автор - Nic70y
Дата добавления - 28.07.2016 в 18:26
drugojandrew Дата: Четверг, 28.07.2016, 18:29 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Говорит "ошибка в формуле"
Извиняюсь, не обратил внимания, что у меня формат американский и там для разделения аргументов используется "," а не ";" и просто скопировал. Формула работает, _Boroda_, спасибо.
 
Ответить
Сообщение
Говорит "ошибка в формуле"
Извиняюсь, не обратил внимания, что у меня формат американский и там для разделения аргументов используется "," а не ";" и просто скопировал. Формула работает, _Boroda_, спасибо.

Автор - drugojandrew
Дата добавления - 28.07.2016 в 18:29
drugojandrew Дата: Четверг, 28.07.2016, 18:31 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=СУММЕСЛИ(A:A;"<="&D2;B:B)
может и так сойдет?

Спасибо, тоже то, что надо.
 
Ответить
Сообщение
=СУММЕСЛИ(A:A;"<="&D2;B:B)
может и так сойдет?

Спасибо, тоже то, что надо.

Автор - drugojandrew
Дата добавления - 28.07.2016 в 18:31
Nic70y Дата: Четверг, 28.07.2016, 18:31 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3480
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Надо прост на флажок нажмать
К сообщению приложен файл: 7520724.gif(9Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 28.07.2016, 18:32
 
Ответить
СообщениеНадо прост на флажок нажмать

Автор - Nic70y
Дата добавления - 28.07.2016 в 18:31
drugojandrew Дата: Четверг, 28.07.2016, 18:59 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
но СУММЕСЛИ по всему столбцу не есть хорошо

интересно почему?
 
Ответить
Сообщение
но СУММЕСЛИ по всему столбцу не есть хорошо

интересно почему?

Автор - drugojandrew
Дата добавления - 28.07.2016 в 18:59
_Boroda_ Дата: Четверг, 28.07.2016, 19:37 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
интересно почему?

А Вы заведите на листе таких формул штук 100 хотя бы и поймете. Тормознутая она.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
интересно почему?

А Вы заведите на листе таких формул штук 100 хотя бы и поймете. Тормознутая она.

Автор - _Boroda_
Дата добавления - 28.07.2016 в 19:37
drugojandrew Дата: Четверг, 28.07.2016, 20:42 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
А Вы заведите на листе таких формул штук 100 хотя бы и поймете. Тормознутая она.

Завел порядка 1000 ради эксперимента - вроде все хорошо: считает быстро, нисколько не виснет. В любом случае спасибо.
 
Ответить
Сообщение
А Вы заведите на листе таких формул штук 100 хотя бы и поймете. Тормознутая она.

Завел порядка 1000 ради эксперимента - вроде все хорошо: считает быстро, нисколько не виснет. В любом случае спасибо.

Автор - drugojandrew
Дата добавления - 28.07.2016 в 20:42
champ Дата: Суббота, 30.07.2016, 20:46 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
вопрос по приложенному примеру, а можно посчитать сумму за произвольный промежуток времени, например с 23.07.2016 по
28.07.2016?
 
Ответить
Сообщениевопрос по приложенному примеру, а можно посчитать сумму за произвольный промежуток времени, например с 23.07.2016 по
28.07.2016?

Автор - champ
Дата добавления - 30.07.2016 в 20:46
Pelena Дата: Суббота, 30.07.2016, 21:31 | Сообщение № 14
Группа: Модераторы
Ранг: Экселист
Сообщений: 9862
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Используйте СУММЕСЛИМН() и второе условие >= начальной даты


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИспользуйте СУММЕСЛИМН() и второе условие >= начальной даты

Автор - Pelena
Дата добавления - 30.07.2016 в 21:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сумму до указанной даты (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!