Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вывести выборочные данные по условию из списка. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывести выборочные данные по условию из списка. (Формулы/Formulas)
вывести выборочные данные по условию из списка.
koyaanisqatsi Дата: Пятница, 29.07.2016, 12:34 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 610
Репутация: 15 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте.

Для создания этикеток есть такой лист, что в примере. Оттуда берутся данны для этикеток.

Хочется выводить не все данные а по определенным точкам справа написал пример какие надо выводить.

Спасибо.
К сообщению приложен файл: 0067923.xlsx(18Kb)
 
Ответить
СообщениеЗдравствуйте.

Для создания этикеток есть такой лист, что в примере. Оттуда берутся данны для этикеток.

Хочется выводить не все данные а по определенным точкам справа написал пример какие надо выводить.

Спасибо.

Автор - koyaanisqatsi
Дата добавления - 29.07.2016 в 12:34
Manyasha Дата: Пятница, 29.07.2016, 12:47 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1582
Репутация: 659 ±
Замечаний: 0% ±

Excel 2007, 2010
koyaanisqatsi, здравствуйте, так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$1:B$180;НАИМЕНЬШИЙ(ЕСЛИ(B$1:B$180*ЕЧИСЛО(ПОИСКПОЗ($A$1:$A$180;$U$3:$U$5;));СТРОКА(B$1:B$180));СТРОКА(B1)));"")
К сообщению приложен файл: 0067923-1.xlsx(18Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеkoyaanisqatsi, здравствуйте, так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$1:B$180;НАИМЕНЬШИЙ(ЕСЛИ(B$1:B$180*ЕЧИСЛО(ПОИСКПОЗ($A$1:$A$180;$U$3:$U$5;));СТРОКА(B$1:B$180));СТРОКА(B1)));"")

Автор - Manyasha
Дата добавления - 29.07.2016 в 12:47
koyaanisqatsi Дата: Пятница, 29.07.2016, 12:55 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 610
Репутация: 15 ±
Замечаний: 0% ±

Excel 2010
Manyasha, Великолепно ! Благодарю )
 
Ответить
СообщениеManyasha, Великолепно ! Благодарю )

Автор - koyaanisqatsi
Дата добавления - 29.07.2016 в 12:55
_Boroda_ Дата: Пятница, 29.07.2016, 13:01 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант. Немассивная формула
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/B$1:B$180/ПОИСКПОЗ(A$1:A$180;U$2:U$32;)/ЕНД(ПОИСКПОЗ(A$1:A$180;K$1:K1;));B$1:B$180);"")
К сообщению приложен файл: 0067923_1.xlsx(18Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант. Немассивная формула
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/B$1:B$180/ПОИСКПОЗ(A$1:A$180;U$2:U$32;)/ЕНД(ПОИСКПОЗ(A$1:A$180;K$1:K1;));B$1:B$180);"")

Автор - _Boroda_
Дата добавления - 29.07.2016 в 13:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывести выборочные данные по условию из списка. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!