Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Среднедневное значение в сводной таблице - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Среднедневное значение в сводной таблице (Формулы/Formulas)
Среднедневное значение в сводной таблице
Viper25 Дата: Понедельник, 01.08.2016, 17:14 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 4 ±
Замечаний: 0% ±

Excel 2007
Есть сводная таблица курса валют.
Но в ней курс указан не за каждый день месяца.
Подскажите, как рассчитать среднедневной курс.
Просто сложить и разделить на кол-во значений нельзя, поскольку в неуказанных днях курс был предыдущий.
К сообщению приложен файл: 0690855.xls(34Kb)
 
Ответить
СообщениеЕсть сводная таблица курса валют.
Но в ней курс указан не за каждый день месяца.
Подскажите, как рассчитать среднедневной курс.
Просто сложить и разделить на кол-во значений нельзя, поскольку в неуказанных днях курс был предыдущий.

Автор - Viper25
Дата добавления - 01.08.2016 в 17:14
Nic70y Дата: Понедельник, 01.08.2016, 17:19 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИОШИБКА(ВПР(B2;$F$2:$G$19;2;1);0)
;1);0)
только нужно добавить курс до 1-го числа
и тогда ЕСЛИОШИБКА можно выбросить совсем


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 01.08.2016, 17:19
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР(B2;$F$2:$G$19;2;1);0)
;1);0)
только нужно добавить курс до 1-го числа
и тогда ЕСЛИОШИБКА можно выбросить совсем

Автор - Nic70y
Дата добавления - 01.08.2016 в 17:19
Viper25 Дата: Понедельник, 01.08.2016, 17:20 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 4 ±
Замечаний: 0% ±

Excel 2007
Nic70y, добавить не могу, т.к. данные сводной таблицы.
 
Ответить
СообщениеNic70y, добавить не могу, т.к. данные сводной таблицы.

Автор - Viper25
Дата добавления - 01.08.2016 в 17:20
Pelena Дата: Понедельник, 01.08.2016, 17:22 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9869
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
в неуказанных днях курс был предыдущий

Тогда должен быть известен курс на конец предыдущего месяца
К сообщению приложен файл: 7892689.xls(36Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
в неуказанных днях курс был предыдущий

Тогда должен быть известен курс на конец предыдущего месяца

Автор - Pelena
Дата добавления - 01.08.2016 в 17:22
Nic70y Дата: Понедельник, 01.08.2016, 17:22 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Где тогда брать курс на первое число если его вдруг нет?

или так (в файле)
К сообщению приложен файл: 4095158.xls(28Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 01.08.2016, 17:26
 
Ответить
СообщениеГде тогда брать курс на первое число если его вдруг нет?

или так (в файле)

Автор - Nic70y
Дата добавления - 01.08.2016 в 17:22
krosav4ig Дата: Понедельник, 01.08.2016, 17:24 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1349
Репутация: 547 ±
Замечаний: 0% ±

Excel 2007, 2013
вдруг правильно...
если без курса на 1-е число, массивная формула
Код
=СРЗНАЧ(ЕСЛИОШИБКА(ПРОСМОТР(КОНМЕСЯЦА(F2;-1)+СТРОКА(A1:ИНДЕКС(A:A;ДЕНЬ(КОНМЕСЯЦА(F2;0))));F2:F19;G2:G19);))

если курс на 1-е число в H2, массивная формула
Код
=СРЗНАЧ(ЕСЛИОШИБКА(ПРОСМОТР(КОНМЕСЯЦА(F2;-1)+СТРОКА(A1:ИНДЕКС(A:A;ДЕНЬ(КОНМЕСЯЦА(F2;0))));F2:F19;G2:G19);H2))


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Понедельник, 01.08.2016, 17:29
 
Ответить
Сообщениевдруг правильно...
если без курса на 1-е число, массивная формула
Код
=СРЗНАЧ(ЕСЛИОШИБКА(ПРОСМОТР(КОНМЕСЯЦА(F2;-1)+СТРОКА(A1:ИНДЕКС(A:A;ДЕНЬ(КОНМЕСЯЦА(F2;0))));F2:F19;G2:G19);))

если курс на 1-е число в H2, массивная формула
Код
=СРЗНАЧ(ЕСЛИОШИБКА(ПРОСМОТР(КОНМЕСЯЦА(F2;-1)+СТРОКА(A1:ИНДЕКС(A:A;ДЕНЬ(КОНМЕСЯЦА(F2;0))));F2:F19;G2:G19);H2))

Автор - krosav4ig
Дата добавления - 01.08.2016 в 17:24
Viper25 Дата: Понедельник, 01.08.2016, 17:25 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 4 ±
Замечаний: 0% ±

Excel 2007
Nic70y, Pelena, в примере известен курс на 05.01.2016. Значит курс 1-4 числа был такой как 5-го.
Курса на 1-ое число в сводной таблице нет.


Сообщение отредактировал Viper25 - Понедельник, 01.08.2016, 17:29
 
Ответить
СообщениеNic70y, Pelena, в примере известен курс на 05.01.2016. Значит курс 1-4 числа был такой как 5-го.
Курса на 1-ое число в сводной таблице нет.

Автор - Viper25
Дата добавления - 01.08.2016 в 17:25
Nic70y Дата: Понедельник, 01.08.2016, 17:28 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Значит курс 1-4 числа был такой как 5-го
это не логично - что тогда должно быть в последних числах...


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Значит курс 1-4 числа был такой как 5-го
это не логично - что тогда должно быть в последних числах...

Автор - Nic70y
Дата добавления - 01.08.2016 в 17:28
Viper25 Дата: Понедельник, 01.08.2016, 17:31 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 4 ±
Замечаний: 0% ±

Excel 2007
Nic70y, в последних числах предыдущего месяца, если не указан курс, должен быть такой, как следующий известный, т.е. на 5-ое.
 
Ответить
СообщениеNic70y, в последних числах предыдущего месяца, если не указан курс, должен быть такой, как следующий известный, т.е. на 5-ое.

Автор - Viper25
Дата добавления - 01.08.2016 в 17:31
Pelena Дата: Понедельник, 01.08.2016, 17:40 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 9869
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=ЕСЛИ(B2<$F$2;$G$2;ВПР(B2;$F$2:$G$19;2))
К сообщению приложен файл: 1068775.xls(36Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИ(B2<$F$2;$G$2;ВПР(B2;$F$2:$G$19;2))

Автор - Pelena
Дата добавления - 01.08.2016 в 17:40
Nic70y Дата: Понедельник, 01.08.2016, 17:41 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
неправильно все это, но как хотите
Код
=ЕСЛИОШИБКА(ВПР(B2;$F$2:$G$19;2;1);G$2)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениенеправильно все это, но как хотите
Код
=ЕСЛИОШИБКА(ВПР(B2;$F$2:$G$19;2;1);G$2)

Автор - Nic70y
Дата добавления - 01.08.2016 в 17:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Среднедневное значение в сводной таблице (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!