Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение столбцов и вывод значений уникальных в третий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение столбцов и вывод значений уникальных в третий (Формулы/Formulas)
Сравнение столбцов и вывод значений уникальных в третий
povsten Дата: Среда, 03.08.2016, 20:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Подскажите, пожалуйста, долго мучалась не могу понять как мне сравнить 2 столбца с ID и вывести в третий только значения ID, которых нет в обоих столбцах. Файл с примером привожу.
Заранее благодарю.
К сообщению приложен файл: 2395361.xlsx(11Kb)
 
Ответить
СообщениеПодскажите, пожалуйста, долго мучалась не могу понять как мне сравнить 2 столбца с ID и вывести в третий только значения ID, которых нет в обоих столбцах. Файл с примером привожу.
Заранее благодарю.

Автор - povsten
Дата добавления - 03.08.2016 в 20:37
buchlotnik Дата: Среда, 03.08.2016, 20:47 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2632
Репутация: 752 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Итог1:
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$3;A2)>0;"";A2)

Итог2 (формула массива):
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$7;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$3;$A$2:$A$7);"";СТРОКА($A$2:$A$7)-1);СТРОКА(A1)));"")
К сообщению приложен файл: 9001130.xlsx(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеИтог1:
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$3;A2)>0;"";A2)

Итог2 (формула массива):
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$7;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$3;$A$2:$A$7);"";СТРОКА($A$2:$A$7)-1);СТРОКА(A1)));"")

Автор - buchlotnik
Дата добавления - 03.08.2016 в 20:47
Gustav Дата: Среда, 03.08.2016, 20:50 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1350
Репутация: 535 ±
Замечаний: 0% ±

начинал с Excel 4.0...
как мне сравнить 2 столбца с ID и вывести в третий только значения ID, которых нет в обоих столбцах

Судя по файлу, Вы решаете несколько иную задачу - вывести в столбец 3 значения из столбца 1, которых нет в столбце 2 :)


Мой tip box - яд 41001663842605
 
Ответить
Сообщение
как мне сравнить 2 столбца с ID и вывести в третий только значения ID, которых нет в обоих столбцах

Судя по файлу, Вы решаете несколько иную задачу - вывести в столбец 3 значения из столбца 1, которых нет в столбце 2 :)

Автор - Gustav
Дата добавления - 03.08.2016 в 20:50
povsten Дата: Среда, 03.08.2016, 23:18 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
спасибо. все верно. даже некорректно сформулировала, вы правы.
 
Ответить
Сообщениеспасибо. все верно. даже некорректно сформулировала, вы правы.

Автор - povsten
Дата добавления - 03.08.2016 в 23:18
povsten Дата: Среда, 03.08.2016, 23:23 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, первую формулу более менее поняла, а вторую не оч, можете пояснить ее работу?
 
Ответить
Сообщениеbuchlotnik, первую формулу более менее поняла, а вторую не оч, можете пояснить ее работу?

Автор - povsten
Дата добавления - 03.08.2016 в 23:23
buchlotnik Дата: Среда, 03.08.2016, 23:38 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2632
Репутация: 752 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Избавляемся от ошибок:
Код
ЕСЛИОШИБКА(вынималка;"")

Вынималка нужных нам значений:
Код
ИНДЕКС($A$2:$A$7;вынимаемая строка)

Вынимаем мы последовательно строки с нужными значениями:
Код
НАИМЕНЬШИЙ(проверка условия;СТРОКА(A1))

При протяжке эта формула найдёт нам номера строк, удовлетворяющих условию (первый, второй и т.д. по порядку)
Осталось определить номера нужных строк:
Код
ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$3;$A$2:$A$7);"";СТРОКА($A$2:$A$7)-1)

Т.е. если значение из второго столбца найдено в первом – «», иначе – номер строки, -1 потому что данные не с первой, а со второй строки идут.
Как-то так B)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 03.08.2016, 23:44
 
Ответить
СообщениеИзбавляемся от ошибок:
Код
ЕСЛИОШИБКА(вынималка;"")

Вынималка нужных нам значений:
Код
ИНДЕКС($A$2:$A$7;вынимаемая строка)

Вынимаем мы последовательно строки с нужными значениями:
Код
НАИМЕНЬШИЙ(проверка условия;СТРОКА(A1))

При протяжке эта формула найдёт нам номера строк, удовлетворяющих условию (первый, второй и т.д. по порядку)
Осталось определить номера нужных строк:
Код
ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$3;$A$2:$A$7);"";СТРОКА($A$2:$A$7)-1)

Т.е. если значение из второго столбца найдено в первом – «», иначе – номер строки, -1 потому что данные не с первой, а со второй строки идут.
Как-то так B)

Автор - buchlotnik
Дата добавления - 03.08.2016 в 23:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение столбцов и вывод значений уникальных в третий (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!