Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка значений по двум параметрам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений по двум параметрам (Формулы/Formulas)
Подстановка значений по двум параметрам
Leprotto Дата: Четверг, 04.08.2016, 12:57 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Всем добрый день!
Я попробовал использовать ИНДЕКС и ПОИСКПОЗ, но получилась подстановка первого совпадающего кода, что конечно не верно.
Помогите, пожалуйста, прописать смещение просматриваемого массива или может вообще другое решение...
Если на лист "Отчет" внесен товар с кодом, то нужно подставить его срок из листа "Хранение". Пример приложил.
К сообщению приложен файл: podstanovka.xlsx(17Kb)
 
Ответить
СообщениеВсем добрый день!
Я попробовал использовать ИНДЕКС и ПОИСКПОЗ, но получилась подстановка первого совпадающего кода, что конечно не верно.
Помогите, пожалуйста, прописать смещение просматриваемого массива или может вообще другое решение...
Если на лист "Отчет" внесен товар с кодом, то нужно подставить его срок из листа "Хранение". Пример приложил.

Автор - Leprotto
Дата добавления - 04.08.2016 в 12:57
pabchek Дата: Четверг, 04.08.2016, 12:59 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Формула массива
Код
=ИНДЕКС(Таблица1[Срок хранения];ПОИСКПОЗ(Таблица47[[@Эта строка];[Фрукт]]&Таблица47[[@Эта строка];[Код]];Таблица1[Фрукт]&Таблица1[Код];0))

или простая
Код
=СУММЕСЛИМН(Таблица1[Срок хранения];Таблица1[Фрукт];Таблица47[[@Эта строка];[Фрукт]];Таблица1[Код];Таблица47[[@Эта строка];[Код]])
К сообщению приложен файл: 6716490.xlsx(17Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Четверг, 04.08.2016, 13:15
 
Ответить
СообщениеЗдравствуйте!
Формула массива
Код
=ИНДЕКС(Таблица1[Срок хранения];ПОИСКПОЗ(Таблица47[[@Эта строка];[Фрукт]]&Таблица47[[@Эта строка];[Код]];Таблица1[Фрукт]&Таблица1[Код];0))

или простая
Код
=СУММЕСЛИМН(Таблица1[Срок хранения];Таблица1[Фрукт];Таблица47[[@Эта строка];[Фрукт]];Таблица1[Код];Таблица47[[@Эта строка];[Код]])

Автор - pabchek
Дата добавления - 04.08.2016 в 12:59
AlexM Дата: Четверг, 04.08.2016, 13:04 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3048
Репутация: 739 ±
Замечаний: 0% ±

Код
=ПРОСМОТР(2;1/(A2&B2=Хранение!A$2:A$99&Хранение!B$2:B$99);Хранение!C$2:C$99)
К сообщению приложен файл: podstanovka.xls(42Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ПРОСМОТР(2;1/(A2&B2=Хранение!A$2:A$99&Хранение!B$2:B$99);Хранение!C$2:C$99)

Автор - AlexM
Дата добавления - 04.08.2016 в 13:04
китин Дата: Четверг, 04.08.2016, 13:13 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или так
Код
=СУММПРОИЗВ(Таблица1[Срок хранения]*(Таблица1[Фрукт]&Таблица1[Код]=[@Фрукт]&[@Код]))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеили так
Код
=СУММПРОИЗВ(Таблица1[Срок хранения]*(Таблица1[Фрукт]&Таблица1[Код]=[@Фрукт]&[@Код]))

Автор - китин
Дата добавления - 04.08.2016 в 13:13
Leprotto Дата: Четверг, 04.08.2016, 13:46 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Спасибо большое!!!
 
Ответить
СообщениеСпасибо большое!!!

Автор - Leprotto
Дата добавления - 04.08.2016 в 13:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений по двум параметрам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!