Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формирование списка используя данные разных столбцов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование списка используя данные разных столбцов (Формулы/Formulas)
Формирование списка используя данные разных столбцов
zaak88 Дата: Пятница, 12.08.2016, 15:59 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Добрый день, коллеги! Прошу помочь с одним вопросом. В файле на листе исх есть список оригиналов и аналогов. Требуется вывести на листе вых одним столбцом, при этом во втором столбце уточнить статус (оригинал или аналог). Не могу подобрать формулу. Спасибо!
К сообщению приложен файл: 5489170.xlsx(12Kb)


Сообщение отредактировал zaak88 - Пятница, 12.08.2016, 15:59
 
Ответить
СообщениеДобрый день, коллеги! Прошу помочь с одним вопросом. В файле на листе исх есть список оригиналов и аналогов. Требуется вывести на листе вых одним столбцом, при этом во втором столбце уточнить статус (оригинал или аналог). Не могу подобрать формулу. Спасибо!

Автор - zaak88
Дата добавления - 12.08.2016 в 15:59
Nic70y Дата: Пятница, 12.08.2016, 16:15 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3923
Репутация: 830 ±
Замечаний: 0% ±

Excel 2013
что-то ни фига не понятно что из чего выведено...
Требуется вывести на листе вых одним столбцом
а в примере столбец A листа вых не соот. столбцу A листа исх
оригинал или аналог
какой критерий?
(либо #Н/Д, либо не пойму)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Пятница, 12.08.2016, 16:16
 
Ответить
Сообщениечто-то ни фига не понятно что из чего выведено...
Требуется вывести на листе вых одним столбцом
а в примере столбец A листа вых не соот. столбцу A листа исх
оригинал или аналог
какой критерий?
(либо #Н/Д, либо не пойму)

Автор - Nic70y
Дата добавления - 12.08.2016 в 16:15
zaak88 Дата: Пятница, 12.08.2016, 16:34 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Nic70y, позиция в потребности (оригинал). Необходимо вывести оригиналы и аналоги последовательным списком (так как вывел значения) из разных столбцов. Чтобы под оригиналом шли его аналоги. И второй формулой уточнить статус - оригинал/аналог.
 
Ответить
СообщениеNic70y, позиция в потребности (оригинал). Необходимо вывести оригиналы и аналоги последовательным списком (так как вывел значения) из разных столбцов. Чтобы под оригиналом шли его аналоги. И второй формулой уточнить статус - оригинал/аналог.

Автор - zaak88
Дата добавления - 12.08.2016 в 16:34
Nic70y Дата: Пятница, 12.08.2016, 16:55 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3923
Репутация: 830 ±
Замечаний: 0% ±

Excel 2013
массивная:
Код
=ИНДЕКС(исх!A$4:K$37;НАИМЕНЬШИЙ(ЕСЛИ(ЕТЕКСТ(исх!A$4:K$37);СТРОКА(исх!A$4:K$37));СТРОКА(A1))-3;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(ЕТЕКСТ(исх!A$4:K$37);СТРОКА(исх!A$4:K$37)+СТОЛБЕЦ(исх!A$4:K$37)/100);СТРОКА(A1));1)*100;))
и обычная
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A4;исх!A$4:A$37;));"Оригинал";"Аналог")
К сообщению приложен файл: 8383911.xlsx(14Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениемассивная:
Код
=ИНДЕКС(исх!A$4:K$37;НАИМЕНЬШИЙ(ЕСЛИ(ЕТЕКСТ(исх!A$4:K$37);СТРОКА(исх!A$4:K$37));СТРОКА(A1))-3;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(ЕТЕКСТ(исх!A$4:K$37);СТРОКА(исх!A$4:K$37)+СТОЛБЕЦ(исх!A$4:K$37)/100);СТРОКА(A1));1)*100;))
и обычная
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A4;исх!A$4:A$37;));"Оригинал";"Аналог")

Автор - Nic70y
Дата добавления - 12.08.2016 в 16:55
zaak88 Дата: Понедельник, 15.08.2016, 08:11 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Nic70y, извините в инет не выходил. Спасибо огромное, очень помогли, всё работает!
 
Ответить
СообщениеNic70y, извините в инет не выходил. Спасибо огромное, очень помогли, всё работает!

Автор - zaak88
Дата добавления - 15.08.2016 в 08:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование списка используя данные разных столбцов (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!