Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти повторяющиеся значения в Excel и изменить их - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти повторяющиеся значения в Excel и изменить их (Формулы/Formulas)
Найти повторяющиеся значения в Excel и изменить их
profpalitra Дата: Суббота, 13.08.2016, 16:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Есть столбец разных слов в Excel. К примеру:

слово
слово
слово
другое слово
новое слово
другое слово
другое слово
другое слово
слово

Задача состоит в том, чтобы проверить повторялась ли группа слов ранее, если повторялась,
то переименовать все слова в новой найденной группе.

Должно быть вот так:
слово
слово
слово
другое слово
новое слово
другое слово2
другое слово2
другое слово2
слово2

и т. д.


Сообщение отредактировал profpalitra - Суббота, 13.08.2016, 17:39
 
Ответить
СообщениеЕсть столбец разных слов в Excel. К примеру:

слово
слово
слово
другое слово
новое слово
другое слово
другое слово
другое слово
слово

Задача состоит в том, чтобы проверить повторялась ли группа слов ранее, если повторялась,
то переименовать все слова в новой найденной группе.

Должно быть вот так:
слово
слово
слово
другое слово
новое слово
другое слово2
другое слово2
другое слово2
слово2

и т. д.

Автор - profpalitra
Дата добавления - 13.08.2016 в 16:40
krosav4ig Дата: Суббота, 13.08.2016, 19:47 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1465
Репутация: 596 ±
Замечаний: 0% ±

Excel 2007, 2013
Есть столбец разных слов в Excel.
profpalitra, а у мну нет такого столбца
тык


(_)Õvõ(_)
 
Ответить
Сообщение
Есть столбец разных слов в Excel.
profpalitra, а у мну нет такого столбца
тык

Автор - krosav4ig
Дата добавления - 13.08.2016 в 19:47
profpalitra Дата: Суббота, 13.08.2016, 19:50 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
ничего не понял
 
Ответить
Сообщениеничего не понял

Автор - profpalitra
Дата добавления - 13.08.2016 в 19:50
krosav4ig Дата: Суббота, 13.08.2016, 19:56 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1465
Репутация: 596 ±
Замечаний: 0% ±

Excel 2007, 2013
еще раз тык, изучаем, в особенности п. 3
[p.s.]файл в студию rules


(_)Õvõ(_)
 
Ответить
Сообщениееще раз тык, изучаем, в особенности п. 3
[p.s.]файл в студию rules

Автор - krosav4ig
Дата добавления - 13.08.2016 в 19:56
Nic70y Дата: Воскресенье, 14.08.2016, 08:55 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3922
Репутация: 830 ±
Замечаний: 0% ±

Excel 2013
до 9
Код
=A1
Код
=ЕСЛИ(ПОИСКПОЗ(A2;A$1:A2;)=СТРОКА();A2;ЕСЛИ(A2=A1;B1;A2&МАКС(2;ЕСЛИОШИБКА(--ПРАВБ(ИНДЕКС(B$1:B1;СУММПРОИЗВ(МАКС((A$1:A1=A2)*СТРОКА(A$1:A1)))));0)+1)))
Код
=ЕСЛИ(ПОИСКПОЗ(A2;A$1:A2;)=СТРОКА();A2;ЕСЛИ(A2=A1;B1;A2&ЕСЛИОШИБКА(--ПРАВБ(ИНДЕКС(B$1:B1;СУММПРОИЗВ(МАКС((A$1:A1=A2)*СТРОКА(A$1:A1)))));1)+1))
К сообщению приложен файл: 4522845.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Воскресенье, 14.08.2016, 09:00
 
Ответить
Сообщениедо 9
Код
=A1
Код
=ЕСЛИ(ПОИСКПОЗ(A2;A$1:A2;)=СТРОКА();A2;ЕСЛИ(A2=A1;B1;A2&МАКС(2;ЕСЛИОШИБКА(--ПРАВБ(ИНДЕКС(B$1:B1;СУММПРОИЗВ(МАКС((A$1:A1=A2)*СТРОКА(A$1:A1)))));0)+1)))
Код
=ЕСЛИ(ПОИСКПОЗ(A2;A$1:A2;)=СТРОКА();A2;ЕСЛИ(A2=A1;B1;A2&ЕСЛИОШИБКА(--ПРАВБ(ИНДЕКС(B$1:B1;СУММПРОИЗВ(МАКС((A$1:A1=A2)*СТРОКА(A$1:A1)))));1)+1))

Автор - Nic70y
Дата добавления - 14.08.2016 в 08:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти повторяющиеся значения в Excel и изменить их (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!