Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Возврат значений в зависимости от даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возврат значений в зависимости от даты (Формулы/Formulas)
Возврат значений в зависимости от даты
brotheralex Дата: Среда, 17.08.2016, 04:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Коллеги, добрый день.
Не являюсь экспертом в excel, поэтому прошу прощения за дилетантский вопрос.

Исходные данные такие.
Есть лист (лист "k") с коэффициентами с привязкой к компании и дате, с которой определенный коэффициент вступают в силу. Эта дата является ключевой.
Этот лист служит летописью взаимоотношений с компаниями, условно говоря.
И есть рабочий лист (лист "распределение k") где перечислены все заказы с датой.

Соответственно, задача такая.
Из листа "k" на лист лист "распределение k" нужно вернуть корректный коэффициент для каждого заказа в зависимости от даты заказа.
Допустим, по компании №1 применяется коэффициент 1.00 с даты 01.06.2016 и коэффициент 1,25 с даты 10.07.2016.
Соответственно, у заказов компании 1 на листе "распределение k"начиная с даты 10.07.2016 должны быть коэффициенты 1.25, а у более старых заказов - коэффициент 1.00.
Надеюсь, изъяснился понятно...

Честно говоря, мне не хватает знаний для того чтобы выполнить такую задачу. Если цеплять с помощью ВПР, то будет возвращаться только первое значение (в зависимости от сортировки на листе "k").

Надеюсь на вашу помощь! Заранее спасибо!
К сообщению приложен файл: 3938096.xlsx(16Kb)
 
Ответить
СообщениеКоллеги, добрый день.
Не являюсь экспертом в excel, поэтому прошу прощения за дилетантский вопрос.

Исходные данные такие.
Есть лист (лист "k") с коэффициентами с привязкой к компании и дате, с которой определенный коэффициент вступают в силу. Эта дата является ключевой.
Этот лист служит летописью взаимоотношений с компаниями, условно говоря.
И есть рабочий лист (лист "распределение k") где перечислены все заказы с датой.

Соответственно, задача такая.
Из листа "k" на лист лист "распределение k" нужно вернуть корректный коэффициент для каждого заказа в зависимости от даты заказа.
Допустим, по компании №1 применяется коэффициент 1.00 с даты 01.06.2016 и коэффициент 1,25 с даты 10.07.2016.
Соответственно, у заказов компании 1 на листе "распределение k"начиная с даты 10.07.2016 должны быть коэффициенты 1.25, а у более старых заказов - коэффициент 1.00.
Надеюсь, изъяснился понятно...

Честно говоря, мне не хватает знаний для того чтобы выполнить такую задачу. Если цеплять с помощью ВПР, то будет возвращаться только первое значение (в зависимости от сортировки на листе "k").

Надеюсь на вашу помощь! Заранее спасибо!

Автор - brotheralex
Дата добавления - 17.08.2016 в 04:48
krosav4ig Дата: Среда, 17.08.2016, 05:12 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1465
Репутация: 596 ±
Замечаний: 0% ±

Excel 2007, 2013
здравствуйте
Если цеплять с помощью ВПР

для C2 формула(массивная, вводится нажатием Ctrl+Shift+Enter)
Код
=ВПР(МАКС((A2=k!$A$2:$A$10)*(k!$B$2:$B$10<=B2)*k!$B$2:$B$10);ЕСЛИ(A2=k!$A$2:$A$10;k!$B$2:$C$10);2;)


(_)Õvõ(_)
 
Ответить
Сообщениездравствуйте
Если цеплять с помощью ВПР

для C2 формула(массивная, вводится нажатием Ctrl+Shift+Enter)
Код
=ВПР(МАКС((A2=k!$A$2:$A$10)*(k!$B$2:$B$10<=B2)*k!$B$2:$B$10);ЕСЛИ(A2=k!$A$2:$A$10;k!$B$2:$C$10);2;)

Автор - krosav4ig
Дата добавления - 17.08.2016 в 05:12
brotheralex Дата: Среда, 17.08.2016, 05:53 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
для C2 формула(массивная, вводится нажатием Ctrl+Shift+Enter)

=ВПР(МАКС((A2=k!$A$2:$A$10)*(k!$B$2:$B$10<=B2)*k!$B$2:$B$10);ЕСЛИ(A2=k!$A$2:$A$10;k!$B$2:$C$10);2;)


Спасибо, попытаюсь понять!
 
Ответить
Сообщение
для C2 формула(массивная, вводится нажатием Ctrl+Shift+Enter)

=ВПР(МАКС((A2=k!$A$2:$A$10)*(k!$B$2:$B$10<=B2)*k!$B$2:$B$10);ЕСЛИ(A2=k!$A$2:$A$10;k!$B$2:$C$10);2;)


Спасибо, попытаюсь понять!

Автор - brotheralex
Дата добавления - 17.08.2016 в 05:53
Pelena Дата: Среда, 17.08.2016, 10:42 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11045
Репутация: 2468 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ещё вариант, тоже формула массива, если коэффициенты со временем только увеличиваются
Код
=МАКС((A2=k!$A$2:$A$10)*(k!$B$2:$B$10<=B2)*k!$C$2:$C$10)

или более универсальный вариант
Код
=МАКС((k!$B$2:$B$10=МАКС((A2=k!$A$2:$A$10)*(k!$B$2:$B$10<=B2)*k!$B$2:$B$10))*(k!$A$2:$A$10=A2)*k!$C$2:$C$10)
К сообщению приложен файл: 3469807.xlsx(17Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант, тоже формула массива, если коэффициенты со временем только увеличиваются
Код
=МАКС((A2=k!$A$2:$A$10)*(k!$B$2:$B$10<=B2)*k!$C$2:$C$10)

или более универсальный вариант
Код
=МАКС((k!$B$2:$B$10=МАКС((A2=k!$A$2:$A$10)*(k!$B$2:$B$10<=B2)*k!$B$2:$B$10))*(k!$A$2:$A$10=A2)*k!$C$2:$C$10)

Автор - Pelena
Дата добавления - 17.08.2016 в 10:42
brotheralex Дата: Понедельник, 22.08.2016, 10:00 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Огромное спасибо. Я разобрался и всё получилось!)
Благодарю всех за помощь!
 
Ответить
СообщениеОгромное спасибо. Я разобрался и всё получилось!)
Благодарю всех за помощь!

Автор - brotheralex
Дата добавления - 22.08.2016 в 10:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возврат значений в зависимости от даты (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!