Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/преобразовать время в текст - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » преобразовать время в текст (Формулы/Formulas)
преобразовать время в текст
Николай67 Дата: Четверг, 18.08.2016, 11:20 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте. Помогите пожалуйста преобразовать количество часов в текст.
К сообщению приложен файл: 5622492.xlsx(9Kb)
 
Ответить
СообщениеЗдравствуйте. Помогите пожалуйста преобразовать количество часов в текст.

Автор - Николай67
Дата добавления - 18.08.2016 в 11:20
Pelena Дата: Четверг, 18.08.2016, 11:27 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11277
Репутация: 2508 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте
Код
=ДЕНЬ(D2)&" дн. "&ЧАС(D2)&" ч. "&МИНУТЫ(D2)&" мин."


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте
Код
=ДЕНЬ(D2)&" дн. "&ЧАС(D2)&" ч. "&МИНУТЫ(D2)&" мин."

Автор - Pelena
Дата добавления - 18.08.2016 в 11:27
Николай67 Дата: Четверг, 18.08.2016, 11:40 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Николай67, Спасибо большое, но к сожалению формула обнуляет месяца, если есть возможность избежать это, помогите пожалуйста.
К сообщению приложен файл: 6770498.xlsx(9Kb)
 
Ответить
СообщениеНиколай67, Спасибо большое, но к сожалению формула обнуляет месяца, если есть возможность избежать это, помогите пожалуйста.

Автор - Николай67
Дата добавления - 18.08.2016 в 11:40
Pelena Дата: Четверг, 18.08.2016, 11:43 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11277
Репутация: 2508 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Код
=ОТБР(D2)&" дн. "&ЧАС(D2)&" ч. "&МИНУТЫ(D2)&" мин."


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ОТБР(D2)&" дн. "&ЧАС(D2)&" ч. "&МИНУТЫ(D2)&" мин."

Автор - Pelena
Дата добавления - 18.08.2016 в 11:43
Николай67 Дата: Четверг, 18.08.2016, 11:50 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Николай67, Огромное спасибо, все работает! hands
 
Ответить
СообщениеНиколай67, Огромное спасибо, все работает! hands

Автор - Николай67
Дата добавления - 18.08.2016 в 11:50
katlovesmilk Дата: Среда, 26.07.2017, 13:54 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, здравствуйте!

Подскажите, а как в подобной ситуации сделать так, чтобы часы отображались, если они превышают сутки?
Нужно без дней...
К сообщению приложен файл: 7686975.xlsx(10Kb)
 
Ответить
СообщениеPelena, здравствуйте!

Подскажите, а как в подобной ситуации сделать так, чтобы часы отображались, если они превышают сутки?
Нужно без дней...

Автор - katlovesmilk
Дата добавления - 26.07.2017 в 13:54
китин Дата: Среда, 26.07.2017, 14:03 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4227
Репутация: 662 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
осмелюсь ответить вместо Лены, надеюсь ругаться не будет :D
Код
=ТЕКСТ(E31;"[чч]")&" ч."&ТЕКСТ(E31;"мм")&" мин."


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеосмелюсь ответить вместо Лены, надеюсь ругаться не будет :D
Код
=ТЕКСТ(E31;"[чч]")&" ч."&ТЕКСТ(E31;"мм")&" мин."

Автор - китин
Дата добавления - 26.07.2017 в 14:03
katlovesmilk Дата: Среда, 26.07.2017, 14:18 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
китин,
Спасибо большое, Вы мне очень помогли!)


Сообщение отредактировал katlovesmilk - Среда, 26.07.2017, 14:20
 
Ответить
Сообщениекитин,
Спасибо большое, Вы мне очень помогли!)

Автор - katlovesmilk
Дата добавления - 26.07.2017 в 14:18
_Boroda_ Дата: Среда, 26.07.2017, 14:22 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10900
Репутация: 4498 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
не буду

Ну, если не будете ругаться :D , то еще вариант
Код
=ТЕКСТ(E31;"[ч] \ч. мм \мин.")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
не буду

Ну, если не будете ругаться :D , то еще вариант
Код
=ТЕКСТ(E31;"[ч] \ч. мм \мин.")

Автор - _Boroda_
Дата добавления - 26.07.2017 в 14:22
katlovesmilk Дата: Среда, 26.07.2017, 14:28 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, Здорово, спасибо!)
 
Ответить
Сообщение_Boroda_, Здорово, спасибо!)

Автор - katlovesmilk
Дата добавления - 26.07.2017 в 14:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » преобразовать время в текст (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!