Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция ВПР - поиск и вывод значений из общего списка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция ВПР - поиск и вывод значений из общего списка (Формулы/Formulas)
Функция ВПР - поиск и вывод значений из общего списка
povsten Дата: Понедельник, 22.08.2016, 14:28 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Подскажите, пожалуйста, в приложенном файле Excel не получается функцией ВПР вытянуть нужные значения
Необходимо из листа База вытянуть на лист 12 июля значения ID сотрудника в соответствующий (первый) столбец, но вместо ID сотрудника почему-то вытягивается значение ID бейджа.
Вроде функция ВПР написана правильно. В чем ошибка?

Спасибо
К сообщению приложен файл: 2479098-1.xlsx(17Kb)
 
Ответить
СообщениеПодскажите, пожалуйста, в приложенном файле Excel не получается функцией ВПР вытянуть нужные значения
Необходимо из листа База вытянуть на лист 12 июля значения ID сотрудника в соответствующий (первый) столбец, но вместо ID сотрудника почему-то вытягивается значение ID бейджа.
Вроде функция ВПР написана правильно. В чем ошибка?

Спасибо

Автор - povsten
Дата добавления - 22.08.2016 в 14:28
Pelena Дата: Понедельник, 22.08.2016, 14:33 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Для ВПР() Вам потребуется по меньшей мере поменять местами столбцы А и В на листе База.
А так
Код
=ИНДЕКС(База!$A$2:$A$4;ПОИСКПОЗ(B3;База!$B$2:$B$4;0))
К сообщению приложен файл: 4802918.xlsx(16Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДля ВПР() Вам потребуется по меньшей мере поменять местами столбцы А и В на листе База.
А так
Код
=ИНДЕКС(База!$A$2:$A$4;ПОИСКПОЗ(B3;База!$B$2:$B$4;0))

Автор - Pelena
Дата добавления - 22.08.2016 в 14:33
китин Дата: Понедельник, 22.08.2016, 14:40 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или так
Код
=ПРОСМОТР(1;1/(База!$B$2:$B$4='12 июля'!$B3);База!$A$2:$A$4)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеили так
Код
=ПРОСМОТР(1;1/(База!$B$2:$B$4='12 июля'!$B3);База!$A$2:$A$4)

Автор - китин
Дата добавления - 22.08.2016 в 14:40
povsten Дата: Понедельник, 22.08.2016, 14:53 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
спасибо большое. только не поняла почему для ВПР надо менять местами столбцы. По моей формуле, как я полагаю, должно искаться значение $B$3 по всему диапазону $B$2:$B$4 с листа базы, и из базы должно тянуться значение из 1 столбца ID сотрудника, а тянется вообще непонятно что.
 
Ответить
Сообщениеспасибо большое. только не поняла почему для ВПР надо менять местами столбцы. По моей формуле, как я полагаю, должно искаться значение $B$3 по всему диапазону $B$2:$B$4 с листа базы, и из базы должно тянуться значение из 1 столбца ID сотрудника, а тянется вообще непонятно что.

Автор - povsten
Дата добавления - 22.08.2016 в 14:53
китин Дата: Понедельник, 22.08.2016, 14:56 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
povsten, почитайте справку по ВПР. Там все хорошо написано

Цитата
искомое_значение (обязательный)
Значение для поиска. Искомое значение должно находиться в первом столбце диапазона ячеек, указанного в таблице.


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 22.08.2016, 14:58
 
Ответить
Сообщениеpovsten, почитайте справку по ВПР. Там все хорошо написано

Цитата
искомое_значение (обязательный)
Значение для поиска. Искомое значение должно находиться в первом столбце диапазона ячеек, указанного в таблице.

Автор - китин
Дата добавления - 22.08.2016 в 14:56
AlexM Дата: Понедельник, 22.08.2016, 15:19 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3048
Репутация: 739 ±
Замечаний: 0% ±

Код
=ВПР(B3;ЕСЛИ({1;0};База!B$2:B$4;База!A$2:A$4);2;)
PS. povsten, в ваших формулах с ВПР() аргумент интервальный просмотр должен быть ЛОЖЬ или 0
К сообщению приложен файл: 2479098-1.xls(58Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 22.08.2016, 15:23
 
Ответить
Сообщение
Код
=ВПР(B3;ЕСЛИ({1;0};База!B$2:B$4;База!A$2:A$4);2;)
PS. povsten, в ваших формулах с ВПР() аргумент интервальный просмотр должен быть ЛОЖЬ или 0

Автор - AlexM
Дата добавления - 22.08.2016 в 15:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция ВПР - поиск и вывод значений из общего списка (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!