Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Занимаемые места в зависимости от набранных очко - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Занимаемые места в зависимости от набранных очко (Формулы/Formulas)
Занимаемые места в зависимости от набранных очко
мкс Дата: Четверг, 25.08.2016, 09:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 60% ±

Excel 2010
Доброго времени суток, Уважаемые форумчане!

Прошу Вашего совета:

Предыстория: Довольно часто практикуем с друзьями посиделки и игру в UNO. Смысл набрать наименьшее количество очков в процессе игры. Со временем начал обращать внимание что как то не очень хочется кому либо складывать очки, да и могут быть ошибки.

Суть идеи. Написать формулу, которая бы считал общее количество очков(ну с этим совсем просто). А вот назначение занимаемого места с этим столкнулся с несколькими нюансами:
1.При использовании функции РАНГ, и совпадении количества очков у двух и более игроков, им присваиваются одинаковые места, но следующее по порядку место пропускается =РАНГ(C23;$C$23:$H$23). Не наш вариант.
2. для того чтобы уйти от этого написал следующее:
Код
=РАНГ(C23;$C$23:$H$23;1)+СЧЁТЕСЛИ($B$23:B23;C23)
проблема с пропуском занимаемого места ушла, но теперь, при одинаковом количестве очков занимаемое место ставиться некорректно:
Игрок 1- 1 очко 1 место
Игрок 2- 1 очко 2 место
Игрок 3 -2 очка 3 место
Т.е. игрокам с одинаковым количеством очков присваивается различные ранги, хотя по сути они должны быть на одном месте..

Подразумевается чтобы формула присваивала с такой логикой:

Игрок 1- 1 очко 1 место
Игрок 2- 1 очко 1 место
Игрок 3 -2 очка 2 место

3. Пошел глубже и сотворил вот такое:
Код
=ЕСЛИ($C$23:$H$23<=0;РАНГ(C23;$C$23:$H$23;1);СУММ(--(ЧАСТОТА(($C$23:$H$23<C23)*$C$23:$H$23;$C$23:$H$23)>0)))


Но не могу понять причину ошибки, некоторые места дублируются в независимости от количества набранных очков. Ошибку исправить не могу, поэтому далее в поисках и познании вселенной Excel/ Думаю каким еще способом можно добиться желаемого.

Есть какие нибудь мысли как реализовать такую идею? %)
К сообщению приложен файл: __UNO.xlsx(14Kb)


Сообщение отредактировал Manyasha - Четверг, 25.08.2016, 11:09
 
Ответить
СообщениеДоброго времени суток, Уважаемые форумчане!

Прошу Вашего совета:

Предыстория: Довольно часто практикуем с друзьями посиделки и игру в UNO. Смысл набрать наименьшее количество очков в процессе игры. Со временем начал обращать внимание что как то не очень хочется кому либо складывать очки, да и могут быть ошибки.

Суть идеи. Написать формулу, которая бы считал общее количество очков(ну с этим совсем просто). А вот назначение занимаемого места с этим столкнулся с несколькими нюансами:
1.При использовании функции РАНГ, и совпадении количества очков у двух и более игроков, им присваиваются одинаковые места, но следующее по порядку место пропускается =РАНГ(C23;$C$23:$H$23). Не наш вариант.
2. для того чтобы уйти от этого написал следующее:
Код
=РАНГ(C23;$C$23:$H$23;1)+СЧЁТЕСЛИ($B$23:B23;C23)
проблема с пропуском занимаемого места ушла, но теперь, при одинаковом количестве очков занимаемое место ставиться некорректно:
Игрок 1- 1 очко 1 место
Игрок 2- 1 очко 2 место
Игрок 3 -2 очка 3 место
Т.е. игрокам с одинаковым количеством очков присваивается различные ранги, хотя по сути они должны быть на одном месте..

Подразумевается чтобы формула присваивала с такой логикой:

Игрок 1- 1 очко 1 место
Игрок 2- 1 очко 1 место
Игрок 3 -2 очка 2 место

3. Пошел глубже и сотворил вот такое:
Код
=ЕСЛИ($C$23:$H$23<=0;РАНГ(C23;$C$23:$H$23;1);СУММ(--(ЧАСТОТА(($C$23:$H$23<C23)*$C$23:$H$23;$C$23:$H$23)>0)))


Но не могу понять причину ошибки, некоторые места дублируются в независимости от количества набранных очков. Ошибку исправить не могу, поэтому далее в поисках и познании вселенной Excel/ Думаю каким еще способом можно добиться желаемого.

Есть какие нибудь мысли как реализовать такую идею? %)

Автор - мкс
Дата добавления - 25.08.2016 в 09:23
buchlotnik Дата: Четверг, 25.08.2016, 11:06 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=1+СУММПРОИЗВ(($C$23:$H$23<C23)/(СЧЁТЕСЛИ($C$23:$H$23;$C$23:$H$23)))

так проще:
Код
=СУММПРОИЗВ(($C$23:$H$23<=C23)/(СЧЁТЕСЛИ($C$23:$H$23;$C$23:$H$23)))
К сообщению приложен файл: _UNO.xlsx(14Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 25.08.2016, 11:08
 
Ответить
Сообщениетак нужно?
Код
=1+СУММПРОИЗВ(($C$23:$H$23<C23)/(СЧЁТЕСЛИ($C$23:$H$23;$C$23:$H$23)))

так проще:
Код
=СУММПРОИЗВ(($C$23:$H$23<=C23)/(СЧЁТЕСЛИ($C$23:$H$23;$C$23:$H$23)))

Автор - buchlotnik
Дата добавления - 25.08.2016 в 11:06
мкс Дата: Четверг, 25.08.2016, 11:14 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 60% ±

Excel 2010
так нужно?


ОГРОМНЕЙШЕЕ спасибо, то, что нужно!


Сообщение отредактировал Manyasha - Четверг, 25.08.2016, 11:18
 
Ответить
Сообщение
так нужно?


ОГРОМНЕЙШЕЕ спасибо, то, что нужно!

Автор - мкс
Дата добавления - 25.08.2016 в 11:14
мкс Дата: Четверг, 25.08.2016, 13:17 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 60% ±

Excel 2010
buchlotnik, А если в данной формуле :
Перевод / Translate
Код
=СУММПРОИЗВ(($C$23:$H$23<=C23)/(СЧЁТЕСЛИ($C$23:$H$23;$C$23:$H$23)))


вместо последнего условия СЧЕТЕСЛИ использовать просто деление на 1? Я же правильно понимаю что результат выполнения данного кусочка формулы всегда равен 1?

Код
=СУММПРОИЗВ(($C$23:$H$23<=C23)/1)


Сообщение отредактировал Manyasha - Четверг, 25.08.2016, 13:35
 
Ответить
Сообщениеbuchlotnik, А если в данной формуле :
Перевод / Translate
Код
=СУММПРОИЗВ(($C$23:$H$23<=C23)/(СЧЁТЕСЛИ($C$23:$H$23;$C$23:$H$23)))


вместо последнего условия СЧЕТЕСЛИ использовать просто деление на 1? Я же правильно понимаю что результат выполнения данного кусочка формулы всегда равен 1?

Код
=СУММПРОИЗВ(($C$23:$H$23<=C23)/1)

Автор - мкс
Дата добавления - 25.08.2016 в 13:17
buchlotnik Дата: Четверг, 25.08.2016, 13:26 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
использовать просто деление на 1?
а зачем тогда вообще делить? (можно ещё умножить на 1 или прибавить ноль :) )
Цитата
Я же правильно понимаю
нет, не правильно Формулы - Зависимости формул - Вычислить формулу - посмотрите как работает формула или в строке формул выделите интересующий фрагмент формулы и нажмите F9


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 25.08.2016, 13:26
 
Ответить
Сообщение
Цитата
использовать просто деление на 1?
а зачем тогда вообще делить? (можно ещё умножить на 1 или прибавить ноль :) )
Цитата
Я же правильно понимаю
нет, не правильно Формулы - Зависимости формул - Вычислить формулу - посмотрите как работает формула или в строке формул выделите интересующий фрагмент формулы и нажмите F9

Автор - buchlotnik
Дата добавления - 25.08.2016 в 13:26
китин Дата: Четверг, 25.08.2016, 13:31 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
результат выполнения данного кусочка формулы всегда равен 1

неа. данная формула дает нам массив вот такой
Код
{2;2;2;2;1;1}


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
результат выполнения данного кусочка формулы всегда равен 1

неа. данная формула дает нам массив вот такой
Код
{2;2;2;2;1;1}

Автор - китин
Дата добавления - 25.08.2016 в 13:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Занимаемые места в зависимости от набранных очко (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!