Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет ячеек по заданному условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет ячеек по заданному условию (Формулы/Formulas)
Подсчет ячеек по заданному условию
AlekseyM Дата: Четверг, 25.08.2016, 09:58 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброе утро!
Подскажите. пожалуйста, как можно присвоить уникальные номера договорам в разрезе контрагентов. Есть список фирм. в каждой фирме несколько договоров. Например В фирме "А" два разных договора, нужно их пронумеровать по порядку, при этом договоры могут повторяться (столбец E).
Спасибо
К сообщению приложен файл: _Microsoft_Exce.xlsx(11Kb)
 
Ответить
СообщениеДоброе утро!
Подскажите. пожалуйста, как можно присвоить уникальные номера договорам в разрезе контрагентов. Есть список фирм. в каждой фирме несколько договоров. Например В фирме "А" два разных договора, нужно их пронумеровать по порядку, при этом договоры могут повторяться (столбец E).
Спасибо

Автор - AlekseyM
Дата добавления - 25.08.2016 в 09:58
Manyasha Дата: Четверг, 25.08.2016, 11:30 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1817
Репутация: 751 ±
Замечаний: 0% ±

Excel 2007, 2010
AlekseyM, здравствуйте. Не поняла, почему в последней строчке стоит 1, а не 3...
такой вариант подойдет?
Код
=ЕСЛИ(B2<>"";ЕСЛИ(СУММПРОИЗВ(($B$2:B2=B2)*($C$2:C2=C2))=1;1+СУММПРОИЗВ(($B$1:B1=B2)*($F$1:F1<>""));"");"")
К сообщению приложен файл: 9338334.xlsx(12Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеAlekseyM, здравствуйте. Не поняла, почему в последней строчке стоит 1, а не 3...
такой вариант подойдет?
Код
=ЕСЛИ(B2<>"";ЕСЛИ(СУММПРОИЗВ(($B$2:B2=B2)*($C$2:C2=C2))=1;1+СУММПРОИЗВ(($B$1:B1=B2)*($F$1:F1<>""));"");"")

Автор - Manyasha
Дата добавления - 25.08.2016 в 11:30
AlekseyM Дата: Четверг, 25.08.2016, 11:44 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Это я ошибся:)
спасибо огромное!!!
 
Ответить
СообщениеЭто я ошибся:)
спасибо огромное!!!

Автор - AlekseyM
Дата добавления - 25.08.2016 в 11:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет ячеек по заданному условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!