Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Развертывание данных/перегруппировка данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Развертывание данных/перегруппировка данных (Формулы/Formulas)
Развертывание данных/перегруппировка данных
AndreyKabanov Дата: Четверг, 25.08.2016, 11:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Друзья, добрый день,

не могу решить простую задачку в Excel, прошу помощи:

есть таблица состоящая из овермного столбцов, в первой строке написан артикул, в строках ниже написано возможные значение для этого артикула.
необходимо создать таблицу, состоящую только из 2 столбцов: в 1 столбце артикулы, во 2 столбце его возможные значения. То есть в первой строчке в первом столбце должен быть артикул №1, а во втором столбце первой строчки значение№1, далее на след. строке артикул №1 и значение№2 и т.д., потом идет артикул№2 и его первое значение.

Для наглядности прикрепляю файл.

Заранее спасибо
К сообщению приложен файл: Excel_.xlsx(10Kb)
 
Ответить
СообщениеДрузья, добрый день,

не могу решить простую задачку в Excel, прошу помощи:

есть таблица состоящая из овермного столбцов, в первой строке написан артикул, в строках ниже написано возможные значение для этого артикула.
необходимо создать таблицу, состоящую только из 2 столбцов: в 1 столбце артикулы, во 2 столбце его возможные значения. То есть в первой строчке в первом столбце должен быть артикул №1, а во втором столбце первой строчки значение№1, далее на след. строке артикул №1 и значение№2 и т.д., потом идет артикул№2 и его первое значение.

Для наглядности прикрепляю файл.

Заранее спасибо

Автор - AndreyKabanov
Дата добавления - 25.08.2016 в 11:27
Manyasha Дата: Четверг, 25.08.2016, 11:35 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 662 ±
Замечаний: 0% ±

Excel 2007, 2010
AndreyKabanov, здравствуйте.

Посмотрите Готовое решение: Редизайнер таблиц (преобразование в плоскую таблицу)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеAndreyKabanov, здравствуйте.

Посмотрите Готовое решение: Редизайнер таблиц (преобразование в плоскую таблицу)

Автор - Manyasha
Дата добавления - 25.08.2016 в 11:35
китин Дата: Четверг, 25.08.2016, 11:48 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
формула массива.
Код
=ИНДЕКС($A$4:$B$7;НАИМЕНЬШИЙ(ЕСЛИ($A$3:$B$3=$A13;СТРОКА($A$4:$A$7)-3);СЧЁТЕСЛИ($A$13:$A13;A13));ПОИСКПОЗ($A13;$A$3:$B$3;0))

(если кол-во строк одинаковое)
К сообщению приложен файл: 7777777.xlsx(11Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеформула массива.
Код
=ИНДЕКС($A$4:$B$7;НАИМЕНЬШИЙ(ЕСЛИ($A$3:$B$3=$A13;СТРОКА($A$4:$A$7)-3);СЧЁТЕСЛИ($A$13:$A13;A13));ПОИСКПОЗ($A13;$A$3:$B$3;0))

(если кол-во строк одинаковое)

Автор - китин
Дата добавления - 25.08.2016 в 11:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Развертывание данных/перегруппировка данных (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!