Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подставить в колонку остаток, с учетом минимальной цены - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставить в колонку остаток, с учетом минимальной цены (Формулы/Formulas)
Подставить в колонку остаток, с учетом минимальной цены
Mark1976 Дата: Четверг, 25.08.2016, 21:13 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 418
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго вечера. Помогите решить задачу. Есть мониторинг цен на много строк. Очень важно отследить, чтобы кол-ва товара с минимальной ценой было достаточно. Т.е. если цена минимальная и кол-во очень маленькое я меняю цену. Бегать по строчкам очень тяжело. Возможно формулами это сделать? Отчет выгружается из 1С. Результат на листе "После". Заранее спасибо.
К сообщению приложен файл: 0902033.xls(21Kb)
 
Ответить
СообщениеДоброго вечера. Помогите решить задачу. Есть мониторинг цен на много строк. Очень важно отследить, чтобы кол-ва товара с минимальной ценой было достаточно. Т.е. если цена минимальная и кол-во очень маленькое я меняю цену. Бегать по строчкам очень тяжело. Возможно формулами это сделать? Отчет выгружается из 1С. Результат на листе "После". Заранее спасибо.

Автор - Mark1976
Дата добавления - 25.08.2016 в 21:13
Nic70y Дата: Четверг, 25.08.2016, 21:26 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4083
Репутация: 872 ±
Замечаний: 0% ±

Excel 2013
формула массива: (желтые)
Код
=МИН(ЕСЛИ(МИН(ЕСЛИ(E$12:K$12="Цена";E13:K13))=ЕСЛИ(E$12:K$12="Цена";E13:K13);G13:M13))
так надо?
а может так: (зеленые)
Код
=МИН(ЕСЛИ(C22=ЕСЛИ(E$12:K$12="Цена";E22:K22);G22:M22))
К сообщению приложен файл: 0513343.xls(32Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 25.08.2016, 21:29
 
Ответить
Сообщениеформула массива: (желтые)
Код
=МИН(ЕСЛИ(МИН(ЕСЛИ(E$12:K$12="Цена";E13:K13))=ЕСЛИ(E$12:K$12="Цена";E13:K13);G13:M13))
так надо?
а может так: (зеленые)
Код
=МИН(ЕСЛИ(C22=ЕСЛИ(E$12:K$12="Цена";E22:K22);G22:M22))

Автор - Nic70y
Дата добавления - 25.08.2016 в 21:26
buchlotnik Дата: Четверг, 25.08.2016, 21:33 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3004
Репутация: 839 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так что ли?
Код
=ИНДЕКС(E3:M3;ПОИСКПОЗ(C3;E3:M3;0)+2)
или что эквивалентно
Код
=ИНДЕКС(G3:O3;ПОИСКПОЗ(C3;E3:M3;0))
К сообщению приложен файл: 1831848.xls(28Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 25.08.2016, 21:36
 
Ответить
Сообщениетак что ли?
Код
=ИНДЕКС(E3:M3;ПОИСКПОЗ(C3;E3:M3;0)+2)
или что эквивалентно
Код
=ИНДЕКС(G3:O3;ПОИСКПОЗ(C3;E3:M3;0))

Автор - buchlotnik
Дата добавления - 25.08.2016 в 21:33
Mark1976 Дата: Четверг, 25.08.2016, 21:44 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 418
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо.


Сообщение отредактировал Mark1976 - Четверг, 25.08.2016, 21:55
 
Ответить
СообщениеСпасибо.

Автор - Mark1976
Дата добавления - 25.08.2016 в 21:44
Mark1976 Дата: Четверг, 25.08.2016, 21:45 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 418
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, на моем файле что то не сработало? А чем цвет отличается?
 
Ответить
СообщениеNic70y, на моем файле что то не сработало? А чем цвет отличается?

Автор - Mark1976
Дата добавления - 25.08.2016 в 21:45
buchlotnik Дата: Четверг, 25.08.2016, 21:49 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3004
Репутация: 839 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
если еще один поставщик прибавится
Mark1976, может быть, растянуть диапазоны? Как Вы считаете?
[p.s.]это мой последний ответ данному пользователю


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
если еще один поставщик прибавится
Mark1976, может быть, растянуть диапазоны? Как Вы считаете?
[p.s.]это мой последний ответ данному пользователю

Автор - buchlotnik
Дата добавления - 25.08.2016 в 21:49
Nic70y Дата: Четверг, 25.08.2016, 21:50 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4083
Репутация: 872 ±
Замечаний: 0% ±

Excel 2013
на моем файле что то не сработало?
не понял вопроса.
я просто выделил разные формулы.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
на моем файле что то не сработало?
не понял вопроса.
я просто выделил разные формулы.

Автор - Nic70y
Дата добавления - 25.08.2016 в 21:50
Mark1976 Дата: Четверг, 25.08.2016, 21:51 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 418
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Процесс мониторинга теперь ускорится.


Сообщение отредактировал Mark1976 - Четверг, 25.08.2016, 21:56
 
Ответить
СообщениеПроцесс мониторинга теперь ускорится.

Автор - Mark1976
Дата добавления - 25.08.2016 в 21:51
Mark1976 Дата: Четверг, 25.08.2016, 22:06 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 418
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Да, диапазон растянул, и все получилось.
 
Ответить
СообщениеДа, диапазон растянул, и все получилось.

Автор - Mark1976
Дата добавления - 25.08.2016 в 22:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставить в колонку остаток, с учетом минимальной цены (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!