Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вставка строки со значением через 5 строк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка строки со значением через 5 строк (Формулы/Formulas)
Вставка строки со значением через 5 строк
AmsterDam Дата: Пятница, 26.08.2016, 15:26 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Здравствуйте.
Скажите пожалуйста как реализовать:
Есть 1 столбец, как можно вставить постоянное значение через 5 строк?
А
1
2
3
4
5
6 Значение
7
8
9
10
11
12 Значение

Пример прикладываю
К сообщению приложен файл: _Microsoft_Offi.xlsx(11Kb)


Сообщение отредактировал AmsterDam - Пятница, 26.08.2016, 15:41
 
Ответить
СообщениеЗдравствуйте.
Скажите пожалуйста как реализовать:
Есть 1 столбец, как можно вставить постоянное значение через 5 строк?
А
1
2
3
4
5
6 Значение
7
8
9
10
11
12 Значение

Пример прикладываю

Автор - AmsterDam
Дата добавления - 26.08.2016 в 15:26
китин Дата: Пятница, 26.08.2016, 15:35 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4117
Репутация: 636 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
какое значение? куда вставить(гусары молчать!!!!) 36 сообщений на форуме экстрасенсов


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 26.08.2016, 15:36
 
Ответить
Сообщениекакое значение? куда вставить(гусары молчать!!!!) 36 сообщений на форуме экстрасенсов

Автор - китин
Дата добавления - 26.08.2016 в 15:35
AmsterDam Дата: Пятница, 26.08.2016, 15:42 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Извиняюсь, пример приложил
 
Ответить
СообщениеИзвиняюсь, пример приложил

Автор - AmsterDam
Дата добавления - 26.08.2016 в 15:42
buchlotnik Дата: Пятница, 26.08.2016, 15:48 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2627
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Код
=ЕСЛИ(ОСТАТ(A2;6);A2;9999)
и формат [Красный][=9999]0;0 B)
К сообщению приложен файл: 3714193.xlsx(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Код
=ЕСЛИ(ОСТАТ(A2;6);A2;9999)
и формат [Красный][=9999]0;0 B)

Автор - buchlotnik
Дата добавления - 26.08.2016 в 15:48
китин Дата: Пятница, 26.08.2016, 15:50 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4117
Репутация: 636 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
по вашему примеру
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A1);6)=0;9999;СТРОКА(A1))
К сообщению приложен файл: 654987.xlsx(12Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениепо вашему примеру
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A1);6)=0;9999;СТРОКА(A1))

Автор - китин
Дата добавления - 26.08.2016 в 15:50
AmsterDam Дата: Пятница, 26.08.2016, 15:52 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
=ЕСЛИ(ОСТАТ(A2;6);A2;9999)

Спасибо!
А если будет буквенное значение, например "info@mail.ru"
По вашей формуле пишет "Имя"
 
Ответить
Сообщение
=ЕСЛИ(ОСТАТ(A2;6);A2;9999)

Спасибо!
А если будет буквенное значение, например "info@mail.ru"
По вашей формуле пишет "Имя"

Автор - AmsterDam
Дата добавления - 26.08.2016 в 15:52
китин Дата: Пятница, 26.08.2016, 15:56 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4117
Репутация: 636 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вместо 9999 поставьте "info@mail.ru".именно в кавычках
А если будет буквенное значение


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениевместо 9999 поставьте "info@mail.ru".именно в кавычках
А если будет буквенное значение

Автор - китин
Дата добавления - 26.08.2016 в 15:56
buchlotnik Дата: Пятница, 26.08.2016, 15:56 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2627
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
По вашей формуле пишет "Имя"
показывайте в файле, но подозреваю, что вы текст в кавычки не поставили


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
По вашей формуле пишет "Имя"
показывайте в файле, но подозреваю, что вы текст в кавычки не поставили

Автор - buchlotnik
Дата добавления - 26.08.2016 в 15:56
AmsterDam Дата: Пятница, 26.08.2016, 15:59 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Ухх )))
Неправильно я пример написал )))

Прикладываю правильный )))
К сообщению приложен файл: 7669093.xlsx(12Kb)
 
Ответить
СообщениеУхх )))
Неправильно я пример написал )))

Прикладываю правильный )))

Автор - AmsterDam
Дата добавления - 26.08.2016 в 15:59
Nic70y Дата: Пятница, 26.08.2016, 16:03 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3918
Репутация: 829 ±
Замечаний: 0% ±

Excel 2013
Неправильно я пример написал
так я и знал, но новый пример еще хуже
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A1);6);ИНДЕКС(A:A;ОСТАТ(СТРОКА(A1);6)+ЦЕЛОЕ(СТРОКА(A1)/6)*5+1);9999)
К сообщению приложен файл: 1622446.xlsx(12Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Неправильно я пример написал
так я и знал, но новый пример еще хуже
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A1);6);ИНДЕКС(A:A;ОСТАТ(СТРОКА(A1);6)+ЦЕЛОЕ(СТРОКА(A1)/6)*5+1);9999)

Автор - Nic70y
Дата добавления - 26.08.2016 в 16:03
китин Дата: Пятница, 26.08.2016, 16:03 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4117
Репутация: 636 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну дык совсем другой коленкор
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A1);6)=0;"kirill@mail.ru";"info1@mail.ru")
К сообщению приложен файл: _7669093.xlsx(12Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 26.08.2016, 16:03
 
Ответить
Сообщениену дык совсем другой коленкор
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A1);6)=0;"kirill@mail.ru";"info1@mail.ru")

Автор - китин
Дата добавления - 26.08.2016 в 16:03
buchlotnik Дата: Пятница, 26.08.2016, 16:16 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2627
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
чутка короче B)
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A1);6);"info1@mail.ru";"kirill@mail.ru")


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениечутка короче B)
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A1);6);"info1@mail.ru";"kirill@mail.ru")

Автор - buchlotnik
Дата добавления - 26.08.2016 в 16:16
Gustav Дата: Пятница, 26.08.2016, 16:20 | Сообщение № 13
Группа: Друзья
Ранг: Старожил
Сообщений: 1348
Репутация: 534 ±
Замечаний: 0% ±

начинал с Excel 4.0...
А можно еще по-тупому ручками, с сортировкой. Хотя, если синие и красные будут все разные, но надо будет также "через 5", то вполне может и сгодиться без лукавых мудрствований.

Кароч. Нумеруем протяжкой в соседней колонке синие:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
...

После всех синих ниже нумеруем протяжкой в соседней колонке красные:
5,1
10,1
15,1
...

И, наконец, сортируем по этой соседней колонке с номерами!


Мой tip box - яд 41001663842605
 
Ответить
СообщениеА можно еще по-тупому ручками, с сортировкой. Хотя, если синие и красные будут все разные, но надо будет также "через 5", то вполне может и сгодиться без лукавых мудрствований.

Кароч. Нумеруем протяжкой в соседней колонке синие:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
...

После всех синих ниже нумеруем протяжкой в соседней колонке красные:
5,1
10,1
15,1
...

И, наконец, сортируем по этой соседней колонке с номерами!

Автор - Gustav
Дата добавления - 26.08.2016 в 16:20
AmsterDam Дата: Пятница, 26.08.2016, 16:22 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Nic70y - спасибо огромное! Все работает
 
Ответить
СообщениеNic70y - спасибо огромное! Все работает

Автор - AmsterDam
Дата добавления - 26.08.2016 в 16:22
jakim Дата: Пятница, 26.08.2016, 16:24 | Сообщение № 15
Группа: Друзья
Ранг: Ветеран
Сообщений: 763
Репутация: 196 ±
Замечаний: 0% ±

Посмотрите приложение: может угадал.
К сообщению приложен файл: Microsoft_Offi-.xlsx(12Kb)
 
Ответить
Сообщение
Посмотрите приложение: может угадал.

Автор - jakim
Дата добавления - 26.08.2016 в 16:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка строки со значением через 5 строк (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!