Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подсчет данных в ячейках по строкам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет данных в ячейках по строкам (Формулы/Formulas)
подсчет данных в ячейках по строкам
champ Дата: Понедельник, 29.08.2016, 19:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Прошу помочь,
необходимо формулами подсчитать сумму столбцах м1 и м2, и кол-во в столбцах в,н,п
Данные необходимо брать из строк
для 9-й строки в столбце "в" в диапазоне I9:T9 подсчитать кол-во ячеек по условиям I9 > K9, L9>N9, O9>Q9, R9>T9
в столбце "н" I9 = K9, L9=N9, O9=Q9, R9=T9
в столбце "п" I9 < K9, L9<N9, O9<Q9, R9<T9
в "м1" сумма I9 , L9, O9, R9,
в "м2" сумма K9, N9, Q9, T9
К сообщению приложен файл: 2671176_.xlsx(12Kb)
 
Ответить
СообщениеПрошу помочь,
необходимо формулами подсчитать сумму столбцах м1 и м2, и кол-во в столбцах в,н,п
Данные необходимо брать из строк
для 9-й строки в столбце "в" в диапазоне I9:T9 подсчитать кол-во ячеек по условиям I9 > K9, L9>N9, O9>Q9, R9>T9
в столбце "н" I9 = K9, L9=N9, O9=Q9, R9=T9
в столбце "п" I9 < K9, L9<N9, O9<Q9, R9<T9
в "м1" сумма I9 , L9, O9, R9,
в "м2" сумма K9, N9, Q9, T9

Автор - champ
Дата добавления - 29.08.2016 в 19:43
Pelena Дата: Понедельник, 29.08.2016, 20:02 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Так подойдёт?
К сообщению приложен файл: 3761248.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак подойдёт?

Автор - Pelena
Дата добавления - 29.08.2016 в 20:02
champ Дата: Понедельник, 29.08.2016, 20:09 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
не совсем
в случае большого количества ячеек будет длинная формула ,
возможно есть какой то другой способ?
можно ли подсчитать сумму 1, 4, 7 и т.д. ячейки в строке I9:T9 для столбца "м1"
кол-во ячеек удовлетворяющих условиям 1ячейка >3ячейка, 4ячейка>6ячейка и т.д. в строке I9:T9 для столбца "м1"



Сообщение отредактировал champ - Понедельник, 29.08.2016, 20:16
 
Ответить
Сообщениене совсем
в случае большого количества ячеек будет длинная формула ,
возможно есть какой то другой способ?
можно ли подсчитать сумму 1, 4, 7 и т.д. ячейки в строке I9:T9 для столбца "м1"
кол-во ячеек удовлетворяющих условиям 1ячейка >3ячейка, 4ячейка>6ячейка и т.д. в строке I9:T9 для столбца "м1"


Автор - champ
Дата добавления - 29.08.2016 в 20:09
Pelena Дата: Понедельник, 29.08.2016, 20:21 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Так?

UPD. Перевложила файл
К сообщению приложен файл: 4369232.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816


Сообщение отредактировал Pelena - Понедельник, 29.08.2016, 20:26
 
Ответить
СообщениеТак?

UPD. Перевложила файл

Автор - Pelena
Дата добавления - 29.08.2016 в 20:21
champ Дата: Понедельник, 29.08.2016, 20:54 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, спасибо - то что надо, благодарю
 
Ответить
СообщениеPelena, спасибо - то что надо, благодарю

Автор - champ
Дата добавления - 29.08.2016 в 20:54
buchlotnik Дата: Понедельник, 29.08.2016, 21:30 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
у меня так вышло:
Код
=СУММПРОИЗВ(ЕЧИСЛО(I9:R9)*(I9:R9>K9:T9))
Код
=СУММПРОИЗВ(ЕЧИСЛО(I9:R9)*(I9:R9=K9:T9))
Код
=СУММПРОИЗВ(ЕЧИСЛО(K9:T9)*(I9:R9<K9:T9))
Код
=СУММ(ЕСЛИОШИБКА((I9:R9*(J9:S9=":"));0))
Код
=СУММ(ЕСЛИОШИБКА((K9:T9*(J9:S9=":"));0))
К сообщению приложен файл: 0894998.xlsx(13Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеу меня так вышло:
Код
=СУММПРОИЗВ(ЕЧИСЛО(I9:R9)*(I9:R9>K9:T9))
Код
=СУММПРОИЗВ(ЕЧИСЛО(I9:R9)*(I9:R9=K9:T9))
Код
=СУММПРОИЗВ(ЕЧИСЛО(K9:T9)*(I9:R9<K9:T9))
Код
=СУММ(ЕСЛИОШИБКА((I9:R9*(J9:S9=":"));0))
Код
=СУММ(ЕСЛИОШИБКА((K9:T9*(J9:S9=":"));0))

Автор - buchlotnik
Дата добавления - 29.08.2016 в 21:30
champ Дата: Понедельник, 29.08.2016, 23:30 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, 1, 2 и 3 формулы не всегда считают так как надо, 4 и 5 все правильно считает
Приложу другой пример с большим числом данных когда не срабатывают формулы
К сообщению приложен файл: _123.xlsx(20Kb)
 
Ответить
Сообщениеbuchlotnik, 1, 2 и 3 формулы не всегда считают так как надо, 4 и 5 все правильно считает
Приложу другой пример с большим числом данных когда не срабатывают формулы

Автор - champ
Дата добавления - 29.08.2016 в 23:30
buchlotnik Дата: Понедельник, 29.08.2016, 23:38 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
добавил проверку на двоеточие
Код
=СУММПРОИЗВ(ЕЧИСЛО($D4:$AQ4)*(E4:AR4=":")*($D4:$AQ4>$F4:$AS4))
К сообщению приложен файл: 4028128.xlsx(21Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 29.08.2016, 23:39
 
Ответить
Сообщениедобавил проверку на двоеточие
Код
=СУММПРОИЗВ(ЕЧИСЛО($D4:$AQ4)*(E4:AR4=":")*($D4:$AQ4>$F4:$AS4))

Автор - buchlotnik
Дата добавления - 29.08.2016 в 23:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет данных в ячейках по строкам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!