Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборочный перенос данных из одной таблицы в другую - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборочный перенос данных из одной таблицы в другую (Формулы/Formulas)
Выборочный перенос данных из одной таблицы в другую
Машака Дата: Среда, 31.08.2016, 13:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

2013
Добрый день!
Читала аналогичные темы на других форумах, но в своем примере не получается прописать формулу.
Задание в примере, если кратко - заполнять табличку по одному из продуктов, беря данные из общей таблицы со всеми продуктами. В моем примере - в общей таблице фрукты и овощи, мне надо заполнить данные только по фруктам, и столбцы тоже выборочно. Пытаюсь использовать поискпоз и индекс, но не получается.
Прошу помочь, что я делаю не так?
К сообщению приложен файл: 0087983.xlsx(9Kb)


Сообщение отредактировал Машака - Среда, 31.08.2016, 13:51
 
Ответить
СообщениеДобрый день!
Читала аналогичные темы на других форумах, но в своем примере не получается прописать формулу.
Задание в примере, если кратко - заполнять табличку по одному из продуктов, беря данные из общей таблицы со всеми продуктами. В моем примере - в общей таблице фрукты и овощи, мне надо заполнить данные только по фруктам, и столбцы тоже выборочно. Пытаюсь использовать поискпоз и индекс, но не получается.
Прошу помочь, что я делаю не так?

Автор - Машака
Дата добавления - 31.08.2016 в 13:48
sboy Дата: Среда, 31.08.2016, 14:01 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 577
Репутация: 153 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Попробуйте пользоваться сводной таблицей. Пример во вложении
К сообщению приложен файл: 3318302.xlsx(13Kb)
 
Ответить
СообщениеДобрый день.
Попробуйте пользоваться сводной таблицей. Пример во вложении

Автор - sboy
Дата добавления - 31.08.2016 в 14:01
Машака Дата: Среда, 31.08.2016, 14:19 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

2013
Попробуйте пользоваться сводной таблицей


Нет, сводные я хорошо знаю, они не подходят. В реале там и столбцов больше, и с этой новой таблички все сразу идет в презентацию, поэтому важен формат, а там в шапках сразу названия меняются типа" сумма по полю..."
 
Ответить
Сообщение
Попробуйте пользоваться сводной таблицей


Нет, сводные я хорошо знаю, они не подходят. В реале там и столбцов больше, и с этой новой таблички все сразу идет в презентацию, поэтому важен формат, а там в шапках сразу названия меняются типа" сумма по полю..."

Автор - Машака
Дата добавления - 31.08.2016 в 14:19
sboy Дата: Среда, 31.08.2016, 14:28 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 577
Репутация: 153 ±
Замечаний: 0% ±

Excel 2010
Тогда посмотрите может ВПР-ом подойдет?
формула в "Название"
Код
=ЕСЛИОШИБКА(ВПР($L$1;$A3:$D$11;2;0);"")

формула в "Цвет"
Код
=ЕСЛИОШИБКА(ВПР(J3;$B$3:$D$11;3;0);"")
К сообщению приложен файл: 8623530.xlsx(9Kb)
 
Ответить
СообщениеТогда посмотрите может ВПР-ом подойдет?
формула в "Название"
Код
=ЕСЛИОШИБКА(ВПР($L$1;$A3:$D$11;2;0);"")

формула в "Цвет"
Код
=ЕСЛИОШИБКА(ВПР(J3;$B$3:$D$11;3;0);"")

Автор - sboy
Дата добавления - 31.08.2016 в 14:28
jakim Дата: Среда, 31.08.2016, 14:39 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 760
Репутация: 195 ±
Замечаний: 0% ±

Попробуйте так с применением функции АГРЕГАТ.
К сообщению приложен файл: 6254955.xlsx(10Kb)
 
Ответить
Сообщение
Попробуйте так с применением функции АГРЕГАТ.

Автор - jakim
Дата добавления - 31.08.2016 в 14:39
Машака Дата: Среда, 31.08.2016, 17:34 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

2013
Попробуйте так с применением функции АГРЕГАТ.

Да, формула для меня запредельная, но работает!!! буду разбираться, огромное спасибо за ваш труд!
 
Ответить
Сообщение
Попробуйте так с применением функции АГРЕГАТ.

Да, формула для меня запредельная, но работает!!! буду разбираться, огромное спасибо за ваш труд!

Автор - Машака
Дата добавления - 31.08.2016 в 17:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборочный перенос данных из одной таблицы в другую (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!