Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных из одного столбца по разным - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из одного столбца по разным (Формулы/Formulas)
Перенос данных из одного столбца по разным
Ediger Дата: Суббота, 03.09.2016, 17:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Все данные расположены в одном столбце последовательно. Необходимо разбить все данные на 6 столбцов. Первую ячейку в первый столбец, шестую в шестой, седьмую в первый и т.д.
Количество строк 140058.

К сообщению приложен файл: 6448071.xls(24Kb)
 
Ответить
СообщениеВсе данные расположены в одном столбце последовательно. Необходимо разбить все данные на 6 столбцов. Первую ячейку в первый столбец, шестую в шестой, седьмую в первый и т.д.
Количество строк 140058.


Автор - Ediger
Дата добавления - 03.09.2016 в 17:53
_Boroda_ Дата: Суббота, 03.09.2016, 18:03 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС($A$1:$A$140058;(СТРОКА(A1)-1)*6+СТОЛБЕЦ(A1))

Предваряя очевидный вопрос - сознательно использовал ссылки в СТРОКА и СТОЛБЕЦ для того, чтобы результат можно было поместить в любое место
К сообщению приложен файл: 6448071_1.xls(30Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС($A$1:$A$140058;(СТРОКА(A1)-1)*6+СТОЛБЕЦ(A1))

Предваряя очевидный вопрос - сознательно использовал ссылки в СТРОКА и СТОЛБЕЦ для того, чтобы результат можно было поместить в любое место

Автор - _Boroda_
Дата добавления - 03.09.2016 в 18:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из одного столбца по разным (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!