Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сформировать таблицу по 1 критерию по заданным столбцам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сформировать таблицу по 1 критерию по заданным столбцам (Формулы/Formulas)
Сформировать таблицу по 1 критерию по заданным столбцам
Saff Дата: Понедельник, 05.09.2016, 12:42 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 20% ±

Добрый день!
Не могу придумать формулу по которой бы можно было сформировать таблицу по 1 критерию по заданным столбцам из свода
Можно либо формулой массива либо без массива и без макросов )
Я так понимаю вариантов тут много, но из тех которые я знаю работают частично. Что-то похожее нашёл тут.
Подробности в файле.
Если что буду ждать комментариев )
К сообщению приложен файл: 11.xlsx(47Kb)


Сообщение отредактировал Saff - Понедельник, 05.09.2016, 12:57
 
Ответить
СообщениеДобрый день!
Не могу придумать формулу по которой бы можно было сформировать таблицу по 1 критерию по заданным столбцам из свода
Можно либо формулой массива либо без массива и без макросов )
Я так понимаю вариантов тут много, но из тех которые я знаю работают частично. Что-то похожее нашёл тут.
Подробности в файле.
Если что буду ждать комментариев )

Автор - Saff
Дата добавления - 05.09.2016 в 12:42
Szekerfehesvar Дата: Понедельник, 19.09.2016, 14:20 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 6 ±
Замечаний: 20% ±

Excel 2013
Если не принципиально построение 1 формулы для всего - то посмотрите мой вариант (на листе "свод" создан переводной столбец с индексами, для отбора ненулевых итогов года)
Отбор идет по поиску значений только указанного года, смену года поддерживает.
К сообщению приложен файл: 0663475.xlsx(51Kb)
 
Ответить
СообщениеЕсли не принципиально построение 1 формулы для всего - то посмотрите мой вариант (на листе "свод" создан переводной столбец с индексами, для отбора ненулевых итогов года)
Отбор идет по поиску значений только указанного года, смену года поддерживает.

Автор - Szekerfehesvar
Дата добавления - 19.09.2016 в 14:20
Saff Дата: Среда, 21.09.2016, 07:39 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 20% ±

Спасибо, что откликнулись на мою задачу.
Выделил жёлтым цветом ячейки. Данные не совпадают со столбцами через ВПР.
К сообщению приложен файл: 9974763.xlsx(53Kb)
 
Ответить
СообщениеСпасибо, что откликнулись на мою задачу.
Выделил жёлтым цветом ячейки. Данные не совпадают со столбцами через ВПР.

Автор - Saff
Дата добавления - 21.09.2016 в 07:39
Karataev Дата: Среда, 21.09.2016, 12:53 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
Вариант с двумя допстолбцами "I" и "J" на листе 2017. Затем формулы из столбцов "B:H" ссылаются на эти допстолбцы.
Формула (массивная формула, вводится CtrL+Shift+Enter) для допстолбца "I":
Код
=НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(свод!$A$10:$AE$213;;J5)>0;СТРОКА(свод!$A$10:$A$213);"");СТРОКА(1:1))

Формула для допстолбца "J":
Код
=ПОИСКПОЗ($E$3;свод!$6:$6;0)

Формула для "B5":
Код
=ЕСЛИОШИБКА(ИНДЕКС(свод!$A:$AE;I5;4);"")
К сообщению приложен файл: 7425017.xlsx(52Kb)


 
Ответить
СообщениеВариант с двумя допстолбцами "I" и "J" на листе 2017. Затем формулы из столбцов "B:H" ссылаются на эти допстолбцы.
Формула (массивная формула, вводится CtrL+Shift+Enter) для допстолбца "I":
Код
=НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(свод!$A$10:$AE$213;;J5)>0;СТРОКА(свод!$A$10:$A$213);"");СТРОКА(1:1))

Формула для допстолбца "J":
Код
=ПОИСКПОЗ($E$3;свод!$6:$6;0)

Формула для "B5":
Код
=ЕСЛИОШИБКА(ИНДЕКС(свод!$A:$AE;I5;4);"")

Автор - Karataev
Дата добавления - 21.09.2016 в 12:53
Saff Дата: Пятница, 23.09.2016, 12:30 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 20% ±

Шикарно!!! я знал что всё возможное возможно )))
Интересный подход в решении задачи. Всё понятно. Чуток подправил формулу, всё работает...ОГРОМНОЕ спасибо!

Понравилось решение с нумерацией очень. А можете подсказать идею, как отслеживать пункты и под пункты?
 
Ответить
СообщениеШикарно!!! я знал что всё возможное возможно )))
Интересный подход в решении задачи. Всё понятно. Чуток подправил формулу, всё работает...ОГРОМНОЕ спасибо!

Понравилось решение с нумерацией очень. А можете подсказать идею, как отслеживать пункты и под пункты?

Автор - Saff
Дата добавления - 23.09.2016 в 12:30
Karataev Дата: Пятница, 23.09.2016, 12:52 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
А можете подсказать идею, как отслеживать пункты и под пункты?

В посте 3 есть файл, на листе 2017 в столбце "A" удалите формулы и вставьте нумерацию вручную и выложите на форуме, чтобы понимать, какая должна быть нумерация.
[moder]И прочитайте ВНИМАТЕЛЬНО Правила форума[/moder]




Сообщение отредактировал _Boroda_ - Пятница, 23.09.2016, 12:54
 
Ответить
Сообщение
А можете подсказать идею, как отслеживать пункты и под пункты?

В посте 3 есть файл, на листе 2017 в столбце "A" удалите формулы и вставьте нумерацию вручную и выложите на форуме, чтобы понимать, какая должна быть нумерация.
[moder]И прочитайте ВНИМАТЕЛЬНО Правила форума[/moder]

Автор - Karataev
Дата добавления - 23.09.2016 в 12:52
Saff Дата: Пятница, 23.09.2016, 14:37 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 20% ±

Прошу прощения. Вот файл с описанием.
[moder]Нарушение п. 5q Правил форума
Я предупреждал - читайте Правила[/moder]
К сообщению приложен файл: 1083403.xlsx(53Kb)


Сообщение отредактировал Saff - Пятница, 23.09.2016, 14:39
 
Ответить
СообщениеПрошу прощения. Вот файл с описанием.
[moder]Нарушение п. 5q Правил форума
Я предупреждал - читайте Правила[/moder]

Автор - Saff
Дата добавления - 23.09.2016 в 14:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сформировать таблицу по 1 критерию по заданным столбцам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!