Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вставка в ячейку "Победитель" назв. команды по сумме баллов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка в ячейку "Победитель" назв. команды по сумме баллов (Формулы/Formulas)
Вставка в ячейку "Победитель" назв. команды по сумме баллов
vitos88 Дата: Среда, 07.09.2016, 11:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 5 ±
Замечаний: 0% ±

Добрый день! Подскажите, пожалуйста, как автоматически вставлять в ячейку "Лидирующая команда" название команды с наибольшей суммой баллов. Спасибо!
К сообщению приложен файл: 9199584.xls(35Kb)


Сообщение отредактировал vitos88 - Среда, 07.09.2016, 11:08
 
Ответить
СообщениеДобрый день! Подскажите, пожалуйста, как автоматически вставлять в ячейку "Лидирующая команда" название команды с наибольшей суммой баллов. Спасибо!

Автор - vitos88
Дата добавления - 07.09.2016 в 11:04
китин Дата: Среда, 07.09.2016, 11:09 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4331
Репутация: 673 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Доброго и вам.может так?
Код
=ИНДЕКС($B$2:$B$9;ПОИСКПОЗ(МАКС($C$2:$C$9);$C$2:$C$9;0))

или так
Код
=ПРОСМОТР(9^99;C2:C9;B2:B9)
.второе правильно только при сортировке по возрастанию , вычеркиваем.
вот так будет и короче и правильно
Код
=ПРОСМОТР(1;1/(C2:C9=МАКС(C2:C9));B2:B9)
К сообщению приложен файл: 999888999.xlsx(12Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 07.09.2016, 11:21
 
Ответить
СообщениеДоброго и вам.может так?
Код
=ИНДЕКС($B$2:$B$9;ПОИСКПОЗ(МАКС($C$2:$C$9);$C$2:$C$9;0))

или так
Код
=ПРОСМОТР(9^99;C2:C9;B2:B9)
.второе правильно только при сортировке по возрастанию , вычеркиваем.
вот так будет и короче и правильно
Код
=ПРОСМОТР(1;1/(C2:C9=МАКС(C2:C9));B2:B9)

Автор - китин
Дата добавления - 07.09.2016 в 11:09
alx74 Дата: Среда, 07.09.2016, 11:09 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 209
Репутация: 32 ±
Замечаний: 0% ±

попробуйте так:
Код
=ИНДЕКС(B2:B9;ПОИСКПОЗ(МАКС(C2:C9);C2:C9;0);1)


Срочность обратно пропорциональна степени важности.
Яндекс-money:41001687631447


Сообщение отредактировал alx74 - Среда, 07.09.2016, 11:10
 
Ответить
Сообщениепопробуйте так:
Код
=ИНДЕКС(B2:B9;ПОИСКПОЗ(МАКС(C2:C9);C2:C9;0);1)

Автор - alx74
Дата добавления - 07.09.2016 в 11:09
vitos88 Дата: Среда, 07.09.2016, 11:27 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 5 ±
Замечаний: 0% ±

Спасибо! А что, если лидирующих команд несколько (с одинаковым количеством баллов)? Как быть? Можно ли их через запятую указать автоматически?
 
Ответить
СообщениеСпасибо! А что, если лидирующих команд несколько (с одинаковым количеством баллов)? Как быть? Можно ли их через запятую указать автоматически?

Автор - vitos88
Дата добавления - 07.09.2016 в 11:27
_Boroda_ Дата: Среда, 07.09.2016, 11:34 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11315
Репутация: 4675 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Проще всего с допстолбцом. В файле зеленый, там формат ячеек ;;; и формула
Код
=F1&ЕСЛИ(C2=МАКС(C$2:C$9);", "&B2;"")
К сообщению приложен файл: 9199584_1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПроще всего с допстолбцом. В файле зеленый, там формат ячеек ;;; и формула
Код
=F1&ЕСЛИ(C2=МАКС(C$2:C$9);", "&B2;"")

Автор - _Boroda_
Дата добавления - 07.09.2016 в 11:34
китин Дата: Среда, 07.09.2016, 11:35 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4331
Репутация: 673 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
можно, но формулами оч.муторно. наберите в поиске по форуму СцепитьЕсли .Там UDF


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеможно, но формулами оч.муторно. наберите в поиске по форуму СцепитьЕсли .Там UDF

Автор - китин
Дата добавления - 07.09.2016 в 11:35
pabchek Дата: Среда, 07.09.2016, 11:42 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 745
Репутация: 168 ±
Замечаний: 0% ±

Excel 2007
Если подойдет не через запятую, а списком, то (формула массива)
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$2:B$9;НАИБОЛЬШИЙ(ЕСЛИ(C$2:C$9=МАКС(C$2:C$9);СТРОКА(C$2:C$9));СТРОКА(A1)));"")
К сообщению приложен файл: 6343495.xlsx(12Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеЕсли подойдет не через запятую, а списком, то (формула массива)
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$2:B$9;НАИБОЛЬШИЙ(ЕСЛИ(C$2:C$9=МАКС(C$2:C$9);СТРОКА(C$2:C$9));СТРОКА(A1)));"")

Автор - pabchek
Дата добавления - 07.09.2016 в 11:42
K-SerJC Дата: Среда, 07.09.2016, 11:44 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 272
Репутация: 38 ±
Замечаний: 0% ±

Excel 2013
или так:
[vba]
Код
=ДВССЫЛ(АДРЕС(ПОИСКПОЗ(МАКС(C2:C9);C1:C9);2))
[/vba]


Благими намерениями выстелена дорога в АД.
 
Ответить
Сообщениеили так:
[vba]
Код
=ДВССЫЛ(АДРЕС(ПОИСКПОЗ(МАКС(C2:C9);C1:C9);2))
[/vba]

Автор - K-SerJC
Дата добавления - 07.09.2016 в 11:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка в ячейку "Победитель" назв. команды по сумме баллов (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!