Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос строк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос строк (Формулы/Formulas)
Перенос строк
noname342 Дата: Четверг, 08.09.2016, 15:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте.
Подскажите пожалуйста, как отсортировать строки в примере ниже
Есть таблица, первый столбец основной по нему должны равняться все остальные строки, как сделать так что бы все строки перенеслись по номерам, то есть 1 к 1, 3 к 3 и 5 к 5, а 2 и 4 должны остаться пустыми (важно, то, что должна переноситься вся строка целиком относительно первого столбца)
Доступно только для пользователей
 
Ответить
СообщениеЗдравствуйте.
Подскажите пожалуйста, как отсортировать строки в примере ниже
Есть таблица, первый столбец основной по нему должны равняться все остальные строки, как сделать так что бы все строки перенеслись по номерам, то есть 1 к 1, 3 к 3 и 5 к 5, а 2 и 4 должны остаться пустыми (важно, то, что должна переноситься вся строка целиком относительно первого столбца)
Доступно только для пользователей

Автор - noname342
Дата добавления - 08.09.2016 в 15:43
китин Дата: Четверг, 08.09.2016, 15:46 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну предложу вам воспользоваться ВПР. вам это поможет? а без файла примера ответ м.б. только такой.


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену предложу вам воспользоваться ВПР. вам это поможет? а без файла примера ответ м.б. только такой.

Автор - китин
Дата добавления - 08.09.2016 в 15:46
noname342 Дата: Четверг, 08.09.2016, 16:17 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Как то так должно получаться
К сообщению приложен файл: 5895258.xlsx(9Kb)
 
Ответить
СообщениеКак то так должно получаться

Автор - noname342
Дата добавления - 08.09.2016 в 16:17
Manyasha Дата: Четверг, 08.09.2016, 16:46 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1582
Репутация: 659 ±
Замечаний: 0% ±

Excel 2007, 2010
noname342, так?
Код
=ЕСЛИОШИБКА(ВПР($A16;$B$7:$G$12;СТОЛБЕЦ(A1);0);"")

или
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$7:$G$12;ПОИСКПОЗ($A23;$B$7:$B$12;);СТОЛБЕЦ(A1));"")


Ссылки для самообразования:
Видео про ВПР
статья про ВПР
Видео про Индекс+Поискпоз

[p.s.]Давайте тему переименуем в "Сортировка строк в соответствии с номерами" или еще во что-то более подробное, чем "перенос строк".[/p.s.]
К сообщению приложен файл: 5895258-1.xlsx(11Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804


Сообщение отредактировал Manyasha - Четверг, 08.09.2016, 16:47
 
Ответить
Сообщениеnoname342, так?
Код
=ЕСЛИОШИБКА(ВПР($A16;$B$7:$G$12;СТОЛБЕЦ(A1);0);"")

или
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$7:$G$12;ПОИСКПОЗ($A23;$B$7:$B$12;);СТОЛБЕЦ(A1));"")


Ссылки для самообразования:
Видео про ВПР
статья про ВПР
Видео про Индекс+Поискпоз

[p.s.]Давайте тему переименуем в "Сортировка строк в соответствии с номерами" или еще во что-то более подробное, чем "перенос строк".[/p.s.]

Автор - Manyasha
Дата добавления - 08.09.2016 в 16:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос строк (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!