Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет остатка сумм по договорам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет остатка сумм по договорам (Формулы/Formulas)
Подсчет остатка сумм по договорам
parovoznik Дата: Пятница, 09.09.2016, 13:23 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 122
Репутация: 4 ±
Замечаний: 0% ±

Excel 2007
Добрый день.
Имеется таблица для ввода данных и итоговая таблица.
Как просчитать остаток суммы по договору по Клиенту и № договора?
Прописал формулу ЕСЛИ(И),но выдает 0
К сообщению приложен файл: Test.xlsm(12Kb)
 
Ответить
СообщениеДобрый день.
Имеется таблица для ввода данных и итоговая таблица.
Как просчитать остаток суммы по договору по Клиенту и № договора?
Прописал формулу ЕСЛИ(И),но выдает 0

Автор - parovoznik
Дата добавления - 09.09.2016 в 13:23
buchlotnik Дата: Пятница, 09.09.2016, 13:30 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
типа того:
Код
=ПРОСМОТР(9^9;$D$6:$D$10/($B$6:$B$10=G6)/($C$6:$C$10=H6))-СУММПРОИЗВ(($B$6:$B$10=G6)*($C$6:$C$10=H6)*$E$6:$E$10)
К сообщению приложен файл: 8334117.xlsm(13Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетипа того:
Код
=ПРОСМОТР(9^9;$D$6:$D$10/($B$6:$B$10=G6)/($C$6:$C$10=H6))-СУММПРОИЗВ(($B$6:$B$10=G6)*($C$6:$C$10=H6)*$E$6:$E$10)

Автор - buchlotnik
Дата добавления - 09.09.2016 в 13:30
китин Дата: Пятница, 09.09.2016, 13:33 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а если так?
Код
=ЕСЛИ(И(G6=B6;H6=C6);D6-E6;0)
не вот так
Код
=СУММПРОИЗВ($D$6:$D$10*($B$6:$B$10=$G6)*($C$6:$C$10=$H6))-СУММПРОИЗВ($E$6:$E$10*($B$6:$B$10=$G6)*($C$6:$C$10=$H6))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 09.09.2016, 13:36
 
Ответить
Сообщениеа если так?
Код
=ЕСЛИ(И(G6=B6;H6=C6);D6-E6;0)
не вот так
Код
=СУММПРОИЗВ($D$6:$D$10*($B$6:$B$10=$G6)*($C$6:$C$10=$H6))-СУММПРОИЗВ($E$6:$E$10*($B$6:$B$10=$G6)*($C$6:$C$10=$H6))

Автор - китин
Дата добавления - 09.09.2016 в 13:33
buchlotnik Дата: Пятница, 09.09.2016, 13:38 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
не вот так
так шустрее :D


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
не вот так
так шустрее :D

Автор - buchlotnik
Дата добавления - 09.09.2016 в 13:38
krosav4ig Дата: Пятница, 09.09.2016, 13:40 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1362
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007, 2013
или так (формула массива, вводится комбинацией Ctrl+Shift+Enter)
Код
=ВПР(G6&H6;ЕСЛИ({1;0};B$6:B$10&C$6:C$10;D$6:D$10);2;)-СУММЕСЛИМН(E$6:E$10;B$6:B$10;G6;C$6:C$10;H6)


(_)Õvõ(_)
 
Ответить
Сообщениеили так (формула массива, вводится комбинацией Ctrl+Shift+Enter)
Код
=ВПР(G6&H6;ЕСЛИ({1;0};B$6:B$10&C$6:C$10;D$6:D$10);2;)-СУММЕСЛИМН(E$6:E$10;B$6:B$10;G6;C$6:C$10;H6)

Автор - krosav4ig
Дата добавления - 09.09.2016 в 13:40
Nic70y Дата: Пятница, 09.09.2016, 13:40 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
такой вариант:
Код
=СРЗНАЧЕСЛИМН(D$6:D$10;B$6:B$10;G6;C$6:C$10;H6)-СУММЕСЛИМН(E$6:E$10;B$6:B$10;G6;C$6:C$10;H6)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениетакой вариант:
Код
=СРЗНАЧЕСЛИМН(D$6:D$10;B$6:B$10;G6;C$6:C$10;H6)-СУММЕСЛИМН(E$6:E$10;B$6:B$10;G6;C$6:C$10;H6)

Автор - Nic70y
Дата добавления - 09.09.2016 в 13:40
parovoznik Дата: Пятница, 09.09.2016, 14:04 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 122
Репутация: 4 ±
Замечаний: 0% ±

Excel 2007
Ребята спасибо. :D
buchlotnik ,а что значит в Вашей формуле =ПРОСМОТР(9^9) и результат в первой строке должен быть 150( я неправильно изначально написал) :(
К сообщению приложен файл: Test2.xlsm(11Kb)
 
Ответить
СообщениеРебята спасибо. :D
buchlotnik ,а что значит в Вашей формуле =ПРОСМОТР(9^9) и результат в первой строке должен быть 150( я неправильно изначально написал) :(

Автор - parovoznik
Дата добавления - 09.09.2016 в 14:04
Nic70y Дата: Пятница, 09.09.2016, 14:06 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
должен быть 150( я неправильно изначально написал)
а ведь изначально правильно написал %)
Код
=СУММЕСЛИМН(D$6:D$10;B$6:B$10;G6;C$6:C$10;H6)-СУММЕСЛИМН(E$6:E$10;B$6:B$10;G6;C$6:C$10;H6)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
должен быть 150( я неправильно изначально написал)
а ведь изначально правильно написал %)
Код
=СУММЕСЛИМН(D$6:D$10;B$6:B$10;G6;C$6:C$10;H6)-СУММЕСЛИМН(E$6:E$10;B$6:B$10;G6;C$6:C$10;H6)

Автор - Nic70y
Дата добавления - 09.09.2016 в 14:06
_Boroda_ Дата: Пятница, 09.09.2016, 14:09 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9379
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
результат в первой строке должен быть 150

Ну тогда совсем другое дело
Код
=СУММПРОИЗВ(D$6:E$10*{1;-1}*(B$6:B$10=G6)*(C$6:C$10=H6))


Или сводной таблицей с вычисляемым полем (см. файл)
К сообщению приложен файл: Test-1-11.xlsm(15Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
результат в первой строке должен быть 150

Ну тогда совсем другое дело
Код
=СУММПРОИЗВ(D$6:E$10*{1;-1}*(B$6:B$10=G6)*(C$6:C$10=H6))


Или сводной таблицей с вычисляемым полем (см. файл)

Автор - _Boroda_
Дата добавления - 09.09.2016 в 14:09
parovoznik Дата: Пятница, 09.09.2016, 14:37 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 122
Репутация: 4 ±
Замечаний: 0% ±

Excel 2007
Вoroda а что значат єти цифры.{1;-1}?
Всем спасибо за ответы.
 
Ответить
СообщениеВoroda а что значат єти цифры.{1;-1}?
Всем спасибо за ответы.

Автор - parovoznik
Дата добавления - 09.09.2016 в 14:37
_Boroda_ Дата: Пятница, 09.09.2016, 14:45 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9379
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
1. Кусок (B$6:B$10=G6)*(C$6:C$10=H6) дает нам вертикальный массив 1хN с условиями ИСТИНА или ЛОЖЬ.
2. Умножая его на D$6:E$10, получаем матрицу 2хN, в которой нули там, где в п.1 ЛОЖЬ и значения из D:Е там, где в п.1 ИСТИНА.
3. Поскольку значения из Е нам нужно вычитать, то умножаем матрицу из п.2 на 1:-1 - первый столбец D на единицу, второй столбец Е на минус единицу. Значения из Е становятся отрицательными.
4. Все полученное складываем.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение1. Кусок (B$6:B$10=G6)*(C$6:C$10=H6) дает нам вертикальный массив 1хN с условиями ИСТИНА или ЛОЖЬ.
2. Умножая его на D$6:E$10, получаем матрицу 2хN, в которой нули там, где в п.1 ЛОЖЬ и значения из D:Е там, где в п.1 ИСТИНА.
3. Поскольку значения из Е нам нужно вычитать, то умножаем матрицу из п.2 на 1:-1 - первый столбец D на единицу, второй столбец Е на минус единицу. Значения из Е становятся отрицательными.
4. Все полученное складываем.

Автор - _Boroda_
Дата добавления - 09.09.2016 в 14:45
китин Дата: Суббота, 10.09.2016, 08:57 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
D$6:E$10*{1;-1}

даже в голову не пришло hands hands hands


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
D$6:E$10*{1;-1}

даже в голову не пришло hands hands hands

Автор - китин
Дата добавления - 10.09.2016 в 08:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет остатка сумм по договорам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!