Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммировать значения, по условия содержания имя в тексте - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать значения, по условия содержания имя в тексте (Формулы/Formulas)
Суммировать значения, по условия содержания имя в тексте
Alabama19 Дата: Пятница, 09.09.2016, 21:11 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Прошу помощи, возможно ли без макросов выполнить следующую задачу. Пример приложил
К сообщению приложен файл: 7458343.xlsx(8Kb)


Сообщение отредактировал Alabama19 - Пятница, 09.09.2016, 21:15
 
Ответить
СообщениеПрошу помощи, возможно ли без макросов выполнить следующую задачу. Пример приложил

Автор - Alabama19
Дата добавления - 09.09.2016 в 21:11
Nic70y Дата: Пятница, 09.09.2016, 21:20 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
массивная формула:
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(ПОИСК(E1;$A$1:$A$5));$B$1:$B$5))
{формула массива вводится одновременным нажатием Ctrl Shift Enter}
К сообщению приложен файл: 3554848.xlsx(9Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениемассивная формула:
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(ПОИСК(E1;$A$1:$A$5));$B$1:$B$5))
{формула массива вводится одновременным нажатием Ctrl Shift Enter}

Автор - Nic70y
Дата добавления - 09.09.2016 в 21:20
Alabama19 Дата: Пятница, 09.09.2016, 21:29 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Огромное спасибо, подскажите, можно ли сделать тоже самое но прикрепить к таблице ( тоже самое но данные отформатированы в виде таблицы ) ?
К сообщению приложен файл: 111.xlsx(9Kb)
 
Ответить
СообщениеОгромное спасибо, подскажите, можно ли сделать тоже самое но прикрепить к таблице ( тоже самое но данные отформатированы в виде таблицы ) ?

Автор - Alabama19
Дата добавления - 09.09.2016 в 21:29
Alabama19 Дата: Пятница, 09.09.2016, 21:34 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо, сам разобрался. Вы же для как раз для меня выделили {формула массива вводится одновременным нажатием Ctrl Shift Enter} Еще раз ОГРОМНОЕ СПАСИБО!
 
Ответить
СообщениеСпасибо, сам разобрался. Вы же для как раз для меня выделили {формула массива вводится одновременным нажатием Ctrl Shift Enter} Еще раз ОГРОМНОЕ СПАСИБО!

Автор - Alabama19
Дата добавления - 09.09.2016 в 21:34
Nic70y Дата: Пятница, 09.09.2016, 21:34 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
да можно, конечно, просто диапазоны вручную поиенять
[p.s.]но в таблице лучше иметь заголовки[/p.s.]
К сообщению приложен файл: 9452893.xlsx(9Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Пятница, 09.09.2016, 21:35
 
Ответить
Сообщениеда можно, конечно, просто диапазоны вручную поиенять
[p.s.]но в таблице лучше иметь заголовки[/p.s.]

Автор - Nic70y
Дата добавления - 09.09.2016 в 21:34
AlexM Дата: Пятница, 09.09.2016, 21:54 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Не массивная формула
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(E1;$A$1:$A$5))*B$1:$B$5)
Еще не массивная
Код
=СУММЕСЛИ($A1:$A5;"*"&E1&"*";$B1:$B5)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 09.09.2016, 22:13
 
Ответить
СообщениеНе массивная формула
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(E1;$A$1:$A$5))*B$1:$B$5)
Еще не массивная
Код
=СУММЕСЛИ($A1:$A5;"*"&E1&"*";$B1:$B5)

Автор - AlexM
Дата добавления - 09.09.2016 в 21:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать значения, по условия содержания имя в тексте (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!