Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет среднего выборочного значеня - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет среднего выборочного значеня (Формулы/Formulas)
Подсчет среднего выборочного значеня
Horror Дата: Понедельник, 12.09.2016, 11:31 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Есть таблица, и формула подсчета среднего значения выполнения плана человека за определенный период
Суть дела такова: если человек находится в отпуске то соответственно выполнение его плана 0%
Так вот, помогите изменить формулу (ячейка А33) чтобы подсчитывал среднее значение, без 0% и соответственно не учитывать день где 0%
К сообщению приложен файл: 0961785.xlsm(41.4 Kb)
 
Ответить
СообщениеЕсть таблица, и формула подсчета среднего значения выполнения плана человека за определенный период
Суть дела такова: если человек находится в отпуске то соответственно выполнение его плана 0%
Так вот, помогите изменить формулу (ячейка А33) чтобы подсчитывал среднее значение, без 0% и соответственно не учитывать день где 0%

Автор - Horror
Дата добавления - 12.09.2016 в 11:31
Nic70y Дата: Понедельник, 12.09.2016, 11:39 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4570
Репутация: 985 ±
Замечаний: 0% ±

Excel 2013
Код
=СРЗНАЧЕСЛИМН(ИНДЕКС(C3:J24;ПОИСКПОЗ(A27;A3:A24;););ИНДЕКС(C3:J24;ПОИСКПОЗ(A27;A3:A24;););"<>0";C1:J1;">="&A29;C1:J1;"<="&A31)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СРЗНАЧЕСЛИМН(ИНДЕКС(C3:J24;ПОИСКПОЗ(A27;A3:A24;););ИНДЕКС(C3:J24;ПОИСКПОЗ(A27;A3:A24;););"<>0";C1:J1;">="&A29;C1:J1;"<="&A31)

Автор - Nic70y
Дата добавления - 12.09.2016 в 11:39
K-SerJC Дата: Понедельник, 12.09.2016, 11:44 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 348
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММЕСЛИ(C4:J4;">0")/СЧЁТЕСЛИ(C4:J4;">0")

а если так?\

p/s не совсем верно, не учел выборку по фамилии
К сообщению приложен файл: _0961785.xlsm(36.1 Kb)


Благими намерениями выстелена дорога в АД.

Сообщение отредактировал K-SerJC - Понедельник, 12.09.2016, 11:47
 
Ответить
Сообщение
Код
=СУММЕСЛИ(C4:J4;">0")/СЧЁТЕСЛИ(C4:J4;">0")

а если так?\

p/s не совсем верно, не учел выборку по фамилии

Автор - K-SerJC
Дата добавления - 12.09.2016 в 11:44
SLAVICK Дата: Понедельник, 12.09.2016, 11:49 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 2188
Репутация: 736 ±
Замечаний: 0% ±

2007,2010,2013,2016
на базе Вашей формулы так:
Код
=СУММПРОИЗВ((C1:J1>=A29)*(C1:J1<=A31)*(A3:A24=A27)*(C3:J24))/СУММПРОИЗВ((C1:J1>=A29)*(C1:J1<=A31)*(A3:A24=A27)*(C3:J24>0))
К сообщению приложен файл: 0961785_2016-09.xlsm(36.7 Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщениена базе Вашей формулы так:
Код
=СУММПРОИЗВ((C1:J1>=A29)*(C1:J1<=A31)*(A3:A24=A27)*(C3:J24))/СУММПРОИЗВ((C1:J1>=A29)*(C1:J1<=A31)*(A3:A24=A27)*(C3:J24>0))

Автор - SLAVICK
Дата добавления - 12.09.2016 в 11:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет среднего выборочного значеня (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!