Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/MS Excel: Вычисление среднего значения одной формулой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 2
  • 1
  • 2
  • »
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » MS Excel: Вычисление среднего значения одной формулой
MS Excel: Вычисление среднего значения одной формулой
Brisk Дата: Среда, 05.12.2012, 22:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте! Такая вот задачка: Посчитан ряд значений (Х) с помощью простой формулы, в которой выполнены 2 арифметических действия. (А-Б+С). То есть получен ряд значений (А-Б+С) = Х. Из этого ряда получено среднее значение (Хср) формулой СРЗНАЧ. Вопрос: Возможно ли получить это же среднее значение (Хср) с помощью одной единственной формулы, соблюдая все условия? То есть посчитав все (А-Б+С) = Х и их среднее значение. Файл "задача" прикреплен.
Буду очень рад любым предложенным идеям smile , у меня не получается.
К сообщению приложен файл: 9822510.xls(22.5 Kb)


Сообщение отредактировал Brisk - Среда, 05.12.2012, 22:47
 
Ответить
СообщениеЗдравствуйте! Такая вот задачка: Посчитан ряд значений (Х) с помощью простой формулы, в которой выполнены 2 арифметических действия. (А-Б+С). То есть получен ряд значений (А-Б+С) = Х. Из этого ряда получено среднее значение (Хср) формулой СРЗНАЧ. Вопрос: Возможно ли получить это же среднее значение (Хср) с помощью одной единственной формулы, соблюдая все условия? То есть посчитав все (А-Б+С) = Х и их среднее значение. Файл "задача" прикреплен.
Буду очень рад любым предложенным идеям smile , у меня не получается.

Автор - Brisk
Дата добавления - 05.12.2012 в 22:43
Serge_007 Дата: Среда, 05.12.2012, 23:08 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13309
Репутация: ±
Замечаний: ±

Excel 2010
Quote (Brisk)
Возможно ли получить это же среднее значение (Хср) с помощью одной единственной формулы, соблюдая все условия?

Если Вы имеете ввиду одну формулу в одной ячейке, то нет


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Quote (Brisk)
Возможно ли получить это же среднее значение (Хср) с помощью одной единственной формулы, соблюдая все условия?

Если Вы имеете ввиду одну формулу в одной ячейке, то нет

Автор - Serge_007
Дата добавления - 05.12.2012 в 23:08
AlexM Дата: Среда, 05.12.2012, 23:22 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4255
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
А так?
Code
=СУММ(ИНДЕКС(C10:C38+D10:D38-B3;);C3)/СЧЁТЗ(C10:C39)

или формула массива
Code
=СРЗНАЧ(C10:C38+D10:D38-B3;C3)

простая формула
Code
=СРЗНАЧ(ИНДЕКС(C10:C38+D10:D38-B3;);C3)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 05.12.2012, 23:27
 
Ответить
СообщениеА так?
Code
=СУММ(ИНДЕКС(C10:C38+D10:D38-B3;);C3)/СЧЁТЗ(C10:C39)

или формула массива
Code
=СРЗНАЧ(C10:C38+D10:D38-B3;C3)

простая формула
Code
=СРЗНАЧ(ИНДЕКС(C10:C38+D10:D38-B3;);C3)

Автор - AlexM
Дата добавления - 05.12.2012 в 23:22
Serge_007 Дата: Среда, 05.12.2012, 23:27 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13309
Репутация: ±
Замечаний: ±

Excel 2010
AlexM, я так понял, что надо НЕ использовать диапазон С10:С39, а заменить его ОДНОЙ формулой,
Quote (Brisk)
То есть посчитав все (А-Б+С) = Х и их среднее значение


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение AlexM, я так понял, что надо НЕ использовать диапазон С10:С39, а заменить его ОДНОЙ формулой,
Quote (Brisk)
То есть посчитав все (А-Б+С) = Х и их среднее значение

Автор - Serge_007
Дата добавления - 05.12.2012 в 23:27
AlexM Дата: Среда, 05.12.2012, 23:31 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4255
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
а впереди фраза
Quote (Brisk)
помощью одной единственной формулы


PS. Сергей, может быть вы правы.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 05.12.2012, 23:36
 
Ответить
Сообщениеа впереди фраза
Quote (Brisk)
помощью одной единственной формулы


PS. Сергей, может быть вы правы.

Автор - AlexM
Дата добавления - 05.12.2012 в 23:31
Serge_007 Дата: Среда, 05.12.2012, 23:36 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13309
Репутация: ±
Замечаний: ±

Excel 2010
Quote (AlexM)
а впереди фраза
Quote (Brisk)
с помощью одной единственной формулы


Code
=СРЗНАЧ(C10:C39)

biggrin


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Quote (AlexM)
а впереди фраза
Quote (Brisk)
с помощью одной единственной формулы


Code
=СРЗНАЧ(C10:C39)

biggrin

Автор - Serge_007
Дата добавления - 05.12.2012 в 23:36
AlexM Дата: Среда, 05.12.2012, 23:43 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4255
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
surprised
Действительно смешно.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеsurprised
Действительно смешно.

Автор - AlexM
Дата добавления - 05.12.2012 в 23:43
MCH Дата: Среда, 05.12.2012, 23:49 | Сообщение № 8
Группа: Админы
Ранг: Старожил
Сообщений: 1953
Репутация: 723 ±
Замечаний: ±

без ссылок на диапазон C10:D39
формула массива:
[vba]
Code
=СРЗНАЧ(C3-(СТРОКА(1:30)-1)*B3+СУММЕСЛИ(D3:D6;"<"&СТРОКА(1:30);E3:E6))
[/vba]
 
Ответить
Сообщениебез ссылок на диапазон C10:D39
формула массива:
[vba]
Code
=СРЗНАЧ(C3-(СТРОКА(1:30)-1)*B3+СУММЕСЛИ(D3:D6;"<"&СТРОКА(1:30);E3:E6))
[/vba]

Автор - MCH
Дата добавления - 05.12.2012 в 23:49
Serge_007 Дата: Четверг, 06.12.2012, 07:48 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 13309
Репутация: ±
Замечаний: ±

Excel 2010
MCH, тоже "не на чистого" smile
Хотя признаюсь, я даже не рассматривал вариант с использованием первой таблицы...


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение MCH, тоже "не на чистого" smile
Хотя признаюсь, я даже не рассматривал вариант с использованием первой таблицы...

Автор - Serge_007
Дата добавления - 06.12.2012 в 07:48
MCH Дата: Четверг, 06.12.2012, 13:35 | Сообщение № 10
Группа: Админы
Ранг: Старожил
Сообщений: 1953
Репутация: 723 ±
Замечаний: ±

Quote (Serge_007)
тоже "не на чистого"

Сергей, что ты имеешь в виду? Не понял твою фразу.
Если не нравится, что использована функция СТРОКА(1:30), то ее легко можно заменить на массив констант.
 
Ответить
Сообщение
Quote (Serge_007)
тоже "не на чистого"

Сергей, что ты имеешь в виду? Не понял твою фразу.
Если не нравится, что использована функция СТРОКА(1:30), то ее легко можно заменить на массив констант.

Автор - MCH
Дата добавления - 06.12.2012 в 13:35
Serge_007 Дата: Четверг, 06.12.2012, 13:52 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 13309
Репутация: ±
Замечаний: ±

Excel 2010
Quote (MCH)
что ты имеешь в виду?

Quote (Serge_007)
не рассматривал вариант с использованием первой таблицы

Я предположил, что должны быть только "чистые"
Quote (Brisk)
(А-Б+С)
, т.е. первая таблица не используется

Quote (MCH)
Если не нравится

Миш, твои формулы не могут не нравится
Я получаю от них эстетическое удовольствие
Я абсолютно серьёзно говорю


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Quote (MCH)
что ты имеешь в виду?

Quote (Serge_007)
не рассматривал вариант с использованием первой таблицы

Я предположил, что должны быть только "чистые"
Quote (Brisk)
(А-Б+С)
, т.е. первая таблица не используется

Quote (MCH)
Если не нравится

Миш, твои формулы не могут не нравится
Я получаю от них эстетическое удовольствие
Я абсолютно серьёзно говорю

Автор - Serge_007
Дата добавления - 06.12.2012 в 13:52
MCH Дата: Четверг, 06.12.2012, 14:08 | Сообщение № 12
Группа: Админы
Ранг: Старожил
Сообщений: 1953
Репутация: 723 ±
Замечаний: ±

Quote (Serge_007)
Я предположил, что должны быть только "чистые" Цитата, ..., т.е. первая таблица не используется

исходные данные находятся в ячейках:
B3 - потребность за сутки (Б)
C3 - остаток материала на начало месяца
D3:D6 - даты поступлений
E3:E6 - объемы поступлений
как можно чтото посчитать не ссылаясь на эти ячейки?
 
Ответить
Сообщение
Quote (Serge_007)
Я предположил, что должны быть только "чистые" Цитата, ..., т.е. первая таблица не используется

исходные данные находятся в ячейках:
B3 - потребность за сутки (Б)
C3 - остаток материала на начало месяца
D3:D6 - даты поступлений
E3:E6 - объемы поступлений
как можно чтото посчитать не ссылаясь на эти ячейки?

Автор - MCH
Дата добавления - 06.12.2012 в 14:08
Serge_007 Дата: Четверг, 06.12.2012, 14:15 | Сообщение № 13
Группа: Админы
Ранг: Местный житель
Сообщений: 13309
Репутация: ±
Замечаний: ±

Excel 2010
B3 и C3 - константы, остальное брать из ВТОРОЙ таблицы


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеB3 и C3 - константы, остальное брать из ВТОРОЙ таблицы

Автор - Serge_007
Дата добавления - 06.12.2012 в 14:15
MCH Дата: Четверг, 06.12.2012, 14:23 | Сообщение № 14
Группа: Админы
Ранг: Старожил
Сообщений: 1953
Репутация: 723 ±
Замечаний: ±

Quote (Serge_007)
остальное брать из ВТОРОЙ таблицы

Вторая таблица - вспомогательная, я понял что ТС хотел произвести расчеты без составления второй таблицы
 
Ответить
Сообщение
Quote (Serge_007)
остальное брать из ВТОРОЙ таблицы

Вторая таблица - вспомогательная, я понял что ТС хотел произвести расчеты без составления второй таблицы

Автор - MCH
Дата добавления - 06.12.2012 в 14:23
Serge_007 Дата: Четверг, 06.12.2012, 14:35 | Сообщение № 15
Группа: Админы
Ранг: Местный житель
Сообщений: 13309
Репутация: ±
Замечаний: ±

Excel 2010
Теперь уже и я так думаю, но сам ТС куда-то пропал...


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеТеперь уже и я так думаю, но сам ТС куда-то пропал...

Автор - Serge_007
Дата добавления - 06.12.2012 в 14:35
Brisk Дата: Четверг, 06.12.2012, 15:24 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Да, все верно. В формуле не должно быть ссылок на вторую таблицу, т.к. в ней уже посчитаны значения X. В случае, если использовать вторую таблицу, можно воспользоваться функцией СРЗНАЧ smile .
Quote (MCH)
без ссылок на диапазон C10:D39 формула массива:
=СРЗНАЧ(C3-(СТРОКА(1:30)-1)*B3+СУММЕСЛИ(D3:D6;"<"&СТРОКА(1:30);E3:E6))

Я подставил эту формулу, но ответ получился "1500". А (Хср) в задаче равен "938".
Хотя я раньше не использовал в формулах функцию "СТРОКА", может что-то и не так подставил.
Извините, что я тут слегка пропал)


Сообщение отредактировал Brisk - Четверг, 06.12.2012, 15:32
 
Ответить
СообщениеДа, все верно. В формуле не должно быть ссылок на вторую таблицу, т.к. в ней уже посчитаны значения X. В случае, если использовать вторую таблицу, можно воспользоваться функцией СРЗНАЧ smile .
Quote (MCH)
без ссылок на диапазон C10:D39 формула массива:
=СРЗНАЧ(C3-(СТРОКА(1:30)-1)*B3+СУММЕСЛИ(D3:D6;"<"&СТРОКА(1:30);E3:E6))

Я подставил эту формулу, но ответ получился "1500". А (Хср) в задаче равен "938".
Хотя я раньше не использовал в формулах функцию "СТРОКА", может что-то и не так подставил.
Извините, что я тут слегка пропал)

Автор - Brisk
Дата добавления - 06.12.2012 в 15:24
Brisk Дата: Четверг, 06.12.2012, 15:26 | Сообщение № 17
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

МСН, у вас какое значение получилось Хср с этой формулой?


Сообщение отредактировал Brisk - Четверг, 06.12.2012, 15:34
 
Ответить
СообщениеМСН, у вас какое значение получилось Хср с этой формулой?

Автор - Brisk
Дата добавления - 06.12.2012 в 15:26
MCH Дата: Четверг, 06.12.2012, 15:38 | Сообщение № 18
Группа: Админы
Ранг: Старожил
Сообщений: 1953
Репутация: 723 ±
Замечаний: ±

Quote (Brisk)
у вас какое значение получилось Хср с этой формулой?

такое же как и у Вас - 938,333333333333 (см. файл)

Если у Вас получается что то другое (например 1500), то Вы не правильно вводите формулу.
Формулы массива вводятся нажатием Ctrl+Shift+Enter
К сообщению приложен файл: Brisk.xls(28.5 Kb)
 
Ответить
Сообщение
Quote (Brisk)
у вас какое значение получилось Хср с этой формулой?

такое же как и у Вас - 938,333333333333 (см. файл)

Если у Вас получается что то другое (например 1500), то Вы не правильно вводите формулу.
Формулы массива вводятся нажатием Ctrl+Shift+Enter

Автор - MCH
Дата добавления - 06.12.2012 в 15:38
MCH Дата: Четверг, 06.12.2012, 15:41 | Сообщение № 19
Группа: Админы
Ранг: Старожил
Сообщений: 1953
Репутация: 723 ±
Замечаний: ±

Функцию СТРОКА() можете заменить на массив констант, тогда формула не будет нуждатся в массивном вводе:
[vba]
Code
=СРЗНАЧ(C3-{0:1:2:3:4:5:6:7:8:9:10:11:12:13:14:15:16:17:18:19:20:21:22:23:24:25:26:27:28:29}*B3+СУММЕСЛИ(D3:D6;"<"&{1:2:3:4:5:6:7:8:9:10:11:12:13:14:15:16:17:18:19:20:21:22:23:24:25:26:27:28:29:30};E3:E6))
[/vba]
 
Ответить
СообщениеФункцию СТРОКА() можете заменить на массив констант, тогда формула не будет нуждатся в массивном вводе:
[vba]
Code
=СРЗНАЧ(C3-{0:1:2:3:4:5:6:7:8:9:10:11:12:13:14:15:16:17:18:19:20:21:22:23:24:25:26:27:28:29}*B3+СУММЕСЛИ(D3:D6;"<"&{1:2:3:4:5:6:7:8:9:10:11:12:13:14:15:16:17:18:19:20:21:22:23:24:25:26:27:28:29:30};E3:E6))
[/vba]

Автор - MCH
Дата добавления - 06.12.2012 в 15:41
Brisk Дата: Четверг, 06.12.2012, 15:52 | Сообщение № 20
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Ого, вот это да! Я восхищен Вашей формулой. thumbup Большое спасибо за помощь
Quote (MCH)
Формулы массива вводятся нажатием Ctrl+Shift+Enter
. Про это я совсем забыл)


Сообщение отредактировал Brisk - Четверг, 06.12.2012, 15:53
 
Ответить
СообщениеОго, вот это да! Я восхищен Вашей формулой. thumbup Большое спасибо за помощь
Quote (MCH)
Формулы массива вводятся нажатием Ctrl+Shift+Enter
. Про это я совсем забыл)

Автор - Brisk
Дата добавления - 06.12.2012 в 15:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » MS Excel: Вычисление среднего значения одной формулой
  • Страница 1 из 2
  • 1
  • 2
  • »
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!