Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/проставить остатки в соответствии кодам, причем есть отличия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » проставить остатки в соответствии кодам, причем есть отличия (Формулы/Formulas)
проставить остатки в соответствии кодам, причем есть отличия
vermut Дата: Четверг, 15.09.2016, 13:07 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Ребята еще раз всем привет) Есть исходная форма где каждому коду соответствует число остатка кол-ва. В необходимой форме есть кода, и надо проставить остатки из первой формы в соответствии кодам. Причем во второй форме кода имеют по несколько нулей впереди.Как сделать?
К сообщению приложен файл: 6657119.xlsx(14Kb)
 
Ответить
СообщениеРебята еще раз всем привет) Есть исходная форма где каждому коду соответствует число остатка кол-ва. В необходимой форме есть кода, и надо проставить остатки из первой формы в соответствии кодам. Причем во второй форме кода имеют по несколько нулей впереди.Как сделать?

Автор - vermut
Дата добавления - 15.09.2016 в 13:07
китин Дата: Четверг, 15.09.2016, 13:12 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну дык обычным ВПР.
Код
=ВПР(E2;$B$2:$C$5;2;0)
у вас 00000 поставлены форматом ячейки


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену дык обычным ВПР.
Код
=ВПР(E2;$B$2:$C$5;2;0)
у вас 00000 поставлены форматом ячейки

Автор - китин
Дата добавления - 15.09.2016 в 13:12
vermut Дата: Четверг, 15.09.2016, 13:23 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Спасибо Игорь, а если такая ситуация?:

УТ000000823 УТ823
 
Ответить
Сообщение Спасибо Игорь, а если такая ситуация?:

УТ000000823 УТ823

Автор - vermut
Дата добавления - 15.09.2016 в 13:23
китин Дата: Четверг, 15.09.2016, 13:43 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
если такая ситуация?:


Код
=ВПР(ПОДСТАВИТЬ(E2;0;"");$B$2:$C$5;2;0)

а давайте вы сразу приложите файл со всеми возможными ситуациями


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
если такая ситуация?:


Код
=ВПР(ПОДСТАВИТЬ(E2;0;"");$B$2:$C$5;2;0)

а давайте вы сразу приложите файл со всеми возможными ситуациями

Автор - китин
Дата добавления - 15.09.2016 в 13:43
vermut Дата: Четверг, 15.09.2016, 13:51 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
сразу приложите файл
Вот Игорь файл.
К сообщению приложен файл: 999999999.xlsx(70Kb)
 
Ответить
Сообщение
сразу приложите файл
Вот Игорь файл.

Автор - vermut
Дата добавления - 15.09.2016 в 13:51
vermut Дата: Четверг, 15.09.2016, 14:29 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
никак не получается(
 
Ответить
Сообщениеникак не получается(

Автор - vermut
Дата добавления - 15.09.2016 в 14:29
Pelena Дата: Четверг, 15.09.2016, 14:36 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9850
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Что именно не получается? #Н/Д означает, что такой ID не найден


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЧто именно не получается? #Н/Д означает, что такой ID не найден

Автор - Pelena
Дата добавления - 15.09.2016 в 14:36
vermut Дата: Четверг, 15.09.2016, 14:59 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
такой ID не найден

Елена, в том и дело что айди в списках отличается на несколько нулей, после УТ
 
Ответить
Сообщение
такой ID не найден

Елена, в том и дело что айди в списках отличается на несколько нулей, после УТ

Автор - vermut
Дата добавления - 15.09.2016 в 14:59
китин Дата: Четверг, 15.09.2016, 15:12 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
все что смог.остальных в списке нетути. проверяйте
Код
=ЕСЛИОШИБКА(ВПР(ПОДСТАВИТЬ(ПРОСМОТР(9^9;--(ПОДСТАВИТЬ(A2;"УТ"&ПОВТОР(0;СТРОКА($1:$99));",")));"0,";"УТ");$D$2:$E$1567;2;0);ВПР(A2;$D$2:$E$1567;2;0))
К сообщению приложен файл: 444333.xlsx(66Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениевсе что смог.остальных в списке нетути. проверяйте
Код
=ЕСЛИОШИБКА(ВПР(ПОДСТАВИТЬ(ПРОСМОТР(9^9;--(ПОДСТАВИТЬ(A2;"УТ"&ПОВТОР(0;СТРОКА($1:$99));",")));"0,";"УТ");$D$2:$E$1567;2;0);ВПР(A2;$D$2:$E$1567;2;0))

Автор - китин
Дата добавления - 15.09.2016 в 15:12
vermut Дата: Четверг, 15.09.2016, 15:20 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
смог


Игорь урааа, я счастлива! Спасибочки большое!!!
 
Ответить
Сообщение
смог


Игорь урааа, я счастлива! Спасибочки большое!!!

Автор - vermut
Дата добавления - 15.09.2016 в 15:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » проставить остатки в соответствии кодам, причем есть отличия (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!