Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Новые значения и лишние значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Новые значения и лишние значения (Формулы/Formulas)
Новые значения и лишние значения
Strateg_ru Дата: Пятница, 23.09.2016, 17:32 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уважаемые эксперты, нужна Ваша помощь!
Есть диапазон значений А:А (создаётся формулой, вытягивающей значения с Лист2). Значения уникальны.
Есть диапазон значений В:В – результат копипаста столбца А (через вставку значений).
Со времени последнего копипаста в столбец В, значения на Лист2 изменились, а следовательно, изменились и значения столбца А. Таким образом, содержание столбцов А и В – различаются.
Необходимо:
В ячейке С2 показать первую НОВУЮ ячейку из стобца А, которой нет в столбце В. В С3 – вторую новую и т.д.
В ячейке D2 – показать первую ЛИШНЮЮ ячейку из столбца А, которая ещё есть в столбце В с прошлого копипаста (хотя в А её уже нет).
Спасибо!
К сообщению приложен файл: 6029787.xlsx(10Kb)
 
Ответить
СообщениеУважаемые эксперты, нужна Ваша помощь!
Есть диапазон значений А:А (создаётся формулой, вытягивающей значения с Лист2). Значения уникальны.
Есть диапазон значений В:В – результат копипаста столбца А (через вставку значений).
Со времени последнего копипаста в столбец В, значения на Лист2 изменились, а следовательно, изменились и значения столбца А. Таким образом, содержание столбцов А и В – различаются.
Необходимо:
В ячейке С2 показать первую НОВУЮ ячейку из стобца А, которой нет в столбце В. В С3 – вторую новую и т.д.
В ячейке D2 – показать первую ЛИШНЮЮ ячейку из столбца А, которая ещё есть в столбце В с прошлого копипаста (хотя в А её уже нет).
Спасибо!

Автор - Strateg_ru
Дата добавления - 23.09.2016 в 17:32
Pelena Дата: Пятница, 23.09.2016, 18:16 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9867
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$36;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$12;$A$2:$A$36)=0;СТРОКА($A$2:$A$36)-1);СТРОКА(A1)));"")
К сообщению приложен файл: 4840984.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$36;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$12;$A$2:$A$36)=0;СТРОКА($A$2:$A$36)-1);СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 23.09.2016 в 18:16
Strateg_ru Дата: Пятница, 23.09.2016, 19:02 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, спасибо. Только не совсем понял, как растянуть диапазон в столбце В. Потому что, если копируем информацию из А в В (вставкой значений), то в столбцах С и D не должно быть ничего - то есть ни новых ни лишних значений нет. А в вашем примере есть, потому что формула учитывает только 11 существующих сейчас значений. Как сделать так, чтобы А и В учитывались, например, на 1000 ячеек?
Простым растягиванием диапазона - эффект совсем другой...


Сообщение отредактировал Strateg_ru - Пятница, 23.09.2016, 19:03
 
Ответить
СообщениеPelena, спасибо. Только не совсем понял, как растянуть диапазон в столбце В. Потому что, если копируем информацию из А в В (вставкой значений), то в столбцах С и D не должно быть ничего - то есть ни новых ни лишних значений нет. А в вашем примере есть, потому что формула учитывает только 11 существующих сейчас значений. Как сделать так, чтобы А и В учитывались, например, на 1000 ячеек?
Простым растягиванием диапазона - эффект совсем другой...

Автор - Strateg_ru
Дата добавления - 23.09.2016 в 19:02
Pelena Дата: Пятница, 23.09.2016, 19:09 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9867
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Просто увеличьте диапазон
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$1000;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$1000;$A$2:$A$1000)=0;СТРОКА($A$2:$A$1000)-1);СТРОКА(A1)));"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПросто увеличьте диапазон
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$1000;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$1000;$A$2:$A$1000)=0;СТРОКА($A$2:$A$1000)-1);СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 23.09.2016 в 19:09
Strateg_ru Дата: Пятница, 23.09.2016, 19:46 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, эм... ещё раз sorry... покажите - что не так?
К сообщению приложен файл: 2083227.xlsx(12Kb)
 
Ответить
СообщениеPelena, эм... ещё раз sorry... покажите - что не так?

Автор - Strateg_ru
Дата добавления - 23.09.2016 в 19:46
Pelena Дата: Пятница, 23.09.2016, 19:49 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9867
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Вместо 999 поставьте 1000, как и везде
К сообщению приложен файл: 3576034.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВместо 999 поставьте 1000, как и везде

Автор - Pelena
Дата добавления - 23.09.2016 в 19:49
Strateg_ru Дата: Пятница, 23.09.2016, 20:37 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, да, всё работает.
Подскажите ещё - а что происходит, если над всей этой конструкцией добавть 1, 2, 10 строк... почему сбивается формула и как сделать, чтобы она работала везде? (т.е если выделить строку 1, Вставить)
 
Ответить
СообщениеPelena, да, всё работает.
Подскажите ещё - а что происходит, если над всей этой конструкцией добавть 1, 2, 10 строк... почему сбивается формула и как сделать, чтобы она работала везде? (т.е если выделить строку 1, Вставить)

Автор - Strateg_ru
Дата добавления - 23.09.2016 в 20:37
Pelena Дата: Пятница, 23.09.2016, 20:48 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9867
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Пример "несбиваемой" формулы
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$1000;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$1000;$A$2:$A$1000)=0;СТРОКА($A$2:$A$1000)-СТРОКА($A$2)+1);СТРОКА()-СТРОКА($A$2)+1));"")
К сообщению приложен файл: 0225545.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПример "несбиваемой" формулы
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$1000;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$1000;$A$2:$A$1000)=0;СТРОКА($A$2:$A$1000)-СТРОКА($A$2)+1);СТРОКА()-СТРОКА($A$2)+1));"")

Автор - Pelena
Дата добавления - 23.09.2016 в 20:48
Strateg_ru Дата: Пятница, 23.09.2016, 22:10 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, оу.. эта формула сразу заработало в целевом документе! А то уж я думал, что я чего-то не понимаю в формулах... Сейчас я уже в этом уверен %)
Всё таки приятно работать с волшебниками :p
Спасибо Вам огромное!

Тему можно закрывать.
 
Ответить
СообщениеPelena, оу.. эта формула сразу заработало в целевом документе! А то уж я думал, что я чего-то не понимаю в формулах... Сейчас я уже в этом уверен %)
Всё таки приятно работать с волшебниками :p
Спасибо Вам огромное!

Тему можно закрывать.

Автор - Strateg_ru
Дата добавления - 23.09.2016 в 22:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Новые значения и лишние значения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!