Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск позиции (уникальные значения) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск позиции (уникальные значения) (Формулы/Formulas)
Поиск позиции (уникальные значения)
heaven33rus Дата: Понедельник, 26.09.2016, 17:16 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Приветствую.
Подскажите, есть ли какой прием для оптимизации способа, которым я сравниваю таблицы.
Есть два списка с именами и номерами. В случае, если я использую поиск позиции во второй таблице, то в ячейках напротив ячейки с не уникальными именами, отображается первый найденный номер для такого имени из первого списка.
Словами наверно не сильно понятно, смотрите файлик :)

спасибо :)
К сообщению приложен файл: 7303587.xls(28Kb)
 
Ответить
СообщениеПриветствую.
Подскажите, есть ли какой прием для оптимизации способа, которым я сравниваю таблицы.
Есть два списка с именами и номерами. В случае, если я использую поиск позиции во второй таблице, то в ячейках напротив ячейки с не уникальными именами, отображается первый найденный номер для такого имени из первого списка.
Словами наверно не сильно понятно, смотрите файлик :)

спасибо :)

Автор - heaven33rus
Дата добавления - 26.09.2016 в 17:16
_Boroda_ Дата: Понедельник, 26.09.2016, 17:45 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$3:C$9;НАИМЕНЬШИЙ(ЕСЛИ(B$3:B$9=G3;СТРОКА(B$1:B$7));СЧЁТЕСЛИ(G$3:G3;G3)));"")
К сообщению приложен файл: 7303587_1.xls(29Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$3:C$9;НАИМЕНЬШИЙ(ЕСЛИ(B$3:B$9=G3;СТРОКА(B$1:B$7));СЧЁТЕСЛИ(G$3:G3;G3)));"")

Автор - _Boroda_
Дата добавления - 26.09.2016 в 17:45
jakim Дата: Понедельник, 26.09.2016, 20:10 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 763
Репутация: 196 ±
Замечаний: 0% ±

Для Вас подойдёт и такая формула

Код
=INDEX(C:C;AGGREGATE(15;6;ROW(C$3:C$477)/($B$3:$B$477=E3);COUNTIF($E$3:$E3;$E3)))
К сообщению приложен файл: 7303587.xlsx(9Kb)
 
Ответить
Сообщение
Для Вас подойдёт и такая формула

Код
=INDEX(C:C;AGGREGATE(15;6;ROW(C$3:C$477)/($B$3:$B$477=E3);COUNTIF($E$3:$E3;$E3)))

Автор - jakim
Дата добавления - 26.09.2016 в 20:10
heaven33rus Дата: Вторник, 27.09.2016, 11:26 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Так нужно?

Работает в моем примере, но не смог это применить к моим огроменным файлам :) Спасибо.

Для Вас подойдёт и такая формула

А вот эта штука видимо попроще, работает на ура :) Спасибо огромное :) )


Сообщение отредактировал Manyasha - Вторник, 27.09.2016, 11:37
 
Ответить
Сообщение
Так нужно?

Работает в моем примере, но не смог это применить к моим огроменным файлам :) Спасибо.

Для Вас подойдёт и такая формула

А вот эта штука видимо попроще, работает на ура :) Спасибо огромное :) )

Автор - heaven33rus
Дата добавления - 27.09.2016 в 11:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск позиции (уникальные значения) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!