Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск пустых ячеек по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск пустых ячеек по условию (Формулы/Formulas)
Поиск пустых ячеек по условию
Leprotto Дата: Вторник, 27.09.2016, 14:22 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день, форумчане!
Тыркаюсь, не могу подсчитать и определить места пустых ячеек, рядом с которыми дата.
Короткий пример приложил.
К сообщению приложен файл: poisk_bez_koda.xlsx(10Kb)
 
Ответить
СообщениеДобрый день, форумчане!
Тыркаюсь, не могу подсчитать и определить места пустых ячеек, рядом с которыми дата.
Короткий пример приложил.

Автор - Leprotto
Дата добавления - 27.09.2016 в 14:22
buchlotnik Дата: Вторник, 27.09.2016, 14:29 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=SUMPRODUCT(ISBLANK(Таблица1[Код])*ISNUMBER(Таблица1[Дата]))
или
Код
=COUNTIFS(Таблица1[Код];"";Таблица1[Дата];">0")


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Вторник, 27.09.2016, 14:31
 
Ответить
Сообщениетак нужно?
Код
=SUMPRODUCT(ISBLANK(Таблица1[Код])*ISNUMBER(Таблица1[Дата]))
или
Код
=COUNTIFS(Таблица1[Код];"";Таблица1[Дата];">0")

Автор - buchlotnik
Дата добавления - 27.09.2016 в 14:29
_Boroda_ Дата: Вторник, 27.09.2016, 14:31 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9371
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СЧЁТЕСЛИМН(A5:A12;"";B5:B12;">0")

Код
=СЧЁТЕСЛИМН(A5:A12;"";B5:B12;"<>")

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ((A$5:A$12="")*B$5:B$12;СТРОКА(B$5:B$12));СТРОКА(A1));"")
К сообщению приложен файл: poisk_bez_koda_.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СЧЁТЕСЛИМН(A5:A12;"";B5:B12;">0")

Код
=СЧЁТЕСЛИМН(A5:A12;"";B5:B12;"<>")

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ((A$5:A$12="")*B$5:B$12;СТРОКА(B$5:B$12));СТРОКА(A1));"")

Автор - _Boroda_
Дата добавления - 27.09.2016 в 14:31
Leprotto Дата: Вторник, 27.09.2016, 16:19 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
buchlotnik, _Boroda_,
СПАСИБО БОЛЬШОЕ !!!
 
Ответить
Сообщениеbuchlotnik, _Boroda_,
СПАСИБО БОЛЬШОЕ !!!

Автор - Leprotto
Дата добавления - 27.09.2016 в 16:19
Leprotto Дата: Среда, 28.09.2016, 11:59 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, Посмотрите, пожалуйста...
Использовал Ваше решение аналогичной задачи (для поиска отсутствия дат)
и выяснилось, что работает только если код это число.
С любыми другими символами в столбце "Код" формула перестает работать :(
К сообщению приложен файл: 0887524.xlsx(14Kb)
 
Ответить
Сообщение_Boroda_, Посмотрите, пожалуйста...
Использовал Ваше решение аналогичной задачи (для поиска отсутствия дат)
и выяснилось, что работает только если код это число.
С любыми другими символами в столбце "Код" формула перестает работать :(

Автор - Leprotto
Дата добавления - 28.09.2016 в 11:59
buchlotnik Дата: Среда, 28.09.2016, 12:05 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
не догнал, а что не работает?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 28.09.2016, 12:08
 
Ответить
Сообщениене догнал, а что не работает?

Автор - buchlotnik
Дата добавления - 28.09.2016 в 12:05
Leprotto Дата: Среда, 28.09.2016, 13:22 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
buchlotnik, формула определения строки, предложенная _Boroda_.
Если все коды числовые, то все работает.
Если хотя бы один код текстовый, то не работает.
См. файл, отметил синим.
К сообщению приложен файл: 0014657.xlsx(14Kb)
 
Ответить
Сообщениеbuchlotnik, формула определения строки, предложенная _Boroda_.
Если все коды числовые, то все работает.
Если хотя бы один код текстовый, то не работает.
См. файл, отметил синим.

Автор - Leprotto
Дата добавления - 28.09.2016 в 13:22
buchlotnik Дата: Среда, 28.09.2016, 13:28 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
понял - тогда вот так:
Код
=IFERROR(SMALL(IF((B$5:B$12="")*(A$5:A$12<>"");ROW(A$5:A$12));ROW(A1));"")
К сообщению приложен файл: 8803839.xlsx(14Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениепонял - тогда вот так:
Код
=IFERROR(SMALL(IF((B$5:B$12="")*(A$5:A$12<>"");ROW(A$5:A$12));ROW(A1));"")

Автор - buchlotnik
Дата добавления - 28.09.2016 в 13:28
Leprotto Дата: Среда, 28.09.2016, 13:42 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
buchlotnik, Помогло. Благодарю ))
 
Ответить
Сообщениеbuchlotnik, Помогло. Благодарю ))

Автор - Leprotto
Дата добавления - 28.09.2016 в 13:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск пустых ячеек по условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!