Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/счётесли критерий формула - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » счётесли критерий формула (Формулы/Formulas)
счётесли критерий формула
VictorM Дата: Среда, 28.09.2016, 12:10 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 27 ±
Замечаний: 0% ±

Здравствуйте, Уважаемые.
Подскажите, пожалуйста, как мне прописать формулу типа
[vba]
Код
=СЧЁТЕСЛИ(($A$11:$A$50);ПРАВСИМВ($A$11:$A$50;1)
[/vba]
и соответственно определяла ПРАВСИМВ и считала
гуглом пользовался - ничего не смог найти


Сообщение отредактировал VictorM - Среда, 28.09.2016, 12:11
 
Ответить
СообщениеЗдравствуйте, Уважаемые.
Подскажите, пожалуйста, как мне прописать формулу типа
[vba]
Код
=СЧЁТЕСЛИ(($A$11:$A$50);ПРАВСИМВ($A$11:$A$50;1)
[/vba]
и соответственно определяла ПРАВСИМВ и считала
гуглом пользовался - ничего не смог найти

Автор - VictorM
Дата добавления - 28.09.2016 в 12:10
VictorM Дата: Среда, 28.09.2016, 12:14 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 27 ±
Замечаний: 0% ±

тоже самое и
[vba]
Код
=СУММЕСЛИ($A$11:$A$50;1;$C$11:$C$50)
[/vba]
только вместо 1 должна быть ПРАВСИМВ
 
Ответить
Сообщениетоже самое и
[vba]
Код
=СУММЕСЛИ($A$11:$A$50;1;$C$11:$C$50)
[/vba]
только вместо 1 должна быть ПРАВСИМВ

Автор - VictorM
Дата добавления - 28.09.2016 в 12:14
buchlotnik Дата: Среда, 28.09.2016, 12:19 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=SUMPRODUCT(--(RIGHT($A$11:$A$50;1)="1"))


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=SUMPRODUCT(--(RIGHT($A$11:$A$50;1)="1"))

Автор - buchlotnik
Дата добавления - 28.09.2016 в 12:19
VictorM Дата: Среда, 28.09.2016, 12:29 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 27 ±
Замечаний: 0% ±

да, спасибо!
со СЧЕТЕСЛИ получилось!
 
Ответить
Сообщениеда, спасибо!
со СЧЕТЕСЛИ получилось!

Автор - VictorM
Дата добавления - 28.09.2016 в 12:29
buchlotnik Дата: Среда, 28.09.2016, 12:31 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
со СЧЕТЕСЛИ получилось!
так поделитесь решением yes


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
со СЧЕТЕСЛИ получилось!
так поделитесь решением yes

Автор - buchlotnik
Дата добавления - 28.09.2016 в 12:31
VictorM Дата: Среда, 28.09.2016, 12:34 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 27 ±
Замечаний: 0% ±

Цитата
так поделитесь решением

решение - Ваша формула.
работает как нужно было в первом посте, все считает
 
Ответить
Сообщение
Цитата
так поделитесь решением

решение - Ваша формула.
работает как нужно было в первом посте, все считает

Автор - VictorM
Дата добавления - 28.09.2016 в 12:34
VictorM Дата: Среда, 28.09.2016, 12:37 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 27 ±
Замечаний: 0% ±

а вот с СУММЕСЛИ не получается ничего (
 
Ответить
Сообщениеа вот с СУММЕСЛИ не получается ничего (

Автор - VictorM
Дата добавления - 28.09.2016 в 12:37
buchlotnik Дата: Среда, 28.09.2016, 12:46 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
дык то же самое:
Код
=СУММПРОИЗВ(диапазон_суммирования*(ПРАВСИМВ($A$11:$A$50;1)="1"))


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениедык то же самое:
Код
=СУММПРОИЗВ(диапазон_суммирования*(ПРАВСИМВ($A$11:$A$50;1)="1"))

Автор - buchlotnik
Дата добавления - 28.09.2016 в 12:46
_Boroda_ Дата: Среда, 28.09.2016, 12:56 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
VictorM, Файл-пример приложите


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеVictorM, Файл-пример приложите

Автор - _Boroda_
Дата добавления - 28.09.2016 в 12:56
VictorM Дата: Среда, 28.09.2016, 13:29 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 27 ±
Замечаний: 0% ±

Цитата
дык то же самое:

спасибо.
Все сработало
 
Ответить
Сообщение
Цитата
дык то же самое:

спасибо.
Все сработало

Автор - VictorM
Дата добавления - 28.09.2016 в 13:29
VictorM Дата: Среда, 28.09.2016, 13:34 | Сообщение № 11
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 27 ±
Замечаний: 0% ±

Цитата
Файл-пример приложите


да, извините, вот пример файла
К сообщению приложен файл: 3657025.xls(14Kb)
 
Ответить
Сообщение
Цитата
Файл-пример приложите


да, извините, вот пример файла

Автор - VictorM
Дата добавления - 28.09.2016 в 13:34
buchlotnik Дата: Среда, 28.09.2016, 13:37 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
тогда можно и так:
Код
=COUNTIF(A11:A20;"*_1")
Код
=SUMIF(A11:A20;"*_1";C11:C20)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетогда можно и так:
Код
=COUNTIF(A11:A20;"*_1")
Код
=SUMIF(A11:A20;"*_1";C11:C20)

Автор - buchlotnik
Дата добавления - 28.09.2016 в 13:37
_Boroda_ Дата: Среда, 28.09.2016, 13:40 | Сообщение № 13
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=СУММЕСЛИ(A11:A20;"*"&D2;C11:C20)

Код
=СЧЁТЕСЛИ(A11:A20;"*"&D2)
К сообщению приложен файл: 3657025_1.xls(32Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=СУММЕСЛИ(A11:A20;"*"&D2;C11:C20)

Код
=СЧЁТЕСЛИ(A11:A20;"*"&D2)

Автор - _Boroda_
Дата добавления - 28.09.2016 в 13:40
VictorM Дата: Среда, 28.09.2016, 18:48 | Сообщение № 14
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 27 ±
Замечаний: 0% ±

Спасибо всем за помощь.
Вопрос закрыт.
 
Ответить
СообщениеСпасибо всем за помощь.
Вопрос закрыт.

Автор - VictorM
Дата добавления - 28.09.2016 в 18:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » счётесли критерий формула (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!