Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма между пустыми ячейками - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма между пустыми ячейками (Формулы/Formulas)
Сумма между пустыми ячейками
AVI Дата: Четверг, 29.09.2016, 10:53 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
У меня формируются столбцы А и В.
Подразумевается, что ячейка A2 это сумма цифр из B3:B4, A5 = сумм(B6:B9), A10 = сумм(B11:B13)
Но это не всегда верно, поэтому нужна проверка. То есть отдельно сложить суммы между пустыми ячейками в столбце В и вывести их в ячейки как указано в столбце С
В статичном виде я могу сделать, я могу сделать, что бы складывалось от пустой и вниз, но как ограничить суммирование следующей пустой ячейкой я не знаю.
К сообщению приложен файл: sum.xlsx(9Kb)


Сообщение отредактировал AVI - Четверг, 29.09.2016, 10:54
 
Ответить
СообщениеДобрый день!
У меня формируются столбцы А и В.
Подразумевается, что ячейка A2 это сумма цифр из B3:B4, A5 = сумм(B6:B9), A10 = сумм(B11:B13)
Но это не всегда верно, поэтому нужна проверка. То есть отдельно сложить суммы между пустыми ячейками в столбце В и вывести их в ячейки как указано в столбце С
В статичном виде я могу сделать, я могу сделать, что бы складывалось от пустой и вниз, но как ограничить суммирование следующей пустой ячейкой я не знаю.

Автор - AVI
Дата добавления - 29.09.2016 в 10:53
buchlotnik Дата: Четверг, 29.09.2016, 11:10 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно? (массивка)
Код
=IF(ISBLANK(B2);SUM(B3:INDEX($B$1:B35;MIN(IF(ISBLANK(B3:B35);ROW(B3:B35);""))));"")
К сообщению приложен файл: 0388509.xlsx(11Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно? (массивка)
Код
=IF(ISBLANK(B2);SUM(B3:INDEX($B$1:B35;MIN(IF(ISBLANK(B3:B35);ROW(B3:B35);""))));"")

Автор - buchlotnik
Дата добавления - 29.09.2016 в 11:10
_Boroda_ Дата: Четверг, 29.09.2016, 11:32 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вариант
Код
=ЕСЛИ(A2="";"";СУММ(B3:B99)-СУММ(C3:C99))
К сообщению приложен файл: um_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вариант
Код
=ЕСЛИ(A2="";"";СУММ(B3:B99)-СУММ(C3:C99))

Автор - _Boroda_
Дата добавления - 29.09.2016 в 11:32
AVI Дата: Четверг, 29.09.2016, 11:42 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, да, но если перенести формулу в другое место суммы собираются не верные
Ап. Разобрался, спасибо!


Сообщение отредактировал AVI - Четверг, 29.09.2016, 11:50
 
Ответить
Сообщениеbuchlotnik, да, но если перенести формулу в другое место суммы собираются не верные
Ап. Разобрался, спасибо!

Автор - AVI
Дата добавления - 29.09.2016 в 11:42
AVI Дата: Четверг, 29.09.2016, 11:52 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, Спасибо, я почти так же делал, но не доделал... Спасибо, большое!
 
Ответить
Сообщение_Boroda_, Спасибо, я почти так же делал, но не доделал... Спасибо, большое!

Автор - AVI
Дата добавления - 29.09.2016 в 11:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма между пустыми ячейками (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!