Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск столбца по условиям из ячейки, пример прилагается. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск столбца по условиям из ячейки, пример прилагается. (Формулы/Formulas)
Поиск столбца по условиям из ячейки, пример прилагается.
valermihali4 Дата: Четверг, 29.09.2016, 13:03 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Как вставить в ячейку значение из определенного столбца используя поиск.
К сообщению приложен файл: 5613445.xlsx(11Kb)
 
Ответить
СообщениеКак вставить в ячейку значение из определенного столбца используя поиск.

Автор - valermihali4
Дата добавления - 29.09.2016 в 13:03
buchlotnik Дата: Четверг, 29.09.2016, 13:10 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
И вам здравствуйте.
Цитата
используя поиск
никак, ПОИСК() в строке ищет.
Код
=VLOOKUP(A1;Лист2!$D$9:$E$17;2;0)

хотя, что это я, ловите:
Код
=LOOKUP(;-1/SEARCH(A1;Лист2!$D$9:$D$17);Лист2!$E$9:$E$17)
К сообщению приложен файл: 7840918.xlsx(11Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 29.09.2016, 13:12
 
Ответить
СообщениеИ вам здравствуйте.
Цитата
используя поиск
никак, ПОИСК() в строке ищет.
Код
=VLOOKUP(A1;Лист2!$D$9:$E$17;2;0)

хотя, что это я, ловите:
Код
=LOOKUP(;-1/SEARCH(A1;Лист2!$D$9:$D$17);Лист2!$E$9:$E$17)

Автор - buchlotnik
Дата добавления - 29.09.2016 в 13:10
Che79 Дата: Четверг, 29.09.2016, 13:10 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 177
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
valermihali4, здравствуйте.
Так нужно?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(A1;Лист2!$D$9:$D$17;Лист2!$E$9:$E$17);"")
К сообщению приложен файл: 290916.xlsx(11Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Четверг, 29.09.2016, 13:26
 
Ответить
Сообщениеvalermihali4, здравствуйте.
Так нужно?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(A1;Лист2!$D$9:$D$17;Лист2!$E$9:$E$17);"")

Автор - Che79
Дата добавления - 29.09.2016 в 13:10
valermihali4 Дата: Четверг, 29.09.2016, 13:15 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо огромное за ответ! Первый предложенный подошел идеально.
Проще в инженерной программе нарисовать слона чем справится с этим экселем))))
Еще раз большое спасибо, всем. hands hands hands
 
Ответить
СообщениеСпасибо огромное за ответ! Первый предложенный подошел идеально.
Проще в инженерной программе нарисовать слона чем справится с этим экселем))))
Еще раз большое спасибо, всем. hands hands hands

Автор - valermihali4
Дата добавления - 29.09.2016 в 13:15
buchlotnik Дата: Четверг, 29.09.2016, 13:16 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
[offtop]А можно поподробнее про сложности рисования слонов, или нужно в масштабе 1 к 1? :D


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение[offtop]А можно поподробнее про сложности рисования слонов, или нужно в масштабе 1 к 1? :D

Автор - buchlotnik
Дата добавления - 29.09.2016 в 13:16
valermihali4 Дата: Четверг, 29.09.2016, 13:19 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
я имел ввиду в солид воркс в 3d )))
 
Ответить
Сообщениея имел ввиду в солид воркс в 3d )))

Автор - valermihali4
Дата добавления - 29.09.2016 в 13:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск столбца по условиям из ячейки, пример прилагается. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!