Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выставить значиния в зависимости от даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выставить значиния в зависимости от даты (Формулы/Formulas)
Выставить значиния в зависимости от даты
Alabama19 Дата: Пятница, 30.09.2016, 02:22 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Выставить значиния в зависимости от даты. При том что датой должно являться сегодняшнее число. Пример приложил, думаю там все понятней.
К сообщению приложен файл: 2988594.xlsx(10Kb)
 
Ответить
СообщениеВыставить значиния в зависимости от даты. При том что датой должно являться сегодняшнее число. Пример приложил, думаю там все понятней.

Автор - Alabama19
Дата добавления - 30.09.2016 в 02:22
AVI Дата: Пятница, 30.09.2016, 06:58 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Alabama19, пойдет?
Это по условию
Код
=ЕСЛИ(ИЛИ(B1=СЕГОДНЯ();B1=СЕГОДНЯ()-1);1;"")

Это, если нужно в остальных остальных поставить 2
Код
=ЕСЛИ(ИЛИ(B1=СЕГОДНЯ();B1=СЕГОДНЯ()-1);1;2)


Сообщение отредактировал AVI - Пятница, 30.09.2016, 07:01
 
Ответить
СообщениеAlabama19, пойдет?
Это по условию
Код
=ЕСЛИ(ИЛИ(B1=СЕГОДНЯ();B1=СЕГОДНЯ()-1);1;"")

Это, если нужно в остальных остальных поставить 2
Код
=ЕСЛИ(ИЛИ(B1=СЕГОДНЯ();B1=СЕГОДНЯ()-1);1;2)

Автор - AVI
Дата добавления - 30.09.2016 в 06:58
Nic70y Дата: Пятница, 30.09.2016, 07:19 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3924
Репутация: 831 ±
Замечаний: 0% ±

Excel 2013
Код
=2-(СЕГОДНЯ()-B1<2)
Код
=2-(СЕГОДНЯ()-B1<2)+(СЕГОДНЯ()<B1)
Код
=2-(ЦЕЛОЕ((СЕГОДНЯ()-B1)/2)=0)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Пятница, 30.09.2016, 07:30
 
Ответить
Сообщение
Код
=2-(СЕГОДНЯ()-B1<2)
Код
=2-(СЕГОДНЯ()-B1<2)+(СЕГОДНЯ()<B1)
Код
=2-(ЦЕЛОЕ((СЕГОДНЯ()-B1)/2)=0)

Автор - Nic70y
Дата добавления - 30.09.2016 в 07:19
AVI Дата: Пятница, 30.09.2016, 07:32 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Пошло любимое "до кучи")))
 
Ответить
СообщениеПошло любимое "до кучи")))

Автор - AVI
Дата добавления - 30.09.2016 в 07:32
buchlotnik Дата: Пятница, 30.09.2016, 09:23 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2627
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так чутка проще:
Код
=2-(TODAY()-B11<2)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак чутка проще:
Код
=2-(TODAY()-B11<2)

Автор - buchlotnik
Дата добавления - 30.09.2016 в 09:23
Nic70y Дата: Пятница, 30.09.2016, 09:59 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3924
Репутация: 831 ±
Замечаний: 0% ±

Excel 2013
чутка проще
так уже есть
=2-(СЕГОДНЯ()-B1<2)
но тогда завтра и т.д. попадет


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
чутка проще
так уже есть
=2-(СЕГОДНЯ()-B1<2)
но тогда завтра и т.д. попадет

Автор - Nic70y
Дата добавления - 30.09.2016 в 09:59
buchlotnik Дата: Пятница, 30.09.2016, 10:06 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2627
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
тогда завтра и т.д. попадет
Николай, завтра быть не может - там столбец В к СЕГОДНЯ() привязан (типа сегодня и раньше)
Цитата
так уже есть
проглядел - утро пятницы - простительно :)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
тогда завтра и т.д. попадет
Николай, завтра быть не может - там столбец В к СЕГОДНЯ() привязан (типа сегодня и раньше)
Цитата
так уже есть
проглядел - утро пятницы - простительно :)

Автор - buchlotnik
Дата добавления - 30.09.2016 в 10:06
AVI Дата: Пятница, 30.09.2016, 10:10 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Как-то вы все подругому мыслите)
 
Ответить
СообщениеКак-то вы все подругому мыслите)

Автор - AVI
Дата добавления - 30.09.2016 в 10:10
Nic70y Дата: Пятница, 30.09.2016, 10:15 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3924
Репутация: 831 ±
Замечаний: 0% ±

Excel 2013
быть не может
точно, а я и не смотрел, что там формулы и доп.столбец :D
подругому мыслите)
это мы "выпендриваемся" :D


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
быть не может
точно, а я и не смотрел, что там формулы и доп.столбец :D
подругому мыслите)
это мы "выпендриваемся" :D

Автор - Nic70y
Дата добавления - 30.09.2016 в 10:15
buchlotnik Дата: Пятница, 30.09.2016, 10:24 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2627
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
"выпендриваемся"
ну да B) , а с учётом столбца А можно просто
Код
=1+(A1>1)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 30.09.2016, 10:24
 
Ответить
Сообщение
Цитата
"выпендриваемся"
ну да B) , а с учётом столбца А можно просто
Код
=1+(A1>1)

Автор - buchlotnik
Дата добавления - 30.09.2016 в 10:24
AVI Дата: Пятница, 30.09.2016, 10:39 | Сообщение № 11
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Нужно ждать _Boroda_


Сообщение отредактировал AVI - Пятница, 30.09.2016, 10:40
 
Ответить
СообщениеНужно ждать _Boroda_

Автор - AVI
Дата добавления - 30.09.2016 в 10:39
buchlotnik Дата: Пятница, 30.09.2016, 10:43 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2627
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
AVI, вам ТЕКСТА() не хватает? Ловите :)
Код
=TEXT(TODAY()-B11;"[<2]1;2")


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеAVI, вам ТЕКСТА() не хватает? Ловите :)
Код
=TEXT(TODAY()-B11;"[<2]1;2")

Автор - buchlotnik
Дата добавления - 30.09.2016 в 10:43
китин Дата: Пятница, 30.09.2016, 10:54 | Сообщение № 13
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4117
Репутация: 636 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну и до кучи
Код
=ЕСЛИОШИБКА(ПРОСМОТР(1;СЕГОДНЯ()-B1;1);"")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену и до кучи
Код
=ЕСЛИОШИБКА(ПРОСМОТР(1;СЕГОДНЯ()-B1;1);"")

Автор - китин
Дата добавления - 30.09.2016 в 10:54
AVI Дата: Пятница, 30.09.2016, 10:59 | Сообщение № 14
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, спасибо, только не автор статьи)
 
Ответить
Сообщениеbuchlotnik, спасибо, только не автор статьи)

Автор - AVI
Дата добавления - 30.09.2016 в 10:59
Alabama19 Дата: Пятница, 30.09.2016, 16:34 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем огромное, человеческое, спасибо! Выручили тысячный раз!
 
Ответить
СообщениеВсем огромное, человеческое, спасибо! Выручили тысячный раз!

Автор - Alabama19
Дата добавления - 30.09.2016 в 16:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выставить значиния в зависимости от даты (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!