Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР при разбиении столбца со значением на несколько строк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР при разбиении столбца со значением на несколько строк (Формулы/Formulas)
ВПР при разбиении столбца со значением на несколько строк
Nikolay86 Дата: Пятница, 30.09.2016, 11:06 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Цель: Расчет стоимости одной единицы товара
В файле Primer с помощью ВПР могу получить цену товаров из базы, но не могу получить количество товара т.к. столбец с искомым элементом разбивается на две строки.
К сообщению приложен файл: Primer.xlsx(12Kb)
 
Ответить
СообщениеЦель: Расчет стоимости одной единицы товара
В файле Primer с помощью ВПР могу получить цену товаров из базы, но не могу получить количество товара т.к. столбец с искомым элементом разбивается на две строки.

Автор - Nikolay86
Дата добавления - 30.09.2016 в 11:06
buchlotnik Дата: Пятница, 30.09.2016, 11:11 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
столбец с искомым элементом разбивается на две строки
руки за такое отрывать надо >( , ну да ладно победим:
Код
=INDEX(База!$F$6:$F$31;MATCH(A5;База!$A$6:$A$31;0)+1)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 30.09.2016, 11:16
 
Ответить
Сообщение
Цитата
столбец с искомым элементом разбивается на две строки
руки за такое отрывать надо >( , ну да ладно победим:
Код
=INDEX(База!$F$6:$F$31;MATCH(A5;База!$A$6:$A$31;0)+1)

Автор - buchlotnik
Дата добавления - 30.09.2016 в 11:11
Nikolay86 Дата: Пятница, 30.09.2016, 11:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
=ИНДЕКС(База!$F$6:$F$31;ПОИСКПОЗ(A5;База!$A$6:$A$31;0)+1)

Работает. Спасибо. Сам так пробовал только "+1" не ставил и он мне цену все возвращал :( .
 
Ответить
Сообщение
=ИНДЕКС(База!$F$6:$F$31;ПОИСКПОЗ(A5;База!$A$6:$A$31;0)+1)

Работает. Спасибо. Сам так пробовал только "+1" не ставил и он мне цену все возвращал :( .

Автор - Nikolay86
Дата добавления - 30.09.2016 в 11:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР при разбиении столбца со значением на несколько строк (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!