Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма по значениям заданных дат - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по значениям заданных дат (Формулы/Formulas)
Сумма по значениям заданных дат
122334boss Дата: Пятница, 30.09.2016, 13:45 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 191
Репутация: 0 ±
Замечаний: 20% ±

Добрый день.

Помогите решить проблему.
В прикрепленном файле пример, в котором нужно просуммировать значения приближающихся дат и долг по прошедшим датам.

Заранее спасибо)))
К сообщению приложен файл: 6646041.xlsx(13Kb)
 
Ответить
СообщениеДобрый день.

Помогите решить проблему.
В прикрепленном файле пример, в котором нужно просуммировать значения приближающихся дат и долг по прошедшим датам.

Заранее спасибо)))

Автор - 122334boss
Дата добавления - 30.09.2016 в 13:45
122334boss Дата: Воскресенье, 02.10.2016, 23:04 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 191
Репутация: 0 ±
Замечаний: 20% ±

Уважаемые форумчане, это не выполнимо?
 
Ответить
СообщениеУважаемые форумчане, это не выполнимо?

Автор - 122334boss
Дата добавления - 02.10.2016 в 23:04
Pelena Дата: Воскресенье, 02.10.2016, 23:23 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9846
Репутация: 2253 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Так подойдёт?
Добавила ещё условное форматирование, чтобы ячейки сами закрашивались
К сообщению приложен файл: 7507415.xlsx(14Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак подойдёт?
Добавила ещё условное форматирование, чтобы ячейки сами закрашивались

Автор - Pelena
Дата добавления - 02.10.2016 в 23:23
122334boss Дата: Воскресенье, 02.10.2016, 23:28 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 191
Репутация: 0 ±
Замечаний: 20% ±

в принципе подойдет, но если в будущем будет 100 платежей, а нужно показать ближайший?
 
Ответить
Сообщениев принципе подойдет, но если в будущем будет 100 платежей, а нужно показать ближайший?

Автор - 122334boss
Дата добавления - 02.10.2016 в 23:28
122334boss Дата: Воскресенье, 02.10.2016, 23:40 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 191
Репутация: 0 ±
Замечаний: 20% ±

Pelena, спасибо...
но дата ближайшего платежа - это не конец месяца, а ближайшее число...
 
Ответить
СообщениеPelena, спасибо...
но дата ближайшего платежа - это не конец месяца, а ближайшее число...

Автор - 122334boss
Дата добавления - 02.10.2016 в 23:40
Pelena Дата: Воскресенье, 02.10.2016, 23:52 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9846
Репутация: 2253 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Так?
К сообщению приложен файл: 2142366.xlsx(14Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак?

Автор - Pelena
Дата добавления - 02.10.2016 в 23:52
gling Дата: Понедельник, 03.10.2016, 00:13 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Здравствуйте. Посмотрите еще вариант.
К сообщению приложен файл: 6761203.xlsx(14Kb)


Сообщение отредактировал gling - Понедельник, 03.10.2016, 00:24
 
Ответить
СообщениеЗдравствуйте. Посмотрите еще вариант.

Автор - gling
Дата добавления - 03.10.2016 в 00:13
122334boss Дата: Понедельник, 03.10.2016, 09:16 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 191
Репутация: 0 ±
Замечаний: 20% ±

Pelena,
если проставить более одной будущей оплаты, то значения даты отображаются не корректно.
 
Ответить
СообщениеPelena,
если проставить более одной будущей оплаты, то значения даты отображаются не корректно.

Автор - 122334boss
Дата добавления - 03.10.2016 в 09:16
122334boss Дата: Понедельник, 03.10.2016, 09:16 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 191
Репутация: 0 ±
Замечаний: 20% ±

gling,
спасибо огромное.
работает так как надо!!!
 
Ответить
Сообщениеgling,
спасибо огромное.
работает так как надо!!!

Автор - 122334boss
Дата добавления - 03.10.2016 в 09:16
Pelena Дата: Понедельник, 03.10.2016, 09:26 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 9846
Репутация: 2253 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
значения даты отображаются не корректно

Так вроде считает
К сообщению приложен файл: 8931971.xlsx(14Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
значения даты отображаются не корректно

Так вроде считает

Автор - Pelena
Дата добавления - 03.10.2016 в 09:26
_Boroda_ Дата: Понедельник, 03.10.2016, 11:14 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще дату можно так
Код
=ИНДЕКС(B7:B999;ПОИСКПОЗ(B1;B6:B998))

а сумму платежа
Код
=ПРОСМОТР(H2;B6:B999;H6:H999+K6:K999)

А дату как у Лены
Код
=СУММПРОИЗВ((B6:B999<B1)*(F5:K5=H5)*F6:K999)
К сообщению приложен файл: 6646041_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще дату можно так
Код
=ИНДЕКС(B7:B999;ПОИСКПОЗ(B1;B6:B998))

а сумму платежа
Код
=ПРОСМОТР(H2;B6:B999;H6:H999+K6:K999)

А дату как у Лены
Код
=СУММПРОИЗВ((B6:B999<B1)*(F5:K5=H5)*F6:K999)

Автор - _Boroda_
Дата добавления - 03.10.2016 в 11:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по значениям заданных дат (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!