Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение отдельных ячеек заданными данными - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение отдельных ячеек заданными данными (Формулы/Formulas)
Заполнение отдельных ячеек заданными данными
feksel Дата: Воскресенье, 02.10.2016, 15:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте :)
В листе ТРЕБУЕТСЯ проставлены даты в ячейке I15:I45 и буквы,цифры и т.д. в ячейках L15:L74 и O15:O74 какими я заполняю таблицу на листе РАСПОЛОЖЕНИЕ, возможно ли реализовать следующее
Если я поставлю на листе ТРЕБУЕТСЯ букву В рядом с датой, то на листе РАСПОЛОЖЕНИЕ под этой датой я мог бы вносить только значения какие есть в листе ТРЕБУЕТСЯ (в ячейках O15:O74) под буквой В.
А если не стоит буква В, то под этой датой я мог бы использовать только значения какие стоят в ячейках L15:L74 на листе ТРЕБУЕТСЯ.
Ну а естественно любые другие сочетания букв и цифр не мог бы вносить в этих ячейках.
К сообщению приложен файл: 2274612.xlsx(41Kb)


Сообщение отредактировал feksel - Воскресенье, 02.10.2016, 15:58
 
Ответить
СообщениеЗдравствуйте :)
В листе ТРЕБУЕТСЯ проставлены даты в ячейке I15:I45 и буквы,цифры и т.д. в ячейках L15:L74 и O15:O74 какими я заполняю таблицу на листе РАСПОЛОЖЕНИЕ, возможно ли реализовать следующее
Если я поставлю на листе ТРЕБУЕТСЯ букву В рядом с датой, то на листе РАСПОЛОЖЕНИЕ под этой датой я мог бы вносить только значения какие есть в листе ТРЕБУЕТСЯ (в ячейках O15:O74) под буквой В.
А если не стоит буква В, то под этой датой я мог бы использовать только значения какие стоят в ячейках L15:L74 на листе ТРЕБУЕТСЯ.
Ну а естественно любые другие сочетания букв и цифр не мог бы вносить в этих ячейках.

Автор - feksel
Дата добавления - 02.10.2016 в 15:50
Karataev Дата: Воскресенье, 02.10.2016, 16:18 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 734
Репутация: 263 ±
Замечаний: 0% ±

Excel
Реализовано с помощью проверки данных. Проверка данных применена на листе расположение в "F4:G10". Используется формула:
Код
=СЧЁТЕСЛИ(ИНДЕКС(Требуется!$A$15:$O$74;0;ЕСЛИ(ВПР(F$3;Требуется!$I:$O;2;0)="в";15;12));F4)>0

PS. Проверка данных не проверяет данные, если одна ячейка копируется в другую ячейку.
Проверку данных можно попробовать сделать в виде выпадающего списка.
К сообщению приложен файл: 9955013.xlsx(40Kb)




Сообщение отредактировал Karataev - Воскресенье, 02.10.2016, 16:21
 
Ответить
СообщениеРеализовано с помощью проверки данных. Проверка данных применена на листе расположение в "F4:G10". Используется формула:
Код
=СЧЁТЕСЛИ(ИНДЕКС(Требуется!$A$15:$O$74;0;ЕСЛИ(ВПР(F$3;Требуется!$I:$O;2;0)="в";15;12));F4)>0

PS. Проверка данных не проверяет данные, если одна ячейка копируется в другую ячейку.
Проверку данных можно попробовать сделать в виде выпадающего списка.

Автор - Karataev
Дата добавления - 02.10.2016 в 16:18
_Boroda_ Дата: Понедельник, 03.10.2016, 12:13 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9834
Репутация: 4152 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Выпадающим списком с автоподстройкой количества элементов. Имена смтортите, нажав Контрл F3. Нам нужны Д0_ и Д1_.
Значения в списках должны быть без пропусков.
К сообщению приложен файл: 0480414.xlsx(40Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВыпадающим списком с автоподстройкой количества элементов. Имена смтортите, нажав Контрл F3. Нам нужны Д0_ и Д1_.
Значения в списках должны быть без пропусков.

Автор - _Boroda_
Дата добавления - 03.10.2016 в 12:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение отдельных ячеек заданными данными (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!