Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор из текста элементов и их склеивание в другой ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор из текста элементов и их склеивание в другой ячейке (Формулы/Formulas)
Выбор из текста элементов и их склеивание в другой ячейке
Webbear Дата: Среда, 05.10.2016, 08:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 2 ±
Замечаний: 0% ±

Excel 2010
Добрый день, уважаемые форумчане!
Не могу сообразить, можно ли сделать следующее действие используя формулы:
В ячейке А1: Заявка № 67 к договору № 1/16-Р
В ячейке В1: З-67-1/16-Р (нужно получить!!!)

Дополнительно: есть вероятность того, что в ячейке А1 запись будет выглядеть иначе. Не будет "№" или пробела между № цифрой (человеческий фактор напр. "заявка 67 к договору №1/16-Р)
Дополнительно 2: часть ячеек может следующий вид
В ячейке А2: Договор № 1/16-Р
В ячейке В2: 1/16-Р (нужно получить!!!)
К сообщению приложен файл: 1234.xlsx(12Kb)
 
Ответить
СообщениеДобрый день, уважаемые форумчане!
Не могу сообразить, можно ли сделать следующее действие используя формулы:
В ячейке А1: Заявка № 67 к договору № 1/16-Р
В ячейке В1: З-67-1/16-Р (нужно получить!!!)

Дополнительно: есть вероятность того, что в ячейке А1 запись будет выглядеть иначе. Не будет "№" или пробела между № цифрой (человеческий фактор напр. "заявка 67 к договору №1/16-Р)
Дополнительно 2: часть ячеек может следующий вид
В ячейке А2: Договор № 1/16-Р
В ячейке В2: 1/16-Р (нужно получить!!!)

Автор - Webbear
Дата добавления - 05.10.2016 в 08:30
buchlotnik Дата: Среда, 05.10.2016, 10:25 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Webbear, можно чутка побольше примеров? Слэш в номере договора всегда есть? номер договора всегда в конце строки? и т.п.


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеWebbear, можно чутка побольше примеров? Слэш в номере договора всегда есть? номер договора всегда в конце строки? и т.п.

Автор - buchlotnik
Дата добавления - 05.10.2016 в 10:25
_Boroda_ Дата: Среда, 05.10.2016, 10:34 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
По поводу "побольше" абсолютно согласен.
Пока такой неоптимизированный вариант
Код
=ЕСЛИ(ЛЕВБ(A1)="з";"З-";"")&ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ЗАМЕНИТЬ(ПСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A1;"№";));" ";ПОВТОР(" ";99));99;99)&ПРАВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A1;"№";);" ";ПОВТОР(" ";99));99);49;99;));" ";"-")
К сообщению приложен файл: 1234_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПо поводу "побольше" абсолютно согласен.
Пока такой неоптимизированный вариант
Код
=ЕСЛИ(ЛЕВБ(A1)="з";"З-";"")&ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ЗАМЕНИТЬ(ПСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A1;"№";));" ";ПОВТОР(" ";99));99;99)&ПРАВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A1;"№";);" ";ПОВТОР(" ";99));99);49;99;));" ";"-")

Автор - _Boroda_
Дата добавления - 05.10.2016 в 10:34
Webbear Дата: Среда, 05.10.2016, 10:57 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 2 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, Добрый день!
Нет, номер может быть любым. Из последних:
1). 1/16-Р
2).Заявка № 67 к договору № 1/16-Р
3).004/02/16 и соответственно заявки к нему и ко всем последующим.
4).5/15-12-01
5).29р/15-12-01
6).16-09 за всю историю один раз встретился.
 
Ответить
Сообщениеbuchlotnik, Добрый день!
Нет, номер может быть любым. Из последних:
1). 1/16-Р
2).Заявка № 67 к договору № 1/16-Р
3).004/02/16 и соответственно заявки к нему и ко всем последующим.
4).5/15-12-01
5).29р/15-12-01
6).16-09 за всю историю один раз встретился.

Автор - Webbear
Дата добавления - 05.10.2016 в 10:57
Webbear Дата: Среда, 05.10.2016, 11:24 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 2 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Спасибо, работает!, но при создании номера З-67-1/16-р почему-то не срабатывает макрос, который берет эти данные и вставляет в другой лист :(
Но это уже совсем другая тема тут
Видимо без макроса не обойтись.... если кто может привести пример оного, буду благодарен.


Сообщение отредактировал Webbear - Среда, 05.10.2016, 11:33
 
Ответить
Сообщение_Boroda_, Спасибо, работает!, но при создании номера З-67-1/16-р почему-то не срабатывает макрос, который берет эти данные и вставляет в другой лист :(
Но это уже совсем другая тема тут
Видимо без макроса не обойтись.... если кто может привести пример оного, буду благодарен.

Автор - Webbear
Дата добавления - 05.10.2016 в 11:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор из текста элементов и их склеивание в другой ячейке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!