Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнить дубликаты по значениям в соседних ячейках - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить дубликаты по значениям в соседних ячейках (Формулы/Formulas)
Сравнить дубликаты по значениям в соседних ячейках
МихаилФаворский Дата: Пятница, 07.10.2016, 23:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Сравнить дубли из столбца B по разнице значений в стоблбцах A и C тех же строк

Помогите, пожалуйста, с нетривиальной задачей..

Есть таблица с данными:
Столбец А - дата_1, столбец B - номера, столбец C - дата_2.
Столбец B содержит дубликаты, однако, в столбцах A и С данные разные.
Нужно проверить номера в столбце B на задвоения, если один и тот же номер присутствует несколько раз, то исключить все дубли кроме того, у которого дата_1 ближе к дате_2 (как до, так и после).
Сделать это нужно добавив столбец D, в котором отметить все уникальные значения и отобранные дубли, например "удовлетворяет условию", а отсеянные дубли (с бОльшей разницей между датами) - "не удовлетворяет условию".
Пример данных во вложении.

Заранее огромное спасибо за помощь!
К сообщению приложен файл: Workbook1.xlsx(46Kb)


Сообщение отредактировал МихаилФаворский - Пятница, 07.10.2016, 23:28
 
Ответить
СообщениеСравнить дубли из столбца B по разнице значений в стоблбцах A и C тех же строк

Помогите, пожалуйста, с нетривиальной задачей..

Есть таблица с данными:
Столбец А - дата_1, столбец B - номера, столбец C - дата_2.
Столбец B содержит дубликаты, однако, в столбцах A и С данные разные.
Нужно проверить номера в столбце B на задвоения, если один и тот же номер присутствует несколько раз, то исключить все дубли кроме того, у которого дата_1 ближе к дате_2 (как до, так и после).
Сделать это нужно добавив столбец D, в котором отметить все уникальные значения и отобранные дубли, например "удовлетворяет условию", а отсеянные дубли (с бОльшей разницей между датами) - "не удовлетворяет условию".
Пример данных во вложении.

Заранее огромное спасибо за помощь!

Автор - МихаилФаворский
Дата добавления - 07.10.2016 в 23:26
Manyasha Дата: Суббота, 08.10.2016, 01:29 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1832
Репутация: 766 ±
Замечаний: 0% ±

Excel 2007, 2010
МихаилФаворский, так нужно?
Код
=ЕСЛИ(МИН(ЕСЛИ($B$2:$B$29=B2;ABS($C$2:$C$29-$A$2:$A$29);""))=ABS(C2-A2);"Да";"Нет")

или так
Код
=--(МИН(ЕСЛИ($B$2:$B$29=B2;ABS($C$2:$C$29-$A$2:$A$29);""))=ABS(C2-A2))
и формат ячеек "Да";;"Нет"

Оба варианта массивные, вводить через ctrl+shift+enter.
К сообщению приложен файл: Workbook1-1.xlsx(11Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеМихаилФаворский, так нужно?
Код
=ЕСЛИ(МИН(ЕСЛИ($B$2:$B$29=B2;ABS($C$2:$C$29-$A$2:$A$29);""))=ABS(C2-A2);"Да";"Нет")

или так
Код
=--(МИН(ЕСЛИ($B$2:$B$29=B2;ABS($C$2:$C$29-$A$2:$A$29);""))=ABS(C2-A2))
и формат ячеек "Да";;"Нет"

Оба варианта массивные, вводить через ctrl+shift+enter.

Автор - Manyasha
Дата добавления - 08.10.2016 в 01:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить дубликаты по значениям в соседних ячейках (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!