Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическая замена данных и расстановка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическая замена данных и расстановка (Формулы/Formulas)
Автоматическая замена данных и расстановка
marishka20016 Дата: Среда, 12.10.2016, 11:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте знатоки!
На работе вот появилась заморочка и я решила обратиться к Вам. Просто пользоваться функцией НАЙТИ и ЗАМЕНИТЬ НА и после еще перенос занимает много времени.
У меня есть 2 листа, один с заполненным графиком, а во второй мне требуется переносить эти значения, но уже с замененными некоторыми значениями ячеек.
На листе ГРАФИК я заполнила одну строку для примера, как он должен заполняться после замены данных ячеек. А теперь попробую пояснить по подробнее что мне требуется.
В листе ГРАФИК 2 в ячейках F5:F14 стоят фамилии сотрудников, а в ячейках G5:AK14 проставлен их рабочий график.
В ячейках C3:C30 данные какие проставляются в графике сотрудников, а в ячейках D3 : D30 те значение, на которые следует заменять значения графика. То есть БД на 22, 99ц на 9, В на пустую и т.д., после чего эти замененные значения должны переносится в лист ГРАФИК на каждого сотрудника отдельно.
Повторюсь - на листе ГРАФИК я заполнила одну строку для примера, как он должен заполняться после замены данных ячеек.
К сообщению приложен файл: 4504107.xlsm(15Kb)


Сообщение отредактировал marishka20016 - Среда, 12.10.2016, 11:07
 
Ответить
СообщениеЗдравствуйте знатоки!
На работе вот появилась заморочка и я решила обратиться к Вам. Просто пользоваться функцией НАЙТИ и ЗАМЕНИТЬ НА и после еще перенос занимает много времени.
У меня есть 2 листа, один с заполненным графиком, а во второй мне требуется переносить эти значения, но уже с замененными некоторыми значениями ячеек.
На листе ГРАФИК я заполнила одну строку для примера, как он должен заполняться после замены данных ячеек. А теперь попробую пояснить по подробнее что мне требуется.
В листе ГРАФИК 2 в ячейках F5:F14 стоят фамилии сотрудников, а в ячейках G5:AK14 проставлен их рабочий график.
В ячейках C3:C30 данные какие проставляются в графике сотрудников, а в ячейках D3 : D30 те значение, на которые следует заменять значения графика. То есть БД на 22, 99ц на 9, В на пустую и т.д., после чего эти замененные значения должны переносится в лист ГРАФИК на каждого сотрудника отдельно.
Повторюсь - на листе ГРАФИК я заполнила одну строку для примера, как он должен заполняться после замены данных ячеек.

Автор - marishka20016
Дата добавления - 12.10.2016 в 11:06
_Boroda_ Дата: Среда, 12.10.2016, 11:17 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ВПР(ИНДЕКС('График (2)'!G$4:G$13;ПОИСКПОЗ($C4;'График (2)'!$F$4:$F$13;));'График (2)'!$C$3:$D$24;2;)

или
Код
=ВПР(ПРОСМОТР(;-1/($C5='График (2)'!$F$4:$F$13);'График (2)'!G$4:G$13);'График (2)'!$C$3:$D$24;2;)
К сообщению приложен файл: 4504107_1.xlsm(18Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ВПР(ИНДЕКС('График (2)'!G$4:G$13;ПОИСКПОЗ($C4;'График (2)'!$F$4:$F$13;));'График (2)'!$C$3:$D$24;2;)

или
Код
=ВПР(ПРОСМОТР(;-1/($C5='График (2)'!$F$4:$F$13);'График (2)'!G$4:G$13);'График (2)'!$C$3:$D$24;2;)

Автор - _Boroda_
Дата добавления - 12.10.2016 в 11:17
marishka20016 Дата: Среда, 12.10.2016, 11:29 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Да, большое спасибо
 
Ответить
СообщениеДа, большое спасибо

Автор - marishka20016
Дата добавления - 12.10.2016 в 11:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическая замена данных и расстановка (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!