Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Иерархия руководителей. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Иерархия руководителей. (Иное/Other)
Иерархия руководителей.
SBardashov Дата: Четверг, 13.10.2016, 13:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!

Помогите решить задачу. Есть таблица с сотрудниками, у каждого сотрудника есть руководитель, у руководителя свой руководитель, нужно определить конечного руководителя для каждого сотрудника.
К сообщению приложен файл: 0432484.xlsx(9Kb)
 
Ответить
СообщениеДобрый день!

Помогите решить задачу. Есть таблица с сотрудниками, у каждого сотрудника есть руководитель, у руководителя свой руководитель, нужно определить конечного руководителя для каждого сотрудника.

Автор - SBardashov
Дата добавления - 13.10.2016 в 13:49
Pelena Дата: Четверг, 13.10.2016, 14:40 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9889
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Дык, Медведев у всех :D


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДык, Медведев у всех :D

Автор - Pelena
Дата добавления - 13.10.2016 в 14:40
Светлый Дата: Четверг, 13.10.2016, 14:51 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 56 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
Вот такая формула проверит 5 уровней вложенности:
Код
=ЕСЛИ(СЧЁТЕСЛИ(A:A;B2)=0;"1-"&B2;ЕСЛИ(СЧЁТЕСЛИ(A:A;ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A)))=0;"2-"&ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));ЕСЛИ(СЧЁТЕСЛИ(A:A;ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));A:A)))=0;"3-"&ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));A:A));ЕСЛИ(СЧЁТЕСЛИ(A:A;ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));A:A));A:A)))=0;"4-"&ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));A:A));A:A));ЕСЛИ(СЧЁТЕСЛИ(A:A;ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));A:A));A:A));A:A)))=0;"5-"&ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));A:A));A:A));A:A));0)))))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Вот такая формула проверит 5 уровней вложенности:
Код
=ЕСЛИ(СЧЁТЕСЛИ(A:A;B2)=0;"1-"&B2;ЕСЛИ(СЧЁТЕСЛИ(A:A;ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A)))=0;"2-"&ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));ЕСЛИ(СЧЁТЕСЛИ(A:A;ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));A:A)))=0;"3-"&ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));A:A));ЕСЛИ(СЧЁТЕСЛИ(A:A;ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));A:A));A:A)))=0;"4-"&ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));A:A));A:A));ЕСЛИ(СЧЁТЕСЛИ(A:A;ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));A:A));A:A));A:A)))=0;"5-"&ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(ИНДЕКС(B:B;ПОИСКПОЗ(B2;A:A));A:A));A:A));A:A));0)))))

Автор - Светлый
Дата добавления - 13.10.2016 в 14:51
buchlotnik Дата: Четверг, 13.10.2016, 15:04 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениекросс на планете

Автор - buchlotnik
Дата добавления - 13.10.2016 в 15:04
_Boroda_ Дата: Четверг, 13.10.2016, 15:54 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9380
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант на 5 вложений
Код
=ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2);A:B;2;);ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2));A:B;2;);ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2);A:B;2;); ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2)));A:B;2;);ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2);A:B;2;);ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2));A:B;2;);ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР( B2;A:B;2;);B2);A:B;2;);ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2))))
К сообщению приложен файл: 0432484_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант на 5 вложений
Код
=ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2);A:B;2;);ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2));A:B;2;);ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2);A:B;2;); ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2)));A:B;2;);ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2);A:B;2;);ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2));A:B;2;);ЕСЛИОШИБКА(ВПР(ЕСЛИОШИБКА(ВПР( B2;A:B;2;);B2);A:B;2;);ЕСЛИОШИБКА(ВПР(B2;A:B;2;);B2))))

Автор - _Boroda_
Дата добавления - 13.10.2016 в 15:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Иерархия руководителей. (Иное/Other)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!