Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение 2 таблиц с формулой если/то - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение 2 таблиц с формулой если/то (Формулы/Formulas)
Сравнение 2 таблиц с формулой если/то
Зарина Дата: Четверг, 13.10.2016, 14:50 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Есть файлик, 3 листа с кодами которым нужно присвоить наименование.
В том же файле 4 лист - СПР, в котором это название присутствует.
Нужно сделать так, если на 1, 2, 3 листах колонки КФО, Счет бюджетного учета и КОСГУ совпадают с листом СПР то присвоить наименование из листа СПР.
Можно сделать для каждого из 3 листов отдельную формулу
К сообщению приложен файл: 1068582.xls(22Kb)


Сообщение отредактировал Зарина - Четверг, 13.10.2016, 14:50
 
Ответить
СообщениеДобрый день!
Есть файлик, 3 листа с кодами которым нужно присвоить наименование.
В том же файле 4 лист - СПР, в котором это название присутствует.
Нужно сделать так, если на 1, 2, 3 листах колонки КФО, Счет бюджетного учета и КОСГУ совпадают с листом СПР то присвоить наименование из листа СПР.
Можно сделать для каждого из 3 листов отдельную формулу

Автор - Зарина
Дата добавления - 13.10.2016 в 14:50
_Boroda_ Дата: Четверг, 13.10.2016, 14:56 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(C2=спр!A$3:A$9)/(D2=спр!B$3:B$9)/(E2=спр!$C2:$C8);спр!D$3:D$9);"")
К сообщению приложен файл: 1068582_1.xls(34Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(C2=спр!A$3:A$9)/(D2=спр!B$3:B$9)/(E2=спр!$C2:$C8);спр!D$3:D$9);"")

Автор - _Boroda_
Дата добавления - 13.10.2016 в 14:56
Зарина Дата: Четверг, 13.10.2016, 14:59 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
АГА
 
Ответить
СообщениеАГА

Автор - Зарина
Дата добавления - 13.10.2016 в 14:59
Зарина Дата: Четверг, 13.10.2016, 15:05 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
А можно еще расчет для 2 страницы?
 
Ответить
СообщениеА можно еще расчет для 2 страницы?

Автор - Зарина
Дата добавления - 13.10.2016 в 15:05
_Boroda_ Дата: Четверг, 13.10.2016, 15:18 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Чуть переписал
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(-C2=-спр!$A$3:$A$9)/(-D2=-спр!$B$3:$B$9)/(-E2=-спр!$C$3:$C$9);спр!$D$3:$D$9);"")&""
К сообщению приложен файл: 1068582_2.xls(36Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЧуть переписал
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(-C2=-спр!$A$3:$A$9)/(-D2=-спр!$B$3:$B$9)/(-E2=-спр!$C$3:$C$9);спр!$D$3:$D$9);"")&""

Автор - _Boroda_
Дата добавления - 13.10.2016 в 15:18
Зарина Дата: Четверг, 13.10.2016, 15:28 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо огромное!
 
Ответить
СообщениеСпасибо огромное!

Автор - Зарина
Дата добавления - 13.10.2016 в 15:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение 2 таблиц с формулой если/то (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!