Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Протяжка формулы с изменением шага в значении - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Протяжка формулы с изменением шага в значении (Формулы/Formulas)
Протяжка формулы с изменением шага в значении
machka Дата: Понедельник, 24.10.2016, 10:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Здравствуйте!
Есть № нити С1, D1, E1, F1, С3, D3, E3, F3 и есть их символы С2, D2, E2, F2, С4, D4, E4, F4.
Во второй таблице вручную записываются номера ниток, чтоб в третьей отобразились их символы.
Итак, в 3-й таблице есть формула:
Код
=ЕСЛИ(C20=150;C2;ЕСЛИ(C20=151;D2;ЕСЛИ(C20=152;E2;ЕСЛИ(C20=154;F2))))

Если ее протянуть по строке, то в ней должно измениться лишь выражение С20 на D20, E20, F20 и т.д.
Если протянуть по столбцу, то в ней должны измениться:
1) выражение С20 на С21, С22, С23 и т.д. с соответствующим этому выражению номером ниток;
2) значение с шагом С4, С6, С8 и т.д. (меняется символ)
То есть, формула должна иметь следующий вид:
Код
=ЕСЛИ(C21=400;C4;ЕСЛИ(C21=402;D4;ЕСЛИ(C21=407;E4;ЕСЛИ(C21=414;F4))))

Помогите, пожалуйста разобраться!
К сообщению приложен файл: 4578990.xlsx(12Kb)


Сообщение отредактировал Manyasha - Понедельник, 24.10.2016, 10:54
 
Ответить
СообщениеЗдравствуйте!
Есть № нити С1, D1, E1, F1, С3, D3, E3, F3 и есть их символы С2, D2, E2, F2, С4, D4, E4, F4.
Во второй таблице вручную записываются номера ниток, чтоб в третьей отобразились их символы.
Итак, в 3-й таблице есть формула:
Код
=ЕСЛИ(C20=150;C2;ЕСЛИ(C20=151;D2;ЕСЛИ(C20=152;E2;ЕСЛИ(C20=154;F2))))

Если ее протянуть по строке, то в ней должно измениться лишь выражение С20 на D20, E20, F20 и т.д.
Если протянуть по столбцу, то в ней должны измениться:
1) выражение С20 на С21, С22, С23 и т.д. с соответствующим этому выражению номером ниток;
2) значение с шагом С4, С6, С8 и т.д. (меняется символ)
То есть, формула должна иметь следующий вид:
Код
=ЕСЛИ(C21=400;C4;ЕСЛИ(C21=402;D4;ЕСЛИ(C21=407;E4;ЕСЛИ(C21=414;F4))))

Помогите, пожалуйста разобраться!

Автор - machka
Дата добавления - 24.10.2016 в 10:40
Michael_S Дата: Понедельник, 24.10.2016, 11:01 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
Добрый день!
Так надо?
К сообщению приложен файл: 3985593.xlsx(12Kb)


ЯД: 41001136675053
WM: R389613894253
 
Ответить
СообщениеДобрый день!
Так надо?

Автор - Michael_S
Дата добавления - 24.10.2016 в 11:01
_Boroda_ Дата: Понедельник, 24.10.2016, 11:04 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Чет я торможу, ну ладно, что вышло, то вышло
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС($C$2:$F$16;ПОИСКПОЗ($B20;$B$1:$B$15;););ПОИСКПОЗ(C20;ИНДЕКС($C$1:$F$15;ПОИСКПОЗ($B20;$B$1:$B$15;););));"")
К сообщению приложен файл: 4578990_1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЧет я торможу, ну ладно, что вышло, то вышло
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС($C$2:$F$16;ПОИСКПОЗ($B20;$B$1:$B$15;););ПОИСКПОЗ(C20;ИНДЕКС($C$1:$F$15;ПОИСКПОЗ($B20;$B$1:$B$15;););));"")

Автор - _Boroda_
Дата добавления - 24.10.2016 в 11:04
SLAVICK Дата: Понедельник, 24.10.2016, 11:11 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1834
Репутация: 613 ±
Замечаний: 0% ±

2007,2010,2013,2016
Можно так:
Код
=ИНДЕКС($A$1:$F$16;МАКС(ЕСЛИ($C$1:$F$16=C20;СТРОКА($C$1:$F$16);0))+1;МАКС(ЕСЛИ($C$1:$F$16=C20;СТОЛБЕЦ($C$1:$F$16);0)))
К сообщению приложен файл: 9129789.xlsx(13Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеМожно так:
Код
=ИНДЕКС($A$1:$F$16;МАКС(ЕСЛИ($C$1:$F$16=C20;СТРОКА($C$1:$F$16);0))+1;МАКС(ЕСЛИ($C$1:$F$16=C20;СТОЛБЕЦ($C$1:$F$16);0)))

Автор - SLAVICK
Дата добавления - 24.10.2016 в 11:11
китин Дата: Понедельник, 24.10.2016, 11:11 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так надо?
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС(C$1:F$16;ПОИСКПОЗ($B20;$B$1:$B$16;0)+1;);;ПОИСКПОЗ(C20;$C20:$F20;0));"")
К сообщению приложен файл: 1111111.xlsx(12Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 24.10.2016, 11:12
 
Ответить
Сообщениетак надо?
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС(C$1:F$16;ПОИСКПОЗ($B20;$B$1:$B$16;0)+1;);;ПОИСКПОЗ(C20;$C20:$F20;0));"")

Автор - китин
Дата добавления - 24.10.2016 в 11:11
Michael_S Дата: Понедельник, 24.10.2016, 11:12 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
что вышло, то вышло
Я тоже сначала еслиошибка хотел использовать :)


ЯД: 41001136675053
WM: R389613894253
 
Ответить
Сообщение
что вышло, то вышло
Я тоже сначала еслиошибка хотел использовать :)

Автор - Michael_S
Дата добавления - 24.10.2016 в 11:12
_Boroda_ Дата: Понедельник, 24.10.2016, 11:32 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вот так мне больше нравится
Форум формулу не берет
Смотрите в файле
Вот так если - вместо буквы "я" нужно написать u в квадратике (или z)
Код
=ЕСЛИ(C20;ПРАВБ(ПРОСМОТР(C20&"я";ИНДЕКС($C$1:$F$15&$C$2:$F$16;ПОИСКПОЗ($B20;$B$1:$B$15;);)));"")

Или вот так
Код
=ЕСЛИ(C20;ПРАВБ(ПРОСМОТР(C20&"龜";ИНДЕКС($C$1:$F$15&$C$2:$F$16;ПОИСКПОЗ($B20;$B$1:$B$15;);)));"")
К сообщению приложен файл: 4578990_2.xlsx(13Kb) · 4578990_3.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВот так мне больше нравится
Форум формулу не берет
Смотрите в файле
Вот так если - вместо буквы "я" нужно написать u в квадратике (или z)
Код
=ЕСЛИ(C20;ПРАВБ(ПРОСМОТР(C20&"я";ИНДЕКС($C$1:$F$15&$C$2:$F$16;ПОИСКПОЗ($B20;$B$1:$B$15;);)));"")

Или вот так
Код
=ЕСЛИ(C20;ПРАВБ(ПРОСМОТР(C20&"龜";ИНДЕКС($C$1:$F$15&$C$2:$F$16;ПОИСКПОЗ($B20;$B$1:$B$15;);)));"")

Автор - _Boroda_
Дата добавления - 24.10.2016 в 11:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Протяжка формулы с изменением шага в значении (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!