Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Пропорция - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Пропорция (Формулы/Formulas)
Пропорция
roman66rus Дата: Четверг, 27.10.2016, 20:37 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: 0 ±
Замечаний: 20% ±

2010
Доброго времени суток. Помогите решить задачку.
Есть параметр Х, который зависит от А,Б,В. Идея в том, чтобы примерно спрогнозировать параметр Х в "калькуляторе" задавая предположительные а,б,в. Т.Е. нужно, что-то типа пропорции которая бы анализировала статистику предыдущих данных и на основании этого давала примерный результат. Шаг Х = 0,14 , идеальное значение 4,62. Предсказываемый х должен реагировать на изменение всех трех параметров а,б,в . Попробовал ПРЕДСКАЗ, но че-то не понимаю как она работает. Как прописать формулой : Если а увеличивается при б,в постоянном - х уменьшается; Если а уменьшается при б,в постоянном - х увеличивается; Если а,в постоянные б уменьшается или увеличивается, то х - соответственно; Если а,в уменьшается, б увеличивается, то х-увеличивается и наоборот. Должно ХАБВ примерно равняться абвх.
К сообщению приложен файл: qwe.xls(52Kb)
 
Ответить
СообщениеДоброго времени суток. Помогите решить задачку.
Есть параметр Х, который зависит от А,Б,В. Идея в том, чтобы примерно спрогнозировать параметр Х в "калькуляторе" задавая предположительные а,б,в. Т.Е. нужно, что-то типа пропорции которая бы анализировала статистику предыдущих данных и на основании этого давала примерный результат. Шаг Х = 0,14 , идеальное значение 4,62. Предсказываемый х должен реагировать на изменение всех трех параметров а,б,в . Попробовал ПРЕДСКАЗ, но че-то не понимаю как она работает. Как прописать формулой : Если а увеличивается при б,в постоянном - х уменьшается; Если а уменьшается при б,в постоянном - х увеличивается; Если а,в постоянные б уменьшается или увеличивается, то х - соответственно; Если а,в уменьшается, б увеличивается, то х-увеличивается и наоборот. Должно ХАБВ примерно равняться абвх.

Автор - roman66rus
Дата добавления - 27.10.2016 в 20:37
roman66rus Дата: Вторник, 01.11.2016, 13:04 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: 0 ±
Замечаний: 20% ±

2010
Доброго времени суток.
Нашел похожую тему My WebPage.
И вот, что получилось.
На Лист1 в столбцах D,E вилка значений, Лист2 средние значения основываясь на статистики за 2016г, 2016- соответственно статистика.
Никак не могу додуматься как сделать, чтоб уже внесенные данные не менялись при вводе новой вилки.
Да данные берутся с Лист2, а они расчитываются по последней строке, но все же может у кого появятся какие нибудь варианты?
И еще когда в статистики нет данных нужно, чтоб выдавал приблизительный результат.
К сообщению приложен файл: CaO-2017-.rar(90Kb)


Сообщение отредактировал roman66rus - Вторник, 01.11.2016, 13:05
 
Ответить
СообщениеДоброго времени суток.
Нашел похожую тему My WebPage.
И вот, что получилось.
На Лист1 в столбцах D,E вилка значений, Лист2 средние значения основываясь на статистики за 2016г, 2016- соответственно статистика.
Никак не могу додуматься как сделать, чтоб уже внесенные данные не менялись при вводе новой вилки.
Да данные берутся с Лист2, а они расчитываются по последней строке, но все же может у кого появятся какие нибудь варианты?
И еще когда в статистики нет данных нужно, чтоб выдавал приблизительный результат.

Автор - roman66rus
Дата добавления - 01.11.2016 в 13:04
MCH Дата: Вторник, 01.11.2016, 14:17 | Сообщение № 3
Группа: Админы
Ранг: Старожил
Сообщений: 1755
Репутация: 665 ±
Замечаний: ±

Есть такая функция: ТЕНДЕНЦИЯ(), которая производит линейную аппроксимацию по нескольким факторам
Применительно к первому файлу ее можно записать:
Код
=ТЕНДЕНЦИЯ($B$4:$B$26;$E$4:$G$26;I4:K4)


Но, оценивая коэффициент детерминированности R2, с помощью функции ЛИНЕЙН():
Код
=ИНДЕКС(ЛИНЕЙН(B4:B26;E4:G26;;ИСТИНА);3;2)

Получаем R2 = 0,467466098399216
Низкая достоверность модели, на практике лучше не применять полученные результаты вычисления по данной формуле
 
Ответить
СообщениеЕсть такая функция: ТЕНДЕНЦИЯ(), которая производит линейную аппроксимацию по нескольким факторам
Применительно к первому файлу ее можно записать:
Код
=ТЕНДЕНЦИЯ($B$4:$B$26;$E$4:$G$26;I4:K4)


Но, оценивая коэффициент детерминированности R2, с помощью функции ЛИНЕЙН():
Код
=ИНДЕКС(ЛИНЕЙН(B4:B26;E4:G26;;ИСТИНА);3;2)

Получаем R2 = 0,467466098399216
Низкая достоверность модели, на практике лучше не применять полученные результаты вычисления по данной формуле

Автор - MCH
Дата добавления - 01.11.2016 в 14:17
roman66rus Дата: Вторник, 01.11.2016, 15:15 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: 0 ±
Замечаний: 20% ±

2010
В первом файле я пытался упростить и сократить, чтобы не архивить.
Второй файл почти рабочий вариант. В столбце M хочется видеть предположительное значение на основании статистики за предыдущий год.
 
Ответить
СообщениеВ первом файле я пытался упростить и сократить, чтобы не архивить.
Второй файл почти рабочий вариант. В столбце M хочется видеть предположительное значение на основании статистики за предыдущий год.

Автор - roman66rus
Дата добавления - 01.11.2016 в 15:15
MCH Дата: Вторник, 01.11.2016, 15:41 | Сообщение № 5
Группа: Админы
Ранг: Старожил
Сообщений: 1755
Репутация: 665 ±
Замечаний: ±

Поменял столбцы K и L местами,
Формула на основе функции ТЕНДЕНЦИЯ() в столбце M
К сообщению приложен файл: CaO-2017-.xlsx(60Kb)
 
Ответить
СообщениеПоменял столбцы K и L местами,
Формула на основе функции ТЕНДЕНЦИЯ() в столбце M

Автор - MCH
Дата добавления - 01.11.2016 в 15:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Пропорция (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!