Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула суммирования с учетом критерия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула суммирования с учетом критерия (Формулы/Formulas)
Формула суммирования с учетом критерия
IvanK0 Дата: Четверг, 27.10.2016, 23:19 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Необходимо сложить инструмент, выданный рабочим, с учетом их применяемости на объекте. Заранее спасибо.
К сообщению приложен файл: 6063000.xlsx(10Kb)
 
Ответить
СообщениеНеобходимо сложить инструмент, выданный рабочим, с учетом их применяемости на объекте. Заранее спасибо.

Автор - IvanK0
Дата добавления - 27.10.2016 в 23:19
buchlotnik Дата: Четверг, 27.10.2016, 23:34 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
и вам здрасьте.
В ячейке сколько максимально инструментов? И что с рабочим №3 - две применяемости на три наименования


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеи вам здрасьте.
В ячейке сколько максимально инструментов? И что с рабочим №3 - две применяемости на три наименования

Автор - buchlotnik
Дата добавления - 27.10.2016 в 23:34
Wasilich Дата: Четверг, 27.10.2016, 23:44 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 855
Репутация: 220 ±
Замечаний: 0% ±

2003
Да уж, с такой организацией таблицы вряд ли что выкрутишь. :)
Думаю, для каждого инструмента и его применяемости нужна отдельная строка.
 
Ответить
СообщениеДа уж, с такой организацией таблицы вряд ли что выкрутишь. :)
Думаю, для каждого инструмента и его применяемости нужна отдельная строка.

Автор - Wasilich
Дата добавления - 27.10.2016 в 23:44
IvanK0 Дата: Четверг, 27.10.2016, 23:45 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Это просто пример , по факту инструментов может быть больше
К сообщению приложен файл: 4540274.xlsx(10Kb)
 
Ответить
СообщениеЭто просто пример , по факту инструментов может быть больше

Автор - IvanK0
Дата добавления - 27.10.2016 в 23:45
IvanK0 Дата: Четверг, 27.10.2016, 23:51 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Wasilich, к сожалению, такой формат вероятнее всего нам направят, список будет большой , будем разбивать тогда по отдельным строчкам, но это займет достаточно времени. Я разбил файл по строчкам
К сообщению приложен файл: 7720987.xlsx(10Kb)
 
Ответить
СообщениеWasilich, к сожалению, такой формат вероятнее всего нам направят, список будет большой , будем разбивать тогда по отдельным строчкам, но это займет достаточно времени. Я разбил файл по строчкам

Автор - IvanK0
Дата добавления - 27.10.2016 в 23:51
buchlotnik Дата: Пятница, 28.10.2016, 00:02 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
IvanK0, если разбить на строчки и УБРАТЬ лишние пробелы - идеально ложится сводная таблица
а вот по первоначальному варианту - намонстрячил на формулах с допстолбцами (см второй файл)
инструмент
Код
=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ($B2);" ";ПОВТОР(" ";99));1+99*(СТОЛБЕЦ(A1)-1);99))
применяемость
Код
=ЕСЛИОШИБКА(--СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ($C2);" ";ПОВТОР(" ";99));1+99*(СТОЛБЕЦ(A1)-1);99));0)
ну и сумма
Код
=СУММЕСЛИ($D$2:$G$5;A10;$H$2:$K$5)


UPD файл перезалил
К сообщению приложен файл: 7720987-1-.xlsx(13Kb) · 4540274-1-.xlsx(11Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 28.10.2016, 00:19
 
Ответить
СообщениеIvanK0, если разбить на строчки и УБРАТЬ лишние пробелы - идеально ложится сводная таблица
а вот по первоначальному варианту - намонстрячил на формулах с допстолбцами (см второй файл)
инструмент
Код
=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ($B2);" ";ПОВТОР(" ";99));1+99*(СТОЛБЕЦ(A1)-1);99))
применяемость
Код
=ЕСЛИОШИБКА(--СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ($C2);" ";ПОВТОР(" ";99));1+99*(СТОЛБЕЦ(A1)-1);99));0)
ну и сумма
Код
=СУММЕСЛИ($D$2:$G$5;A10;$H$2:$K$5)


UPD файл перезалил

Автор - buchlotnik
Дата добавления - 28.10.2016 в 00:02
IvanK0 Дата: Пятница, 28.10.2016, 00:16 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
buchlotnik, спасибо.
 
Ответить
Сообщениеbuchlotnik, спасибо.

Автор - IvanK0
Дата добавления - 28.10.2016 в 00:16
Wasilich Дата: Пятница, 28.10.2016, 00:29 | Сообщение № 8
Группа: Друзья
Ранг: Ветеран
Сообщений: 855
Репутация: 220 ±
Замечаний: 0% ±

2003
Ну так проще если такой вид таблицы. Однако, наименования должны совпадать идеально, либо искать другой вариант.
К сообщению приложен файл: IvanK0.xls(28Kb)
 
Ответить
СообщениеНу так проще если такой вид таблицы. Однако, наименования должны совпадать идеально, либо искать другой вариант.

Автор - Wasilich
Дата добавления - 28.10.2016 в 00:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула суммирования с учетом критерия (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!